2 Incidencia Tras Optimización SEO  

Página 1 / 3
 
José Luis
 José Luis
Reputable Member

Buenas noches:
Tras seguir la Excelente aportación en el Blog para la correcta optimización del SEO en la Pagina Web, me encontrado con Dos Incidencias.
Paso a Exponer la Segunda:

Tras seguir las indicaciones y configurar todos los parámetros que se indican, mi Pagina Web muestra unos fallos en diversos apartados que no tienen explicación, ya que no se han modificado, ni Categorías, ni Artículos, no obstante en varios Sub-menús tengo el siguiente error, del cual adjunto una captura,

Se agradecería alguna sugerencia para solucionar esta desagradable situación.
Un saludo.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 13/08/2013 8:36 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola José Luis,

Pon algunos ejemplos de url de tu web que estén fallando, ya que la captura de por si solo nos indica que tenes errores 404 derivados de enlaces rotos o alguna configuración incorercta.

He navegador por varios ítems de tu web y de momento no he tenido ningun 404.

¿Usas alguna extensión SEO/SEF independiente de la nativa de Joomla?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/08/2013 9:30 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

José Luis
 José Luis
Reputable Member

Buenas Noches Luis.

Te comento:

No utilizo ninguna extensión SEO independiente.

Intenta visualizar:
http://www.castillodesaitai.es/album/fotos-tabatha
http://www.castillodesaitai.es/nuestros-basset-hound/machos/bourbon/pedigree-de-bourbon

Te saldrá la pantalla que he reportado y, algunos mas Items tienen el mismo fallo.

Un saludo.

José Luis

ResponderCitar
Respondido : 13/08/2013 9:36 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola José Luis,

Consulto otros enlaces similares y veo que si cargan:

- http://www.castillodesaitai.es/album/fotos-kuka

Sin embargo los que citas no ¿los artículos entiendo que si existen, los que fallan, correcto?.

Si desactivas las urls amigables en la Configuración Global, ¿siguen fallando esos mismos artículos?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/08/2013 9:41 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

José Luis
 José Luis
Reputable Member

Hola Luis.

Los Artículos...existen de hecho funcionaban correctamente antes de modificar los parámetros SEO.

He desactivado las urls amigables en la Configuración Global, tal como me has comentado y los fallos 404 han desaparecido, con lo cual entiendo que el problema es la activación de las urls amigables. Posible solución para poder utilizar las urls amigables sin errores??

Igualmente existe otro error, por el cual había abierto otro hilo...pero no aparece en "Mis Temas".

Un saludo.

José Luis

ResponderCitar
Respondido : 13/08/2013 10:04 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola José Luis,

Bueno, la solución no es prescindir de las urls amigables, sino averiguar porque sucede.

¿Tu archivo htaccess es el que viene por defecto, es otro, cual?

Te recomendamos usar nuestro .htaccess que encontrarás en este post: https://www.webempresa.com/foro/6-Joomla-15/2541-Url-Amigables.html#2543

Este archivo lo localizas en la carpeta de su Hosting /public_html normalmente renombrado como .htaccess o como htaccess.txt, también es posible encontrarlo en /public_html/administrator

Te facilitamos un enlace a un artículo de nuestro Blog donde explicamos algunos detalles de funcionalidad de dicho archivo.

- Códigos útiles .htaccess para sitios web: https://www.webempresa.com/blog/codigos-utiles-htaccess-para-wordpress.html

Te puede interesar este vídeo de ayuda que realizamos sobre Joomla! y SEO: https://www.webempresa.com/videos/seo-2/seo-2.html

Tienes que tener en cuenta que para que tu web se posicione correctamente en buscadores tienes que realizar los siguientes pasos:

1º Introducir una descripción y palabras claves adecuadas en tu Joomla, tanto en la configuración general como en los artículos que quieras afinar su posicionamiento.
2º Activar el SEO de Joomla! para que tus url's sean amigables.
3º Utilizar una herramienta como por ejemplo XMAP que crean un mapa del sitio y un sitemap para Google que tendrás que dar de alta en las Herramientas para Webmaster de Google.
4º Modificar los títulos de los menús y artículos para que contengan las palabras claves que te interesen, utiliza el alias para definir url's con las palabras clave más importantes.
5º Conseguir links de webs con Page Rank alto hacia tu sitio.
6º Modificar los contenidos de tu web para que contengan las palabras claves que te interesen.

Realizando estos pasos conseguirás aumentar considerablemente el posicionamiento en Google y otros buscadores.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/08/2013 10:23 pm

Cursos Gratuitos WordPress

José Luis
 José Luis
Reputable Member

Hola Luis.

Muchas gracias por tu colaboración.

En cierta medida....ya he realizado prácticamente lo que me aconsejas, ya que soy un asiduo lector de vuestro Blog.

Voy a repasar Tus indicaciones.

Muchas gracias

José Luis.

ResponderCitar
Respondido : 13/08/2013 10:30 pm
José Luis
 José Luis
Reputable Member

Buenas Tardes Luis.

He seguido al pie de la letra tus indicaciones y he cargado el archivo .htaccess que me has reportado, no obstante, si activo las Urls Amigables....volvemos a tener los mismos fallos que te comentaba al principio, igualmente me he leído todos los hilos sobre este tema y todos se basan en dicho fichero.

Con lo cual, si Yo ya he cargado el fichero .htaccess y tengo error, solo me cabe la posible solución que el fallo se deba en el servidor o que el fichero en cuestión...tenga algún parámetro erróneo.

Evidentemente y para no afectar a la web, las Urls Amigables las tengo desactivadas.

Un saludo.

ResponderCitar
Respondido : 14/08/2013 3:49 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola José

Revisa el siguiente video : https://www.webempresa.com/blog/item/317-urls-amigables-en-joomla.html

Asegúrate también de que tu archivo .htaccess tiene contenido, si no tienes contenido en este archivo deberás buscar y renombrar el archivo htaccess.txt a .htaccess

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/08/2013 4:44 pm
José Luis
 José Luis
Reputable Member

Buenas tardes Jhon.

Gracias por tu aportación...pero ya me he visto varios vídeos sobre el tema y a priori..ya están realizadas las acciones que me comentas, de hecho..he cargado un fichero que me ha reportado Luis y, efectivamente, tiene contenido....pero el resultado es el mismo...si están activadas las urls amigables...tengo errores.

De hecho en Google WebMaster me salen dos errores de index.php

Un saludo.

ResponderCitar
Respondido : 14/08/2013 5:39 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola José

Puedes enviar algunas capturas de pantalla de la configuración de las urls amigables?

Verifica los permisos de tu archivo .htaccess deben ser 644

Verifica si tienes actualizaciones de tu Joomla.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/08/2013 6:33 pm
José Luis
 José Luis
Reputable Member

Buenas noches Jhon.

Te respondo:
Efectivamente los permisos son 644
Te adjunto una captura de la configuración:

Te adjunto una Captura de las actualizaciones pendientes:

Estas actualizaciones...siempre dan el error= "

Tipo de archivo desconocido
La ruta de actualización no existe

Ya me aclaras como hacer las Urls amigables...
Un saludo.

ResponderCitar
Respondido : 14/08/2013 7:54 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

José Luis
 José Luis
Reputable Member

Jhon:

Te adjunto los parámetros del fichero en cuestión:
##
# @version $Id: htaccess.txt 10492 2008-07-02 06:38:28Z ircmaxell $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##

#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR]
# Block out any script that includes a tag in URL
RewriteCond %{QUERY_STRING} (|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

# RewriteBase /

########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|.php|.html|.htm|.feed|.pdf|.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section

Un saludo.

ResponderCitar
Respondido : 14/08/2013 7:57 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Jose

Activa las urls amigables en tu pantalla ya que entiendo que la captura lo has hecho cuando lo tenias en No amigables.

Luego limpia la cache de tu sitio web.

Has realizado recientemente alguna configuración o instalación de extensiones?

Veo que tienes una extensión de seguridad para no hacer click con el botón alterno del mouse, desactiva esta extensión u otras que hayas instalado recientemente, especialmente si tienen funcionalidad del sistema o seguridad o urls amigables.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/08/2013 8:38 pm

Cursos Gratuitos WordPress

José Luis
 José Luis
Reputable Member

Hola Jhon.

He realizado lo que mes has comentado y... no es la solución, ya que desactivando el pluning que comentas y realizando las demás acciones, si activo las urls amigables de dan fallo. Lo curioso es que hay apartados de la Pagina que si funciona y en cambio en otros sale el error, con lo cual creo que si fuera por un pluning o extensión concreta...o funcionan todos los Apartados o No funciona ninguno.
Evidentemente...para evitar dichos fallos tengo las urls amigables desactivadas, con lo cual cuando te mande la captura...se reflejaba que no estaban activadas..

Un saludo.

ResponderCitar
Respondido : 15/08/2013 8:56 am
Página 1 / 3

Por favor Iniciar Sesión o Registro