Componente Sh404sef  

 
Enrique
 Enrique
Famed Member

Buenos días,

Estoy utilizando el componente sh404sef, al activarlo me han desaparecido 5 módulos del Inicio.

Los 5 módulos son del tipo "Personalizar html".

Como lo puedo evitar?

Un saludo, Enrique P.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 31/03/2014 12:17 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Personalmente no recomiendo utilizar ningún componente de SEO, incluido el sh404SEF, ya que suelen generar bastantes problemas inesperados como el que comentas, y que pueden ser muy complicados de resolver. El propio sistema de urls amigables que incorpora Joomla por defecto es suficientemente bueno.

En tu caso, si han desaparecido módulos de la página de inicio (supongo que todos los que había) se debe a que se ha perdido la referencia entre el elemento de menú de la página de inicio y los módulos, de forma que el sh404SEF interfiera en ello. Tendrías que probar a editar los módulos y verificar que tienes la asignación adecuada al elemento de menú de la página de inicio, no sea que hayas creado un nuevo elemento de menú para la página de inicio y por eso te haya desaparecido.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/03/2014 3:01 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Famed Member

Buenas tardes Pablo,

Es necesario hacerlo para que desaparezca la palabra "item" que te pone el componente k2 en la url, los módulos desaparecen cuando habilito el parámetro "habilitar optimización de url" .

Hay alguna otra forma para eliminar el item de k2 de la url sin tener que utilizar componentes para SEO?, o alguna forma para que me aparezcan los módulos del Inicio?

Te adjunto el componente?

Un saludo, Enrique P.

ResponderCitar
Respondido : 31/03/2014 5:00 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Enrique

En los parámetros de k2 , en el tab de avanzados, sección SEO, Enable advanced SEF for K2 URL, prueba habilitando esta opción

Esto se discute en : http://forum.joomla.org/viewtopic.php?f=618&t=680373

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/03/2014 10:51 pm

Cursos Gratuitos WordPress

Enrique
 Enrique
Famed Member

Buenos días Jhon,

En los parámetros de k2 no me aparece esa opción, te adjunto una imagen.

Hay que instalar algún plugin?, he estado leyendo en el foro y tiene dos repuestas, la que tu me das y crear otro menú...

La que tu me das es mejor para el que tenga más artículos.

Un saludo, Enrique P.

ResponderCitar
Respondido : 01/04/2014 10:38 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Enrique,

Puedes probar en:

a "jugar" con los parámetros:
Insert Item id in URL
Unique ID

Para ver si se resuelve el problema.
Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 01/04/2014 11:25 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Enrique
 Enrique
Famed Member

Buenos días Jordi,

Tampoco, solo me aparecen los módulos si deshabilito la opción de "optimizar url" que es la opción que me quita la cadena de texto "item" que me crea k2.

Un saludo, Enrique P.

ResponderCitar
Respondido : 01/04/2014 12:51 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Enrique,

He actualizado a la última versión de K2 en un Joomla! 2.5, y me aparece ahora:
Enable advanced SEF for K2 URLs.

Entonces ya sirven soluciones del tipo http://chandank.com/cms/joomla/remove-item-from-k2-joomla y http://www.pixelfire.com.au/website-and-graphic-design-blog/item/122-how-to-remove-item-and-item-id-from-a-k2-url

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 01/04/2014 1:19 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Enrique
 Enrique
Famed Member

Buenas tardes Jordi,

Acabo de actualizar a la última versión de k2, he configurado los parámetros de k2 tal y como ponen en las dos url que me has pasado, menos el código que hay que añadir para el botón "leer más" que no entiendo muy bien lo que hay que hacer.

Ahora si haces click sobre cualquier artículo, te da un error 404, porque?

Un saludo, Enrique P.

ResponderCitar
Respondido : 01/04/2014 2:06 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

He probado a entrar en un artículo de K2 y el error que me da no es 404, sino 403, es decir, se trata de un error de permisos de acceso.

Es posible que pueda estar causado por este parámetro, pero para saberlo tendrías que probar a desactivarlo y ver si así desaparece el error.

Las pruebas las he realizado en la siguiente página que muestra enlaces a artículos, que entiendo que son artículos de K2:

Contenido solo visible a usuarios registrados

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/04/2014 5:20 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Famed Member

Buenas tardes Pablo,

Ya he desinstalado el componente sh404sef y me sigue apareciendo el mismo error. Eso aparece a partir de la actualización que he realizado de k2.

Un saludo, Enrique P.

ResponderCitar
Respondido : 01/04/2014 9:18 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Realiza la prueba si desactivando las urls amigables por lo menos permite el acceso a las paginas web.

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/04/2014 6:22 am

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro