Con cada actualizacion Joomla pierdo el sitio  

 
daber
 daber
Estimable Member

Vengo de la version 1.7.2 y desde que actualicé a la 2.5.0 me viene ocurriendo siempre lo mismo. Error, vuelta atras a la 1.7.2 y al querer actualizar de nuevo se pierde la web.
Me ha ocurrido con la 2.51, 2.5.2, 2.5.3 y ahora con la 2.5.4
Que puedo hacer para que este problema no vuelva a repetirse. ¿Quizás hacer una instalación en limpio de la ultima version y pasar despues los ficheros?
Me gusta estudiar, investigar y resolver los problemas que se me van presentando, pero esto ya resulta bastante cansino.
Saludos.

PD: Recien restaurado, una vez más.

Citar
Respondido : 02/04/2012 9:24 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola daber

Es posible que tengas una extensión que no es 100% compatible con Joomla 2.5

Es posible también que guardes cache de tus extensiones , y al momento de actualizar pueden haber problemas.

Que herramientas estas usando para actualizar?, puedes usar admin tools para la actualización , revisa el siguiente artículo :
https://www.webempresa.com/blog/actualizar-automaticamente-joomla-17-a-la-ultima-version-estable-con-admin-tools.html

No olvides realizar una copia de tu sitio antes de realizar la actualización.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 03/04/2012 1:59 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

daber
 daber
Estimable Member

Vengo actualzando el admintools y despues de restaurar el sitio me ha admitido la actualizacion a la vers 2.5.4, pero se que este problema se va a plantear en la próxima actualización de nuevo. Por eso quisiera saber, por una parte, cómo comprobar que las extensiones instaladas son 100 % compatibles con Joomla 2.5 y por otra, si se arreglaría el problema definitivamente haciendo una instalación en limpio de Joomla 2.5.4.
Porque tambien tengo otra incidencia que ya comenté a gnumax, y es que me crea una nueva línea de version de joomla por cada actualizacion instalada ( ver en la imagen)

ResponderCitar
Respondido : 03/04/2012 7:40 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Daber

Realiza el siguiente proceso y verifica si se soluciona el problema

- Desde el menú sitio=> mantenimiento => Realiza los tres procesos, limpiar cache, purgar cache expirad y desbloqueo global

- Luego en el menú de extensiones => gestor de extensiones => bases de datos => arreglar

- Deslogueate de tu backend y luego ingresa nuevamente

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 03/04/2012 10:08 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

daber
 daber
Estimable Member

Realizado el proceso, la incidencia persiste Jhon.

La estructura de tablas dela base de datos está actualizada.
Otra información

Versión del esquema de la base de datos (en '#__schemas'): 2.5.4-2012-03-19.
Actualizar versión (en #__extensions): 2.5.4.
Controlador de la base de datos: mysqli.
63 cambios en la base de datos se han comprobado correctamente.
23 cambios en la base de datos no han alterado el esquema de las tablas y se han saltado.

ResponderCitar
Respondido : 03/04/2012 10:17 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola daber,

Se me ocurre algo que puedes probar para descartar al menos el tema de que las actualizaciones cada vez te comprometen mas la estabilidad del sitio web, quizás derivado que arrastrar problemas desde 1.7.x o habiendo mezclado diferentes packs en las distintas actualizaciones.

Realiza una instalación (si tienes espacio en tu Hosting) del Pack Joomla! 2.5 (vídeo) y una vez lo hayas hecho, haz una copia de la actual base de datos (desde phpmyadmin exportada) o sea creas una nueva base de datos y le importas la que hayas exportado de tu instalación problemática y los datos de esa ddbb creada y a la que has importado la del sitio problemático añadelos en el configuration de tu "nueva" instalación 2.5.

Ya se que no tendrás las mismas extensiones que en la que has ido migrando, pero es para descartar si el core es el que te da problemas o es fruto de otras extensiones.

No olvides realizar las oportunas copias de seguridad antes de hacer nada.

Hecho esto nos comentas y vemos por donde avanzamos. 😉

Nota: Espero haberme explicado 😀

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 03/04/2012 10:55 pm

Cursos Gratuitos WordPress

daber
 daber
Estimable Member

Confieso que he tenido que leer varias veces el segundo bloque de 5 párrafos :laugh: , pero creo que al final lo he entendido :unsure: .
Mañana, con un poco de tiempo lo intentaré.
Muchas gracias a los dos.

ResponderCitar
Respondido : 03/04/2012 11:13 pm
Jorge
 Jorge
Estimable Member

Aupa buenos díias,

Al hilo de la recomendación en este tema sobre actualizar a través de Admintools, me pregunto si viendo que cada vez que se actualiza utilizando este componente, todo el tema de los idiomas se estropean, no sería mas conveniente utilizar otro medio mas fiable o recomendar otro tipo de actualización?

Lo pregunto porque en las ocasiones que actualicé por este medio siempre me ocasionó ese problema. Desconozco si existe la posibilidad de que este componente sea capaz de detectar el idioma instalado y lo haga en ese mismo idioma

Venga un saludo

ResponderCitar
Respondido : 04/04/2012 9:28 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jorge,

Hay usuarios que prefieren el tema de actualización "automática". Personalmente prefiero no utilizar extensiones, sino en Joomla! 2.5 para actualizar, descargar el parche y realizar la instalación a través del gestor de extensiones de Joomla!.

Respecto al tema de problemas en los idiomas. La mayoría de actualizaciones son de seguridad, y no incorporan cambios en los idiomas, pero en el caso de que no sea así:
- Si el pack es de Joomla.org, al descargar el parche de actualización solo incluye el idioma inglés, por lo que otros idiomas quedan sin actualizar.
- Si el pack es de JoomlaSpanish.org, al descargar el parche de actualización incluye el idioma inglés y el español.

Si hay otros idiomas añadidos en el sitio web, en caso de que sea multi-idioma, entonces hay que instalar los paquetes de idiomas correspondientes a esa versión de Joomla!.

(Antes de realizar cualquier actualización, hay que realizar una copia de seguridad completa del sitio web).

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 04/04/2012 11:49 am
daber
 daber
Estimable Member

Hecha la prueba recomendada por Luis, el nuevo sitio de prueba funciona estupendamente:

Entre una y otra instalacion observo ésta diferencia en el backend:

Parece que no tengo instalado el JAT3 Clean Caché. ¿Pudiera ser ésto?
Lo que tengo instalado es el plugin Caché Cleaner.
Como obtengo (en su caso) el JAT3 y como instalarlo?
Saludos.

PD: Pues parece que no tenia nada que ver. Instalado el JAT3 y desinstalado el Caché Cleaner, todo sigue igual.

ResponderCitar
Respondido : 04/04/2012 4:01 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Daber

Has podido solucionar entonces finalmente tu problema?

El JAT3 es un pluging que da soporte a plantillas, algunas plantillas como de Joomlart utilizan esta extensión para la construcción de sus plantillas.

No es estrictamente necesario tenerlo instalado salvo tengas algún template que lo requiera.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 04/04/2012 5:08 pm
daber
 daber
Estimable Member

No Jhon, todo sigue igual.
Me pregunto que pasaría si remachara Joomla 2.5.4 sobre mi instalación salvo la carpeta instal y la de templates e images? :unsure:

ResponderCitar
Respondido : 04/04/2012 5:13 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola daber,

Personalmente considero que actualizar con Admin Tools es tan legítimo como hacerlo con el Gestor de Actualizaciones nativo en Joomla! 1.7/2.5 y esto lo recomiendan tambien miembros del core de Joomla! así que no es ninguna novedad. No en vano el desarrollador de Admin Tools (Nicholas) colabora estrechamente en el Bug Squad de Joomla! y en la última versión 2.5.4 hay cambios que se han realizado sugeridos por el mismo.

Dicho esto queda claro que tu problema es posible que se derive de una mezcla de packs mientras has ido actualizando, por que si lo haces desde un pack limpio veo que el proceso es válido.

Deshacer lo que has hecho no es posible por lo que no creo que la solución sea seguir aplicando arnica sobre el actual problema.

¿Dispones de una copia de seguridad de cuando tu web AUN NO ESTABA MIGRADA?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 04/04/2012 9:26 pm
daber
 daber
Estimable Member

Asi pienso yo tambien. Más vale una vez "colorao" que 20 amarillo. Tambien llevas razón en que es probable que en 1.7 mezclara algun pack.
Tengo 16 copias de seguridad, pero precisamente hace tiempo borré las anteriores, en la que debía encontrarse la de la vers 1.7
Creo que vpy a hacer una instalacion en limpio de la 2.54 en un subdirectorio e intentar salvar las carpetas images, templates, etc.. Creo que había alguna herramienta para migrar los artículos, pero no se si existe para 2.5.
Iré trabajando poco a poco. Si tienes algún consejo, será bienvenido.
Saludos.

ResponderCitar
Respondido : 04/04/2012 9:49 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola daber,

Sobre lo que comenté de las actualizaciones automáticas con con Admin Tools, veo que se ha hecho públco, y en parte lo que Nicholas Dionysopoulos (Admin Tools) decia es correcto. 😉

- http://community.joomla.org/blogs/community/1564-new-and-improved-updater.html

Sobre migrar usuarios, artículos, etc para aprovecharlos ¿de que versión a que versión?.

En próximas versiones veremos que lo que ya se venia usando para actualizar en Admin Tools ahora va a estar por defecto en el core de Joomla! 😉

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 04/04/2012 10:04 pm

Por favor Iniciar Sesión o Registro