"consejos sobre cambiar de versión 2.5.28 a 3.X."  

 
zysqo
 zysqo
Estimable Member

Hola, en la parte superior del backend tengo la siguiente información, y me preocupa el que pueda tener algún problema en la web a partir del 01/01/2015.

(Joomla! 2.5 Support Is Ending On December 31, 2014! Click Here for More Information.)

Tengo la versión 2.5.28 en la plantilla "Clarion", y les agradecería que me aconsejaran sobre lo que significa el enunciado. Y que debo de hacer a partir de ahora para seguir teniendo la web en perfectas condiciones y poder trabajar en ella como hasta ahora.

He visto algún mensaje del foro sobre este tema, pero sigo sin comprender si aún debo seguir en la versión 2.5.28 o cambiar ya a una versión 3.X,, además de cuando y como hacerlo.

Entiendo escasamente el funcionamiento de Joomla, por lo que me sería de ayuda que la respuesta fuese lo más fácil posible.

Gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 30/12/2014 11:42 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Es correcto que la versión de Joomla 2.5 esta llegando a su fin por lo tanto tendrás que pasar por un proceso de migración sin antes realizar una copia de seguridad. Debes verificar que tanto la plantilla y extensiones se encuentren disponibles para la nueva versión de Joomla 3 y lo que te recomiendo es que realices la prueba en un directorio.

Puedes revisar el siguiente articulo de blog:

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/12/2014 12:47 am

Cursos Gratuitos WordPress

zysqo
 zysqo
Estimable Member

Hola,

Respecto a tu respuesta he visto el vídeo, pero no enseña como comprobar si funcionan la plantilla y las extensiones en Joomla 3.

Te agradecería que me indicaras los pasos a seguir, ya que ignoro como hacerlo cuando me dices que realice la prueba en un directorio para verificar que la plantilla "CLARION" y las extensiones, son útiles en la versión 3.

Y por último quisiera saber si aunque el soporte de 2.5 termina el 31 de diciembre, ¿la ayuda que estáis realizando en este foro contestando a nuestras dudas, la seguiréis dando?

Un saludo.

ResponderCitar
Respondido : 31/12/2014 1:52 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

El mensaje de que el soporte para Joomla 2.5 termina el 31 de diciembre significa que el equipo desarrollador de esta herramienta no sacará nuevas versión para la rama 2.5, solo seguirán sacando actualizaciones para Joomla 3.

Por nuestra parte seguiremos dando soporte sobre Joomla, independientemente de la versión que estés usando, aunque en ocasiones podremos sugerirte que te actualices a una versión superior.

No existe un sistema automático para comprobar si las extensiones y plantilla que tienes en tu web son compatibles con Joomla 3.3. Esta comprobación habrá que hacerla de forma manual, verificando si la versiones que estás utilizando en las extensiones que hayas añadido a tu web son compatibles con Joomla 3.3 o no.

Ya te adelanto que casi con total seguridad la plantilla Clarion que tienes puede no ser compatible con Joomla 3. La mejor forma de comprobar esto y hacer pruebas es realizando un clon de tu web en otro directorio y probar a actualizar dicho clon a Joomla 3.3 para analizar los problemas que surgen.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/12/2014 2:48 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

zysqo
 zysqo
Estimable Member

Hola,

Siguiendo vuestros pasos, he clonado la web en otro directorio para realizar las pruebas, y comprobar si la última versión 3.3.6 es compatible a mi plantilla y a sus extensiones.

Para el caso de no funcionar mi plantilla actual "CLARION", ya he descargado la plantilla "FAVOURITE" para intentar adaptarla a la nueva versión.

Habiendo llegado hasta este punto, estoy dudando en seguir ya que he leído vuestro siguiente comentario en el foro sobre esperar a la versión 3.4. (adjunto pantalla)

Bajo vuestro punto de vista, y sabiendo que no tengo ninguna prisa por cambiar de la versión 2.5.28. ¿Sería mejor esperarme para migrar a la 3.4, sin pasar por la 3.3.6? O es aconsejable hacerlo ya mismo.

Un saludo.

ResponderCitar
Respondido : 15/01/2015 11:24 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

No debes esperar, puedes y es recomendable hacer el cambio, el post que haz puesto en captura es de hace mas de 8 meses.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/01/2015 11:45 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

zysqo
 zysqo
Estimable Member

Hola.

Estoy intentando realizar el cambio como explicáis en vuestro vídeo: (). Y no me deja a través del componente "actualizar joomla". Adjunto pantallas.

También he probado a traves del gestor de extensiones subiendo e instalando el archivo zip que ofreceis en el siguiente enlace: ( https://www.webempresa.com/descargar-joomla-3.html), pero tampoco me lo permite.

Agradecería alguna sugerencia para llevarla a cabo la actualización a 3.3.6

Saludos.

ResponderCitar
Respondido : 16/01/2015 2:00 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Prueba a cambiar por la opción que te adjunto en captura.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/01/2015 2:17 am

wpdoctor-revisa-la-salud-de-tu-wordpress

zysqo
 zysqo
Estimable Member

Hola,

Desde un principio lo hice como explica el vídeo con el soporte corto.

Pero aún cambiando al soporte de largo plazo, como me indicas, sigue sin aparecerme la última versión en el componente "actualizar Joola".

Probando después de intentar subir e instalar vuestro archivo zip del pack 3.3.6 en el gestor de actualizaciones me sale la siguiente instrucción en el componente "actualizar joomla".
JInstaller: :Instalación: No se puede encontrar el archivo de configuración XML.

Mi idea es la de cambiar la versión 2.5 a la 3.3.6 solo en la web que he clonado paralelamente a la original, para después añadirle la plantilla "favourite" y ver que funciona correctamente. En el caso de ir bien realizaría dichos cambios en la web original.

¿Alguna sugerencia de como debo proceder para dar con la solución a lo que pretendo?

Un saludo.

ResponderCitar
Respondido : 16/01/2015 3:05 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Prueba a descargarte el siguiente archivo de actualización en instálalo en tu Joomla 2.5 desde Extensiones->Gestor de Extensiones, como si de una extensión se tratase:

https://github.com/joomla/joomla-cms/releases/download/3.3.6/Joomla_3.3.6-Stable-Update_Package.zip

Recuerda que esto debes hacerlo en un clon de tu web real o habiendo hecho antes una copia de seguridad completa de la web.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/01/2015 3:26 pm

Cursos Gratuitos WordPress

zysqo
 zysqo
Estimable Member

Hola,

He realizado la operación que me indicas y después de subir e instalar el archivo zip en el gestor de extensiones, se me ha quedado la pantalla completamente en blanco. Pero sin comunicarme ningún error.

Seguidamente he seguido los pasos de este tutorial ( ), pero no he podido completarlo al no poder entrar en el backend de la web clonada, ya que intento ir a mi "sitio/clon/administrator" pero me es imposible al colocarse la pantalla en blanco.

Tenía pensado clonar de nuevo la web principal y volver a realizar todos los pasos, pero ignoro si es necesario, por haber alguna solución más practica y rápida.

¿Que me recomiendais hacer para resolverlo?

Un saludo.

ResponderCitar
Respondido : 16/01/2015 11:24 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola

Si es recomendable que realices la clonación de nuevo, después de haber realizado los pasos que te envíe en captura te faltaba limpiar la cache en Joomla para que te muestre la nueva versión.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/01/2015 11:30 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

zysqo
 zysqo
Estimable Member

Hola,

Tras varios intentos sin éxito para completar la actualización de la versión 2.5.28 a la 3.4 por salirme repetidas veces la pantalla en blanco con el error "504 GATEWAY TIME-OUT" , ahora mismo me encuentro en el punto de; (a) haber clonado la web original. (b) tener descargado el archivo con la plantilla Favourite. (c) tener disponible la última versión de Joomla en el backend "componentes/actualización de joomla". (Adjunto pantalla)

Mi problema es debido a que no tengo claro el orden a seguir para llevar a cabo los pasos y que no me aparezca la pantalla blanca. Por eso mi consulta es:

1. ¿debo primero subir e instalar la nueva plantilla "favourite" aún estando en la versión 2.5.28, y antes de instalar la actualización de la versión 3.4?

2. ¿Cuál es la forma más rápida y fácil de averiguar que todas las extensiones que hay en el gestor son compatibles con la nueva versión 3.4?

3. Y por último, en el transcurso de lo realizado anteriormente para conseguir tener disponible en el backend, (pero sin actualizarla), la versión 3.4. Me ha surgido el problema de no poder entrar en la extensión de akeba backup. Saliendo el error que os adjunto en la pantalla "1".

Podríais indicarme si al actualizar la web se arreglaría el problema, o ¿debo de hacer alguna otra cosa al respecto para volver a visualizar el akeba?

Esperando vuestra ayuda, recibid un saludo.

ResponderCitar
Respondido : 05/03/2015 1:19 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Respecto a tus consultas.

1. Debes primero migrar a Joomla 3 y luego instalar la plantilla.

2. La única forma es averiguar uno a uno en tu Joomla que extensiones utilizas y luego buscar en el Joomla Extension Directory si se encuentra disponible.

3. Prueba a desinstalar el Akeeba backup, y luego realiza la actualización

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/03/2015 3:00 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro