Cuando escribo código y guardo aparece barra invertida  

 
Enrique Camba
 Enrique Camba
Reputable Member

Buenas tardes, no entiendo lo que sucede, estoy descolocado.
Estaba trabajando con un proyecto y veía que cuando guardaba el artículo, al lado de las apóstrofes y comillas (la web está en catalán) aparece la barra invertida "". Así que me puse en contacto con Joomlaxtc de donde es la plantilla y no me dan solución, cabe decir que trabaja SIN editor, directamente al código, lo que es más extraño.

En otra web, Contenido solo visible a usuarios registrados

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

Citar
Respondido : 14/03/2013 3:25 pm
Enrique Camba
 Enrique Camba
Reputable Member

He guardado texto en archivos txt y demás sin problema.
¿Puede ser algo relacionado con los servidores?

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

ResponderCitar
Respondido : 14/03/2013 3:33 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Entiendo que el problema lo estás teniendo cuando editas un artículo de Joomla y colocas un texto que incluye comillas como el javascript de Google Analytics, al guardar te coloca la barra invertida.

He probado a hacer esto mismo con un artículo de Joomla 2.5 y me funciona correctamente, incluso cuando añado el código que indicas. Esto lo he realizado con el editor desactivado.

Normalmente la barra invertida que se coloca a la izquierda de la comilla se utiliza para que en una constante de texto que se guarda entre comillas se puedan colocar dentro el mismo tipo de comillas.

Prueba a ir a la configuración global de tu Joomla y pulsa en la pestaña Filtro de textos. Para el usuario Super Usuario (supongo que usas un usuario con esos privilegios en la administración de Joomla) elige la opción Sin filtrado y guarda los cambios.

Si te sigue sin funcionar indícanos de la forma más detallada posible dónde estás colocando el texto y en qué momento te coloca la barra invertida (al guardar, al editar, al mostrarlo pero no al editarlo, etc.).

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2013 3:49 pm
Enrique Camba
 Enrique Camba
Reputable Member

Hola Pablo gran aportación, pero cuando voy a donde me dices veo que ya está desactivado :S para el super user!

Las barritas salen tras guardar, cuando lo copio el texto aparece bien, pero cuando guardo aparecen las barras.

Adjunto un pantallazo de donde coloco el código de seguimiento, es el que he puesto en el inicio del hilo.
En este caso es en el gestor de plantillas de una web con Joomla 2.5 de yootheme en Contenido solo visible a usuarios registrados.

Esto es muy incómodo, ya que en la última web no puedo trabajar ya que aparecen constantemente las barritas y los de joomlaxtc no me contestan.

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

ResponderCitar
Respondido : 14/03/2013 4:00 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Es posible que el error se deba a un problema con la propia plantilla y no tenga nada que ver ni con Joomla ni con el servidor (sino fallaría al ponerlo en un artículo). Lo más fácil es que en lugar de colocar aquí el código de Analytics utilices alguno de los múltiples plugins que pueden hacer esta tarea de forma sencilla.

En el siguiente enlace podrás encontrar varias opciones:

http://extensions.joomla.org/extensions/site-management/analytics/site-analytics-google-based

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2013 4:03 pm
Enrique Camba
 Enrique Camba
Reputable Member

Si pero es que me está fallando en 2 webs diferentes a la vez y de diferentes empresas, ya es raro el problema para que surja a la vez en 2 webs que he empezado hace poco.
Lo de analytics tiene un pase, porque tiene remedio, lo otro no.

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

ResponderCitar
Respondido : 14/03/2013 4:07 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Enrique,

En http://www.joomlart.com/forums/showthread.php?48506-Slashes-Inserted-When-Apostrophe-Used marcan el mismo problema, no se si has instalado algo que realice ese "str_replace"

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 14/03/2013 4:15 pm
Enrique Camba
 Enrique Camba
Reputable Member

Hola Jordi, que tal, he revisado todo lo que he instalado en las plantillas y nada, en la de joomlaxtc no he instalado nada, y en la de yootheme un componente y un plugin que no utilizan str_replace.
Voy a hablar con el sat de joomlaxtc a ver que me cuentan. Gracias por ponerme en la pista de la solución.

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

ResponderCitar
Respondido : 14/03/2013 4:50 pm

Cursos Gratuitos WordPress

Enrique Camba
 Enrique Camba
Reputable Member

Solucionado. El problema es que en vuestros servidores estaban activadas las comillas mágicas y eso hacía que no funcionara bien el joomla de la web, ya que desactivé el com_content del template y seguía dando problemas, era cosa del joomla. Los de joomlaxtc me dijeron que desactivara las comillas mágicas y se ha solucionado el problema. 2 semanas el proyecto parado.

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

ResponderCitar
Respondido : 22/03/2013 9:21 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Enrique,

Los servidores están configurados según los requerimientos de Joomla!.

http://www.joomla.org/technical-requirements.html dependiendo de la versión de Joomla! cambian los requerimientos. Por ejemplo en la versión de Joomla! 1.0 eran unos, y para 3.0 serán otros.

Por ejemplo según que versión de Joomla! necesita PHP 5.3 para funcionar, y si un cliente lo solicita, le cambiamos a otro servidor con esa versión.

Perfecto que se haya solucionado el problema. Cerramos el tema.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 22/03/2013 9:41 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Por favor Iniciar Sesión o Registro