Downgrade temporal de PHP5.4 a PHP5.3  

 
Treses3
 Treses3
Usuario experto

Hola,

Tengo una copia hecha con akeeba de la web antigua que estaba en Joomla 2.5 y php 5.3. Me gustaría restaurarla temporalmente /TMP en Webempresa para copiar la estructura de las categorías, usuarios, metadatos, ...
Desde los tickets webempresa me actualizaron a la ultima versión estable PHP 5.4 (Requisito para la nueva web, componentes como akeeba, pluins..). El instalador Akeeba Kickstart es compatible con PHP 5.4 ya que las nuevas versiones de Akeeba Backup requieren PHP 5.4 para funcionar, igual que el hosting.

Cuando voy a restaurar akeeba me dice:
"IMPORTANT! You are restoring on a server with a different PHP version than the one you used to back up your site. (...)"
>>> Desde el servicio de Tickets de Webempresa me dijeron que se puede forzar a que la web de /public_html/TMP cargue con php 5.3 añadiendo un código en el .htaccess de la web en public_html/TMP/.htaccess

Este codigo: AddHandler application/x-httpd-php53 .php

Excelente!! Ahora akeeba no da el mensaje de estar usando una versión diferente de PHP5.3
En principio el backup se ha restaurado bien como indica la documentacion, pero no se abre bien la pagina 🙁

Me gustaría restaurarla en el servidor local pero estoy teniendo algunos problemas. Entiendo que resultaría inseguro e incompatible con la nueva web. Volver atrás no tiene mucho sentido...
Se podría restaurar en Webempresa por un rato y después deshabilitar PHP5.3?

GRACIAS

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 03/03/2016 1:08 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

No acabo de entender lo que quieres hacer. Preguntas por restaurar la web en Webempresa pero también veo que comentas que eso ya lo has hecho, y que habías tenido problemas.

Siempre puedes aplicar el cambio en la versión de php de forma global, si solo necesitas ver la web durante un momento. Si vas a hacer esto, lo recomendable es que dejaras tu web actual temporalmente en mantenimiento.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 03/03/2016 2:34 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Treses3
 Treses3
Usuario experto

Vale,
Como se cambia la versión de php de forma global?

ResponderCitar
Respondido : 03/03/2016 4:57 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Puedes solicitar el cambio de versión de PHP a través de tickets de soporte.

Sin embargo según lo que comentas al inicio, entiendo que asumes que tu web si funciona con PHP 5.3 y no con PHP 5.4, teoricamente debería funcionar con ambos

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 03/03/2016 5:28 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Treses3
 Treses3
Usuario experto

La web antigua funciona con PHP5.3 y la nueva con PHP5.4
Al restaurar la antigua, akeeba hace todo el proceso correcto pero al abrirla solo se ve lo que hay en la captura de pantalla. No me accede al backend redirige a la raiz (de la nueva).

Probare de solicitar el cambio a PHP5.3 haber si consigo verla ahora que esta restaurada para luego volver a PHP5.4. El problema esta en que el instalador akeeba kickstart 4.1.4 solo va con PHP5.4

Espero haberme explicado + o - bien 🙂

ResponderCitar
Respondido : 03/03/2016 6:01 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tal como te comenté, ambas webs deberían funcionar en PHP 5.4 sin problemas

Si te aparece una pantalla en blanco posiblemente debe ser por otra cosa, tendrías que revisar el archivo error_log y ver si se generan errores recientes.

Tendrías que enviarnos las urls de ambas web la web nueva y la web antigua para revisar , entiendo que ambas se encuentran en una misma cuenta de hosting con PHP 5.4

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 03/03/2016 6:42 pm

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro