jnews - problema con el no account yet?  

Página 1 / 2
 
David
 David
Usuario eminente

Contenido solo visible a usuarios registrados

Citar
Respondido : 26/08/2012 9:59 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David,

Localiza en la ruta:

administrator/components/com_jnews/language

El string _NO_ACCOUNT y traducelo.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/08/2012 10:43 pm

Cursos Gratuitos WordPress

David
 David
Usuario eminente

Gracias Luis,

el tema de la traducción ya lo he solucionado y funciona correctamente.

Respecto a la segunda pregunta ¿alguna idea para cambiar la url donde me redirige para registrarme ?

if(!defined('_NO_ACCOUNT')) define('_NO_ACCOUNT','No tienes cuenta?'); --> traducida
if(!defined('_CREATE_ACCOUNT')) define('_CREATE_ACCOUNT','Registro'); --> traducida, pero no se esta variable donde cambiar la URL a donde me redirige.

Gracias!

David

ResponderCitar
Respondido : 26/08/2012 10:52 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David,

2º El Register debería redirigrme a mi formulario de Registro de usuarios del joomla:
www.caminar-meditar-vivir.com/index.php/component/users/?view=registration
pero no lo hace y la url es incorrecta.

¿Puedes facilitar una captura de como lo tienes actualmente puesto?.

Nota importante: Realiza las consultas de forma separada en post nuevos para evitar anidar consultas de diferente naturaleza bajo un mismo post que luego dificultan la búsqueda de soluciones a otros usuarios, gracias.

Saludos

saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/08/2012 11:27 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David
 David
Usuario eminente

Perfecto Luis. Si quieres muevo la segunda pregunta a un nuevo hilo.

Perdona cuando has mirado había cambiado la opción de "permitir no registrados" en el jnews y por eso no lo has visto. Ahora lo he vuelto a activar sorry.

Si vas a la página y pulsas en "semillas de conciencia" aparece:
Por favor regístrese en el portal antes de registrarse en una lista.
No tienes cuenta? Registro
Si pinchas en Registro me redirige a esta URL:
http://www.caminar-meditar-vivir.com/index.php/component/user/?task=register

que es un 404 not found.

La historia es que no se donde se cambia esa URL para que la gente al pinchar ahí vaya al formulario de suscripcion.

Gracias!

ResponderCitar
Respondido : 26/08/2012 11:47 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David,

¿Tienes habilitado "Usar la reescritura URL" en Configuración Global, Sitio?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/08/2012 12:18 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Usuario eminente

No, no lo tengo.

¿lo tengo que activar?

gracias!

ResponderCitar
Respondido : 27/08/2012 12:19 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David,

La idea es que lo actives, junto con las urls amigables (si no las tienes habilitadas) y limpies la cache del navegador y pruebes nuevamente el link de "Registro".

Además que facilites una captura del módulo para ver como configuraste la redirección a Registrarse.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/08/2012 12:57 am

wpdoctor-revisa-la-salud-de-tu-wordpress

David
 David
Usuario eminente

Hola Luis.

Gracias.

ya he hecho los dos pasos que indicas ( la reescritura y las urls amigables ya estaban) así como limpiar la cache y nada, ahora aparece otro error diferente al pinchar en el link de Registro:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@caminar-meditar-vivir.escuela-wuchi.es and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Te adjunto las dos imagenes del modulo de registro y de la config del jnews

Gracias

un saludo,

David

ResponderCitar
Respondido : 27/08/2012 1:29 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David,

No entiendo a que viene ese error 500 ¿has revisado el archivo .htaccess? entiendo que lo tienes correctamente creado y renombrado de htaccess.txt a .htaccess ¿correcto?.

¿Has probado a cambira la url de redirección y dejar solo index.php?

Revisa el archivo /public_html/error_log a ver si hay alguna referencia al error 500.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/08/2012 2:27 am

Cursos Gratuitos WordPress

David
 David
Usuario eminente

Hola Luis,

si, lo renombré del txt al .htaccess.

Este es el archivo .htaccess que utilizo (es una copia y he quitado la parte de autenticación que tengo)
http://www.caminar-meditar-vivir.com/htaccess.txt

En el log del path del dominio no veo nada relativo a errores 500 u otros significativos.

Respecto a la pregunta de cambiar la redireccion no se como se hace eso, sorry. Imagino que tocando el .htacces pero no lo veo claro.

Gracias!

David

ResponderCitar
Respondido : 27/08/2012 1:24 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola David,

No es posible acceder a tu sitio web Contenido solo visible a usuarios registrados para reproducir el tema del error de acceso que indicas.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 27/08/2012 2:11 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David
 David
Usuario eminente

Hola Jordi,

no entiendo porque no puedes acceder.

El sitio no es publico todavía y está protegido con usuario en .htaccess

Contenido solo visible a usuarios registrados

¿puedes acceder?

un saludo

David

ResponderCitar
Respondido : 27/08/2012 2:17 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Para hacer pruebas es mejor desactivar las urls amigables en la configuración global de Joomla. De esta forma se puede ver la url real y comprobar si todo es correcto en ella.

No veo en tu web el módulo de registro del JNews. Tendrías que indicarnos donde está. Es posible que en el módulo se esté construyendo mal el enlace de registro.

¿Qué versión de JNews tienes instalada? ¿Se trata de la versión gratuita o es de pago?

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/08/2012 4:13 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Usuario eminente

Hola Pablo,

el modulo se encuentra en la barra de la derecha y el botón se llama "semillas de conciencia"

La versión de jnews que tengo es la de pago.

En el historial del post hay un adjunto con la configuracion del modulo de Registro del Jnews.

Acabo de desactivar las url amigables y al pulsar sobre "registro" me redirige a la URL:

http://www.caminar-meditar-vivir.com/index.php?option=com_user&task=register

que es un error 404 y ese es mi problema del que no se salir.

gracias por la ayuda y un saludo,

David

ResponderCitar
Respondido : 27/08/2012 11:48 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro