Las imagenes de mis articulos en K2 no se muestran en Facebook  

 
Mary Mar Alejo
 Mary Mar Alejo
Usuario eminente

Hola,

He actualizado mi version de K2 a la version 2.6.1 [ESTABLE], donde supuestamente se ha solucionado el problema de la libreria OpenGraph que era el causante de que en versiones anteriores al enviar un articulo de K2 a facebook mostrase la imagen equivocada o ninguna:

También se han actualizado las meta-etiquetas de Facebook para usar la especificación OpenGraph. Anteriormente Facebook había dejado de soportar la meta-etiqueta "imagen" que K2 utiliza lo que provocaba muchos problemas para mostrar las imágenes de los artículos correctas en las publicaciones enviadas a Facebook, pudiendo ahora compartir sin problemas y con la imagen correcta.

https://www.webempresa.com/blog/item/943-disponible-k2-v261-para-joomla-15-25-y-30.html

Teoricamente deberia de funcionar, pero lo cierto es que no me muestra imagenes de mis articulos en facebook y tampoco el texto de introducción del articulo sino la meta descripción de mi página, que no deberia.

¿Alguna sugerencia?

NOTA: Mi versión de Joomla! es 2.5.7

Abrazos!

URL del sitio: Contenido solo visible a usuarios registrados

Mary Mar Alejo
"Tenho gostos simples. Me satisfaço com o melhor" (Oscar Wilde)

Citar
Respondido : 18/10/2012 4:42 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Mary

En tu sitio web puedes enviarnos la url específica de algún artículo de k2 con redes sociales para verificar lo que comentas.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/10/2012 6:11 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Mary Mar Alejo
 Mary Mar Alejo
Usuario eminente

Hola Jhon,

Todos mis articulos de la web estan en K2 y todos utilizan la misma configuración, pero de todas las maneras, como me lo pides te paso un link cualquiera para que te ayude a comprobarlo:

http://marymaralejo.com/item/164-phoca-gallery-importando-fotos-do-facebook

Gracias,

Abrazos!!

Mary Mar Alejo
"Tenho gostos simples. Me satisfaço com o melhor" (Oscar Wilde)

ResponderCitar
Respondido : 18/10/2012 6:20 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Mary

Ten en cuenta que k2 sólo te generará correctamente la etiqueta og:image ( que es el meta de etiqueta de imagen para facebook) cuando la imagen es agregada utilizando el tab image desde k2

En el caso del artículo enviado, veo que tiene la imagen correctamente :

Esto se ve ingresando a la siguiente url y luego viendo el código fuente haml
http://marymaralejo.com/item/164-phoca-gallery-importando-fotos-do-facebook

Es posible que hayas realizado mosdificaciones en la imagen recientemente y facebook puede ser que se haya quedado con la imagen anterior aleatoria.

Te sugiero crear un nuevo artículo y agregar una imagen y verificar el código fuente y ver que se genera el código og:image correctamente.

Puedes también probar con un artículo que no tenga imagen como por ejemplo :
http://marymaralejo.com/k2/k2-user-page

Tal como te comenté anteriormente la imagen debe ser agregada desde el tab de imágenes de k2

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/10/2012 9:09 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Mary Mar Alejo
 Mary Mar Alejo
Usuario eminente

Hola Jhon,

Estoy ahora mismo creando un nuevo articulo para probar.

De todas las maneras, siempre agrego la image atraves de la TAB IMAGEN, y siempre tube este problema en relacion a las redes sociales...

Me pasa lo mismo por ejemplo con G+, donde nunca aparece el texto introductorio del articulo, y me aparece la imagen equivocada o ninguna image...

Pero tal como me indicas, estoy creando un nuevo articulo para probar y volver a responder al Foro.

Muchas Gracias,

Abrazos!!!

Mary Mar Alejo
"Tenho gostos simples. Me satisfaço com o melhor" (Oscar Wilde)

ResponderCitar
Respondido : 18/10/2012 9:14 pm
Mary Mar Alejo
 Mary Mar Alejo
Usuario eminente

Hola Jhon,

Como me habias indicado he creado un nuevo articulo:

http://www.marymaralejo.com/item/177-o-que-fazer-depois-de-instalar-o-ubuntu-1210

La imagen fue añadida desde la pestaña IMAGEN (como siempre lo hacia)

He mirado el codigo fuente y supuestamente esta correcto:

Pero al intentar compartirlo en las redes me da el mismo problema como indica la imagen abajo:

En el punto 1, me ha cojido una imagen que no era, ya que me puso el logo de Pinteres (como casi siempre lo hace en facebook).

En el punto 2 me pone la meta-descripción de mi sitio web y no la introducción del articulo me me deberia aparecer.

Entonces sigo con el problema.

¿Que puedo hacer?

Abrazos!!

Mary Mar Alejo
"Tenho gostos simples. Me satisfaço com o melhor" (Oscar Wilde)

ResponderCitar
Respondido : 18/10/2012 10:42 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Mary

Desde la herramienta de depuración de facebook
http://developers.facebook.com/tools/debug

Al probar tu sitio web salen algunos problemas con respecto a los tag de facebook:
http://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fwww.marymaralejo.com%2Fitem%2F177-o-que-fazer-depois-de-instalar-o-ubuntu-1210

Lo que si puedes arreglar es la sugerencia de la imagen cuadrada para compartir colocando una imagen cuadrada como imagen principal.

Se ve por ejemplo que si debería compartir correctamente la imagen, aunque los otros errores es debido al código generado por k2, puedes realizar una prueba simple instalando un nuevo sitio web con k2 y verificar si te sucede lo mismo ya que es posible que sea algún bug de la extensión al generar botones de redes sociales.

Por otro lado es posible que facebook maneje algún tipo de cache y que posiblemente al no haber encontrado ningún meta og antes en tu sitio web haya guardado esta imagen por defecto, prueba eliminando tu imagen de Pinterest y verifica si esto es asi.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/10/2012 11:38 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Mary Mar,

Puedes realizar lo siguiente:

- Deshabilitar cualquier plugin que estés utilizando de Pinterest.
- Eliminar el código del boton de Pinteres en la pestaña "Social" de Facebook.
- Si utilizas meta-descripción y meta-etiquetas en los ítems de menú "eliminalos" solo úsalos en la configuración Global de tu Joomla.
- Limpia la caché de tu Joomla y revisa si ahora al enviar un artículo a Facebook, se muestra el texto del artículo y la imagen del artículo y no el botón de Pinterest.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/10/2012 2:32 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Mary Mar Alejo
 Mary Mar Alejo
Usuario eminente

Hola Luis,

Hice todo lo que me has dicho y parece que parte del problema a funcionado.

Lo que realmente estaba causando el problema era la meta-descripcion del item de menu. La he quitado y solo puse meta-descripcion en la configuacion global.

Al enviar el aticulo al facebook, me aparece asi:

Correctamente, con la imagen correcta, con el titulo correcto y con la intro correcta.

Mega contenta me quede.... Pero aun sigo con parte del problema en G+:

Me aparece bien el titulo, la intro... pero no me aparece la imagen...

De todas las formas... muchas graias... ya estoy contenta, pues mi intencion era solucionarlo en el facebook.

Abrazos!!

Mary Mar Alejo
"Tenho gostos simples. Me satisfaço com o melhor" (Oscar Wilde)

ResponderCitar
Respondido : 19/10/2012 2:49 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Mary Mar,

Me alegra saber que la parte concerniente a Facebook ya te funciona. 🙂

Sobre Google+ ¿tienes actualmente algún plugin (Gestor de Plugins) o un script en K2, Parámetros, Social habilitado de esta red social?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/10/2012 2:58 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro