migracion joomla 2.5 desde otro sitio  

Página 1 / 2
 
gloria
 gloria
Usuario activo

Buenos días,
Soy nueva en el hosting, he importado varios sitios joomla 2.5 que estaban funcionando en xampp y no consigo que aqui funcione ninguno.
Pienso que el problema esta en las bases de datos en 1 caso, y en el otro no se que pensar.

1.- La base de datos .sql viene de NAVICAT,
al importar, solo importa 1 tabla y me da este error:
Error
consulta SQL:

CREATE TABLE `ksjkr_admintools_adminiplist` (

`id` BIGINT( 20 ) UNSIGNED NOT NULL AUTO_INCREMENT ,
`ip` VARCHAR( 255 ) CHARACTER SET utf8 COLLATE utf8_general_ci NULL DEFAULT NULL ,
`description` VARCHAR( 255 ) CHARACTER SET utf8 COLLATE utf8_general_ci NULL DEFAULT NULL
) ENGINE = MYISAM DEFAULT CHARACTER SET = utf8 COLLATE = utf8_general_ci AUTO_INCREMENT =1;

MySQL ha dicho: Documentación

#1075 - Incorrect table definition; there can be only one auto column and it must be defined as a key

En la base de datos esta así:
-- ----------------------------
-- Table structure for `ksjkr_admintools_adminiplist`
-- ----------------------------
DROP TABLE IF EXISTS `ksjkr_admintools_adminiplist`;
CREATE TABLE `ksjkr_admintools_adminiplist` (
`id` bigint(20) UNSIGNED NOT NULL AUTO_INCREMENT ,
`ip` varchar(255) CHARACTER SET utf8 COLLATE utf8_general_ci NULL DEFAULT NULL ,
`description` varchar(255) CHARACTER SET utf8 COLLATE utf8_general_ci NULL DEFAULT NULL
)
ENGINE=MyISAM
DEFAULT CHARACTER SET=utf8 COLLATE=utf8_general_ci
AUTO_INCREMENT=1

;

En este sitio JOOMLA 2.5, no paso de aquí.
URL: www.lloydsbrokers.es
Adjunto base de datos "lloyds.zip" (sql)
-----------------------------

En otro sitio JOOMLA, he importado la base de datos, no me da error, hemodificado configuracion.php con los nuevos datos de nomre, user, pass .
Pero al llamar al sitio desde el navegador devuelve:
Table 'upes_dfim1.pxfqw_session' doesn't exist SQL=INSERT INTO `pxfqw_session` (`session_id`, `client_id`, `time`) VALUES ('18126585619e187dbe5260d0c72e8b26', 0, '1391503701')

URL: www.despachofinanciero.es
Adjunto base de datos "dfim1.zip" (sql)

Quedo a la espera de sus comentarios,
Gracias
Saludos
Gloria

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 04/02/2014 9:53 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Gloria,

Puede ser un problema de navicat, ya que al final de los archivos .sql arrastra mucho código.

La mejor manera de mover Joomla! a "cualquier" otro lugar "remoto o local" es mediante el uso de extensiones como Akeeba Backup o XCloner, las cuales permiten realizar una copia completa del sitio web y de la base de datos en formato .jpa (formato del archivo de la copia para Akeeba Backup y el más recomendado o el formato .zip) y .tar o .tar.gz (formato del archivo de la copia para XCloner), y en un solo archivo llevarse la instalación a donde se desee o mantenerla como archivo de seguridad de la web.

Te adjuntamos unos vídeos para poder copiar y restaurar Joomla! de un Hosting a otro o en el mismo Hosting:

- Como copiar Joomla con Akeeba Backup: https://www.webempresa.com/videos/akeeba_copiadeseguridad/akeeba_copiadeseguridad.html
- Como restaurar Joomla con Akeeba Backup o JoomlaPack: https://www.webempresa.com/videos/akeeba_restauracion/akeeba_restauracion.html

Nota para copias con Akeeba Backup: En el caso de poner una contraseña al realizar un backup anotala para luego introducirla en la restauración.

En el siguiente artículo mostramos información sobre Akeeba Backup

En el siguiente artículo se puede ver como instalar y hacer uso de XCloner para realizar copias de seguridad de Joomla:

- https://www.webempresa.com/blog/copias-de-seguridad-con-xcloner-backup-en-joomla-15-25-y-30.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 04/02/2014 10:18 am

Cursos Gratuitos WordPress

gloria
 gloria
Usuario activo

Hola Jordi,
Muchas gracias por tu rápida respuesta,
pero me temo que eso ya no es posible. La única posibilidad es acceder a los directorios o ficheros, pero ya no puedo acceder al administrator, por qué?? un misterio sin resolver, despues de un ataque que ha destrozado el sistema operativo.
No se si se te ocurrirá otra vía.
Saludos

ResponderCitar
Respondido : 04/02/2014 10:30 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Gloria,

No entiendo. ¿No has dicho antes que estaban funcionando en XAMP y que no te funcionan al subirlos al hosting?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 04/02/2014 10:49 am

wpdoctor-revisa-la-salud-de-tu-wordpress

gloria
 gloria
Usuario activo

Si, funcionaban perfectamente, de hecho después de tu respuesta y en vista de que no consigo avanzar después de una semana, he vuelto a cambiar la ip para que apunte al antigüo xampp, porque en local no es posible, pero desde fuera funcionaban perfectamente, así que voy a probar a hacer lo que me recomiendas, y si funciona con una, lo hago con todas.
En principio he probado para lloyds, que la base de datos no hay manera de importarla.

Peo que opinas de despacho financiero?? Esta todo importado perfectamente y tampoco funciona, el navegador me devuelve
Table 'upes_dfim1.pxfqw_session' doesn't exist SQL=INSERT INTO `pxfqw_session` (`session_id`, `client_id`, `time`) VALUES ('18126585619e187dbe5260d0c72e8b26', 0, '1391507902')

ResponderCitar
Respondido : 04/02/2014 10:58 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Gloria,

Revisa en la base de datos que has importado si la tabla pxfqw_session existe.

Si existe puedes realizar un "reparar tabla" si es que la misma tiene mucho residuo.

https://www.webempresa.com/videos-soporte/cpanel/26-phpmyadmin/index.htm

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 04/02/2014 11:11 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

gloria
 gloria
Usuario activo

Hola de nuevo Jordi,
la tabla
pxfqw_session
No solo no existe, además las tablas de esta base de datos tienen otro prefijo.
Pero
upes_dfim1.pxfqw nop se lo que es, es posible que al crear la base de datos vacia para importar haya asignado este prefijo?? porque up.es es e dominio que esta en vuestro hosting, y crea ese prefijo en el nombre de cada base de datos upes_NOMBRE DE BASE DE DATOS.
Pero el .sufijo es lo que no entiendo de donde sale.

ni que tabla es pxfqw_session, como no sea algo que crea automaticamente el sistema?? Al crear base de datos vacia??

ResponderCitar
Respondido : 04/02/2014 11:33 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Gloria,

Revisa que los datos del archivo configuration.php relacionados con la base de datos son correctos (host, base, usuario, contraseña, prefijos). El prefijo ni las tablas no se crean automáticamente, solo es con una importación de datos. Si faltan tablas es que al importar las mismas con el PHPMyAdmin se ha producido algún error, o que el archivo de la base de datos se ha exportado incorrectamente, contiene errores, o la base de datos en origen estaba dañada.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 04/02/2014 11:37 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

gloria
 gloria
Usuario activo

Gracias jordi,
Voy a revisar estos puntos.
----------------------------

Por otra parte lloyds ya esta online en la ip anterior, si quieres verla, veras que funciona perfectamente, es la que voy a exportar como me has indicado, haciendo backup.
A ver si funciona
Gracias.

ResponderCitar
Respondido : 04/02/2014 11:58 am
gloria
 gloria
Usuario activo

Estimado Jordi,
He seguido el procedimiento del video para hacer y restaurar backup de XCLONER, al final, cuando voy a restaurar me da este error:

XCloner Automatic Restore! - www.maphsbrokers.es

The database details provided are incorrect and/or empty. Unable to connect to mysql server

La base de datos la acabo de crear, y es muy cierto que esta vacía, pero eso no debería ser un error. El usuario y la contraseña los he copiado y pegado, por lo que no hay error.
Que crees que podría hacer?
Gracias de antemano.

ResponderCitar
Respondido : 04/02/2014 4:48 pm

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Por el mensaje que se muestra todo parece indicar que has puesto algo mal en los detalles de conexión a la base de datos. Estos suelen ser 4: nombre de la base de datos, localización de la base de datos (siempre sería localhost), usuario y contraseña. Estos 2 últimos datos deben de corresponder a un usuario que tenga los permisos de acceso correctos a la base de datos en cuestión.

Deberías de revisar estos datos o probar a crear una nueva base de datos con su correspondiente usuario y contraseña para ver si así te funciona.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 04/02/2014 5:30 pm
gloria
 gloria
Usuario activo

Gracias Pablo,
Ya he creado la nueva base de datos, y lo mismo,
Por probar dentro de la pagina doiminio//XCloner.php he modificado file restore options, seleccionando:
Restore files permissions
Restore by using the server utilities (tar)
Incremental transfer

Entonces he dado un paso mas, me devuelve:
XCloner Automatic Restore! - www.maphsbrokers.es
Could not set permissions! Permissions file /home2/upes/public_html/maphsbrokers.es//administrator/backups/perm.txt not found!
Files succesfully copied to /home2/upes/public_html/maphsbrokers.es/
Configuration updated!

Please click here to continue with database import...
-------------------------

No se lo que es //administrator/backups/perm.txt
En ese directorio solo esta el backup.rar TAR.php y XCLoner.php, lo de
perm.txt no se lo que es, y la doble barra tampoco.

Si hago click en
Please click here to continue with database import...

Entonces las respuesta es
XCloner Automatic Restore! - www.maphsbrokers.es

The database details provided are incorrect and/or empty. Unable to connect to mysql server

Otra vez el principio ...

Pero perm.txt??? no lo encuentra porque no existe, debería existir?

ResponderCitar
Respondido : 04/02/2014 6:17 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla gloria

Prueba descomprimiendo el archivo de tu backup manualmnete antes de usar el XCloner.php, luego copia el archivo XCloner.php y TAR.php a la raiz de tu cuenta de hosting, ejecuta el XCloner.php y luego en el tab de archivos, marka la opción de saltar la descompresión (puesto que ya estan descomprimidos), llena los datos de la BD y luego ejecuta.

Si tienes problemas envía algunas capturas para ver que sucede.

lo del archivo param.txt debe ser algo de XCloner, algún tipo de log o de archivo de configuración pero no de tu Joomla.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 04/02/2014 8:24 pm
gloria
 gloria
Usuario activo

Hola Jhon,
Buenas noches y gracias por seguir con esto,
Por ir en orden:
Descomprimido backup.rar con los 2 archivos necesarios para la restauración XCloner.php y TAR.php, todo en el mismo directorio. Adjunto imagen y marco el archivo comprimido .rar , ya descomprimido y los 2 archivos.

Las opciones de importación son:

Elijo la marcada porque ya no es el archivo comprimido.
esto es lo que ocurre
XCloner Automatic Restore! - www.maphsbrokers.es

Could not continue, unable to read the clone backup file! Please make sure you copied the backup in the same directory as XCloner.php

Aunque puedes ver que si esta el archivo Xcloner.php en el directorio

No se que hago mal.
Saludos
Gloria
Contenido solo visible a usuarios registrados

ResponderCitar
Respondido : 04/02/2014 9:40 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola gloria,

¿Sigues el vídeo de como se restaura un backup realizado con XCloner? a juzgar por tus capturas últimas NO, ya que no requiere ni indicar el dominio, el solo coge la url (ruta) donde se ha de restaurar y el archivo de la copia que va a restaurar, tu no se lo indicas.

Revísalo y dime exactamente en que minuto del vídeo te atascas o te surge el problema.

- Copias de Seguridad de WordPress con el plugin XCloner: https://www.webempresa.com/blog/item/688-como-clonar-tu-blog-y-gestionar-copias-de-seguridad-en-wordpress-con-xcloner.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 04/02/2014 11:31 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro