No se visualizan dos módulos en multiidioma (plantilla Methys)  

Página 1 / 2
 
Angel
 Angel
Usuario activo

Buenas,
He seguido los tutoriales de instalación de multiidioma ( y he mirado en el foro y no he encontrado ninguna solución a mi problema. He verificado la publicación y asignación correcta de los módulos/menús/categorías/artículos para idiomas correspondientes y lo sigo teniendo.
En http://hispanorusa.com/webmethys/ru/ me sale la versión que quiero con los módulos publicados y en la versión en español, no: http://hispanorusa.com/webmethys/.
Creo que el problema está en los profiles que al guardar no me admite (se cuelga) que guarde sólo páginas escogidas del ruso y sí me las guarda como All y artículos enumerados.
Adjunto pantallazos.
No sé cómo remediarlo.
Saludos

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 15/05/2014 2:25 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Lo más probable es que el problema que tienes es que no existen esos módulos para el idioma español, o bien sí que existen pero no están asignados al elemento de menú correcto.

Por ejemplo, para la galería de imágenes superior se está cargando en la posición slideshow. Tendría que verificar si en esa posición tienes módulos. Podría haber uno que fuera común para los idiomas (por ejemplo, si solo se cargan imágenes), para lo cuál tendríamos que configurarlo para que cargue en todos los idiomas, o tener una instancia del módulo para cada idioma, en el caso de que en el módulo se carguen textos que queramos mostrar traducidos, para los cuál deberemos asignar cada módulo a su idioma correspondiente.

Además, tendremos que asignar el módulo a los elementos de menú correctos. Ten en cuenta que cuando trabajamos con varios idiomas tendremos un elemento de menú para la página de inicio diferente para cada idioma, por lo que el módulo tendrá que estar asignado a los elementos de menú que le correspondan.

Revisa el siguiente artículo de nuestro blog. Te podrá servir de guía:

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/05/2014 5:49 pm

Cursos Gratuitos WordPress

Angel
 Angel
Usuario activo

Buenas Pablo,
La verdad es que lo tengo todo como en el tutorial que indicas. A cada idioma le tengo asignados los módulos, menús, categorías y contenidos propios y el único módulo que tiene que aparecer en todos los idiomas es el slider de la Galería principal.
Adjunto imágenes respectivas.
Si no es el problema de los profiles en la plantilla Methys, no sé qué más pensar, porque lo he verificado todo y las páginas en sus respectivos idiomas están en su sitio.
Saludos

ResponderCitar
Respondido : 15/05/2014 6:47 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Angel

El problema parece ser que esta sobreutilizando la funcionalidad de todos los idiomas, deberías tener un profile neutro, que se muestre en todos los idiomas (sabemos que no se mostrará)

Revisa la imagen 1, primero sólo debes tener un estilo de plantilla

Luego en la imagen 2 verás que tienes un profile para todos los idiomas y luego un profile independiente por idioma (esta configuración es simlar a la de los menús)

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/05/2014 8:25 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Angel
 Angel
Usuario activo

Buenas Jhon,
Te adjunto los cambios realizados (he habilitado el profile para ES, he atribuido el Menú por defecto al profile Default inicial, pero sólo me guarda cambios cuando al menos uno de los idiomas tiene todas las páginas (All). Ahora All está en ES, pero lo paradójico, es que tras limpiar el cache del sitio, me sigue saliendo el mismo problema de antes: en Ru se visualizan bien los módulos Methys y en ES - no: http://hispanorusa.com/webmethys/ y http://hispanorusa.com/webmethys/ru.
De todas formas, en el tutorial justo sobre este pack en el minuto 13:12 habláis de habilitar el Menú default para todas las páginas en ES y se agrega un nuevo idioma (EN) (que es lo que tenía antes).
No sé si es mejor reescribir la plantilla Methys (?!), se puede bajarla de algún modo sin afectar el resto de la web (no hay mucho hecho, pero para no volver a hacerlo desde cero)...
Saludos

ResponderCitar
Respondido : 16/05/2014 9:30 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

¿A qué te refieres con lo de reescribir la plantilla? En mi respuesta anterior te comentaba que no daba la sensación de que el problema estuviera en la plantilla debido a que para el idioma español da la sensación de que ya está cargando el menú correcto.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/05/2014 2:22 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Angel
 Angel
Usuario activo

No, Pablo,
Tengo contenidos para cada módulo en ES y RU por separado (tal y como lo adjunté en imágenes al mensaje en respuesta al tuyo), pero no se ve el Slider de la Galería principal en español (en ruso sí) ni el Servicios-JA Content slider (en ruso sí). Compara http://hispanorusa.com/webmethys/ (es la página de inicio en español) y http://hispanorusa.com/webmethys/ru (home en ruso). Y eso que están correctamente publicados los correspondientes módulos/menús/categorías/artículos.
Jhon sugirió que era por no haber habilitado un profile de la plantilla Methys a todos los idiomas (Menú por defecto), pero no me guarda los cambios cuando quiero que los profiles por idioma (en mi caso Default-es y Default-ru) sólo tengan unos contenidos seleccionados, me guarda sólo cuando hay al menos uno de estos perfiles habilitado para All (todas las páginas). Y creo que este es el origen de que no se vean dos módulos de esta plantilla en uno de los idiomas.
De hecho, ahora están adjudicadas All pages a la versión en español (!) y sin embargo no las muestra en español, sólo en ruso (vuelvo a pasar las imágenes).
Saludos

ResponderCitar
Respondido : 16/05/2014 2:49 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Prueba a editar el módulo "Servicios - JA Content Slider" que usas para mostrar el slider en español y en el parámetro Mostrar el título elige la opción Mostrar. Comprueba ahora si se muestra el título del módulo.

De ser así, significaría que el problema estaría en una mala configuración del módulo. Por ejemplo, podría ocurrir que estuvieras haciendo referencia a una categoría de artículos vacía o que no están correctamente configurados.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/05/2014 5:47 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Angel
 Angel
Usuario activo

Buenas Pablo,
Antes quise adjuntar más imágenes, pero no me dejó. Aquí te adjunto los pantallazos con "Mostrar" en ambos sliders (Servicios y Galería Principal).
Se muestra el nombre en ES, pero como si no viera los contenidos atribuidos a estos módulos.
Saludos

ResponderCitar
Respondido : 16/05/2014 7:01 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Angel

Veo que ya cambia correctamente el menú y algunos módulos el idioma español y ruso

Sin embargo veo que tienes problemas con el slide, verifica limpiando cache del template, con la galería configurado a Todos, si que debería mostrarse

Si sigues con problemas prueba una extensión de slide alterna y verifica si te sucede lo mismo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/05/2014 9:19 pm

Cursos Gratuitos WordPress

Angel
 Angel
Usuario activo

Buenas Jhon,
He limpiado el caché y persiste la visualización antigua. Muestra los módulos de Galería Principal y del Slider de servicios, tal y como lo sugirió Pablo en el anterior mensaje, pero no consigo dar con el error en su configuración (vuelvo a adjuntar la imagen de configuración).

He mirado con atención el video que me recomiendas y aunque cambiara el slider en uno de los idiomas o incluso en ambos, esto no quita el por qué no me aparece el segundo slider (Servicios-JAContent slider).

Puede haber algún error en cómo guarda los perfiles la plantilla Methys en ES y RU en mi caso concreto? Por qué no consigo guardarlo sólo con las páginas que les asigno a cada perfil?

Te adjunto css del trozo que aparece guardado y mi pregunta es: se puede "forzar" el cambio por css para que no aparezca All en ninguno de los idiomas publicados, sino que esté asignado únicamente al profile Default (con el Menú por defecto)?
O si es mejor no tocarlo, hay posibilidad de reescribir únicamente la carpeta de la plantilla Methys sin tocar el resto de carpetas?
Gracias

ResponderCitar
Respondido : 16/05/2014 10:48 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

En el caso del modulo puedes probar a seleccionar por un idioma especifico en este caso Ruso y no para todos los idiomas?

Verifica también que las asignaciones de los módulos sean para el idioma correspondiente.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/05/2014 2:17 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Angel
 Angel
Usuario activo

Buenas Johnny,
He asignado como predeterminado el idiomas ruso, con el mismo resultado.
He probado asignar los sliders que no se visualizan en ES a otros elementos de menús en ES y sí se muestran correctamente, incluso si están publicados en los mismos elementos de menús en RU (porque pensaba que podría darse una incompatibilidad por esto).
Pero no consigo que se vea ni en la Home page en ES (elemento menú principal CCHR) ni en las Noticias (que era la idea inicial que se viera la Galería principal de slideshow en estos dos elementos en ambos idiomas). Tampoco el Servicios - JA Content slider se visualiza justo en estos dos elementos del menú en ES (en ruso se ve correctamente en todas las páginas asignadas). Ejemplos:
http://hispanorusa.com/webmethys/es/noticias
http://hispanorusa.com/webmethys/novosti
http://hispanorusa.com/webmethys/es/import-export-es
http://hispanorusa.com/webmethys/import-export-ru
No sé qué tipo de error es, hay algún modo de "engañar" a ambos sliders en la versión en ES para que no califiquen los elementos de menú donde deben aparecer (CCHR y Noticias) como erróneos.
Saludos

ResponderCitar
Respondido : 17/05/2014 2:35 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Puedes adjuntarnos nuevas capturas sobre todo de los módulos para verificar en que punto te encuentras y verificar si detectamos un error.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/05/2014 7:04 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Angel
 Angel
Usuario activo

Hola Johnny,

He intentado de diferentes maneras "engañar" el menú principal en español para que me dé el resultado deseado, pero no lo consigo. Si tengo publicados en la página de Inicio o de Noticias la Galería Principal Slideshow, el Servicios-JA Content slider y las Pestañas con tabs correspondientes (Últimas noticias y +leído) - no me muestra los módulos publicados.
No obstante, si es en un elemento de Menú que no es de Inicio, se muestran todos los módulos correctamente.
Adjunto pantallazos.
He intentado asignar como Inicio un apartado que no lo es - deja de mostrar los módulos al vincularlo con la página de inicio en ruso. He clonado un apartado donde no se daba error y al publicar los tres módulos - Galería Principal/Servicios Ja Content/Pestañas y cambiar a "mostrar artículos destacados" - deja de mostrar los tres módulos.
Por si acaso están doblados todos los módulos en ES y RU, tanto de contenidos compartidos, como de contenidos por idioma).
En ruso está todo correcto y se asignan sin problemas los módulos.

ResponderCitar
Respondido : 18/05/2014 8:52 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro