Problemas con Phocamaps y joomla 2.5  

Página 1 / 2
 
Pere
 Pere
Estimable Member

Hola,

estoy colocando mapas de Phocamaps en categorias de menú de joomla y en categorias de k2 con marcadores con un link incorporado.
En el mapa que tengo incrustado en un menú de joomla me funciona bien,

però en los que tengo incrustados en las categorias de k2 me da errores:
· sombras blancas
· pixelados extraños
· los links no funcionan bien

Alguna idea?

Grácias!

Pere.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 30/04/2013 5:23 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Pere

Puedes enviar la url de tu sitio web para ambos casos y ver lo que comentas?

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/04/2013 6:37 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pere
 Pere
Estimable Member

Aqui es donde funciona bien:
http://www.clickandroute.com/ca/mapalocrutes

Y aquí es donde no funciona:
http://www.clickandroute.com/ca/rutes/a-peu

Grácias!

Pere.

ResponderCitar
Respondido : 30/04/2013 6:38 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Pere

Es posible que con k2 no funcione correctamente , aunque es extraño.
Prueba colocar el mismo mapa en ambos lugares y verifica si te sucede lo mismo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/04/2013 8:33 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pere
 Pere
Estimable Member

Saludos,

he hecho la prueba cammiando los mapas y me sigue ocurriendo lo mismo. No es cuestion entonces de un mapa o otro...

Alguna otra idea?

Grácias!

Pere.

ResponderCitar
Respondido : 02/05/2013 8:01 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Parece que se trata de un problema con los CSS del K2 que hace que imágenes que originalmente tienen el fondo transparente pasen a tenerlo blanco.

Prueba a editar el archivo templates/ja_university/css/k2.css y localiza el siguiente código:

div.itemListCategory img {  background: #fff;  display: block;  float: left;  margin: 0 20px 0 0;  padding: 0;}

Elimina de él el atributo background: #fff;. De esta forma se debería de solucionar el problema.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/05/2013 9:06 am

Cursos Gratuitos WordPress

Pere
 Pere
Estimable Member

Grácias,

estaba probando con este post:
http://www.phoca.cz/forum/viewtopic.php?f=38&t=21922

que dice lo mismo, pero no lograba encontrar el archivo... lo buscaba en k2 en vez del template.

Y funciona. De momento este paso está resuelto.

Ahora tengo el problema de las URL... se me coloca delante de la url:
"rutes/ca/"
y me sale una direccion que no existe:
http://www.clickandroute.com/rutes/ca/rutes/a-peu/item/129-el-perafita-i-el-monturull-els-dos-miradors-de-la-cerdanya
cuando la real es:
http://www.clickandroute.com/rutes/a-peu/item/129-el-perafita-i-el-monturull-els-dos-miradors-de-la-cerdanya

Grácias.

Pere.

ResponderCitar
Respondido : 02/05/2013 9:35 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Este otro tema ya tiene una solución más compleja ya que parece tratarse de un conflicto entre las urls amigables, el multilenguaje y el K2 o el Phocamaps.

En el campo de que puedas poner el enlace al agregar el punto al mapa prueba a colocar la ruta absoluta del enlace para ver si te funciona, es decir, poner también el nombre del dominio.

Supongo que desactivando las urls amigables los enlaces también deberán funcionar.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/05/2013 9:48 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pere
 Pere
Estimable Member

Saludos,

He probado con la desactivacion de las url amigables... y en algun caso ha funcionado pero en la mayoria me redireccionaba a una página de inicio con algunos errores.

Pero depende del momento me dereccionaba correctamente.

Tengo puesta asi la configuracion:

Grácias.

Pere.

ResponderCitar
Respondido : 02/05/2013 10:02 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Tendría que ver los enlaces sin las urls amigables para ver la diferencia entre los que funcionan y los que no. Está claro que si un enlace falla sin las urls amigables fallará con ellas activadas.

¿Has probado a poner la ruta absoluta de los enlaces como te he indicado?

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/05/2013 10:10 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pere
 Pere
Estimable Member

Saludos,

los enlaces estan puestos siempre con la ruta absoluta( p.ex.: http://www.clickandroute.com/ca/rutes/esqui-i-raquetes/item/29-el-bastiments-el-somni-hivernal)
, pero ahora estoy viendo que cuando se guarda la edicion del marcador de phocamaps solo conserva la url corta (/rutes/item/29-el-bastiments-el-somni-hivernal).

Tambien me pasa que de repente empiezan a funcionar los enlaces y al seguir probando dejan de funcionar, colocando otra vez la repeticion del directorio "/rutes/.." antes de la url correcta.

Gracias.

Pere.

ResponderCitar
Respondido : 02/05/2013 7:33 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

No me cuadra que te guarde solo la url corta. Tendría que tener la capacidad de poder guardar direcciones absolutas. Por ejemplo, si quieres enlazar con una url externa necesariamente tendrás que poner la dirección completa.

De todas formas, veo que estás haciendo algo que quizá esté provocando el fallo. Para colocar la url veo que estás usando la url amigable, lo que puede generar los problemas. Prueba a poner una url no amigable para los enlaces y luego prueba si funciona.

Ten en cuenta que si pones un enlace sin la url amigable y luego las activas, este enlace también se convertirá en el momento de cargar la página que lo contiene.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 03/05/2013 9:06 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pere
 Pere
Estimable Member

Gracias,

una pregunta absurda... una url amigable? como pongo una que no es amigable? que quiere decir?

Siento mi pregunta, pero aprendo poco a poco...

Saludos.

Pere.

ResponderCitar
Respondido : 03/05/2013 9:22 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Cuando activas el parámetro Motor de búsqueda para URLs amigables en la Configuración Global de Joomla las urls de tu web serán amigables. Si lo desactivas no.

Puedes ver la diferencia activando o desactivando el parámetro y comprobando las urls que se cargan en los distintos elementos de menú.

Ejemplo de url amigable: www.nombredetupaginaweb.com/prueba

Ejemplo de url no amigable: www.nombredetupaginaweb.com/index.php?option=com_content&view=article&id=68&Itemid=584

Para los enlaces que colocas en el Phoca Maps tendrías que probar a poner la url no amigable para ver si te funciona. Para obtener estas urls no amigables desactiva el parámetro en la configuración global y copia los enlaces que necesites. Una vez hecho esto puedes volver a activar el parámetro.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 03/05/2013 9:51 am

Cursos Gratuitos WordPress

Pere
 Pere
Estimable Member

Grácias,

gracias por la explicacion y la solucion.

He copiado las url no amigas y luego he reactivado las url amigables y parece que funciona.

Ahora solo tengo que poner los vinculos con url no amigables y no me da el problema.

Gracias y saludos!

Pere.

ResponderCitar
Respondido : 03/05/2013 10:03 am
Página 1 / 2

Por favor Iniciar Sesión o Registro