Sesiones joomla! 2.5.4  

 
Manuel
 Manuel
Usuario activo

Buenos días,
tengo una instalación de joomla! 2.5 que voy actualizando con admintools. También están instalados los componentes k2 y joomsocial.
Hasta la versión 2.5.3 podía tener abierta una sesión 'front-end' en una pestaña y otra 'back-end' en otra pestaña. Una vez actualizado a 2.5.4 ya no consigo tener las dos sesiones abiertas, si accedo a la administración se cierra la sesión del sitio, y si accedo al sitio, cierra la sesión de la administración.
Alguna idea?.... :blink:

URL del sitio: http://xxxix.quietor.com

Citar
Respondido : 20/05/2012 8:04 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Manuel,

Extraño eso que comentas :huh:

Entiendo que estas en Joomla! 2.5.4 y que usas un navegador estable y actualizado y que no tienes extensiones de seguridad que pudieran afectar.

¿Que tiempo de vida de sesión tienes habilitado para el backend en la Configuración Global?.
¿Tienes practicada alguna redirección por htaccess que pudiera afectar?.

Revisa el archivo /administrator/error_log y /public_html_error_log a ver si hay algo que pueda servirnos para interpretar el problema.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/05/2012 12:50 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Manuel
 Manuel
Usuario activo

Hola Luis,
Estoy con joomla 2.5.4, lo he intentado con los tres navegadores (chrome, ie y firrefox)
El tiempo de vida de sesión habilitado es de 30 minutos.
no encuentro el .httaccess, la última vez que lo vi estaba vacío.
En el httaccess.txt lo único que parece activo son asuntos de 'rewrite'.
Y los dos logs que me comentas están con las mismas lineas repetidas una y otra vez:

[20-May-2012 08:47:39] PHP Warning: Module 'suhosin' already loaded in Unknown on line 0
[20-May-2012 08:47:39] PHP Warning: PHP Startup: Suhosin Extension does not officially support PHP 5.2 and below anymore, because it is discontinued. Use it at your own risk. in Unknown on line 0

Gracias
Saludos

ResponderCitar
Respondido : 20/05/2012 4:11 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Manuel,

Parece que estás utilizando alguna extensión que requiere PHP 5.3 y de ahí los warnings que comentas.

¿Puedes descargar tu archivo /public_html/error_log, comprimirlo en .zip y adjuntarlo para que lo veamos?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/05/2012 4:22 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Manuel
 Manuel
Usuario activo

Aquí está

Saludos

ResponderCitar
Respondido : 20/05/2012 4:29 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Manuel,

Parece ser que arrastras el problema desde marzo ¿has instalado en tu Joomla! 2.5 alguna extensión que esté escrita para PHP 5.3?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/05/2012 4:58 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Manuel
 Manuel
Usuario activo

Estoy verificando la extensiones que tengo instaladas desde el 30 de marzo.
Hay otra cosa que a lo mejor tiene que ver: algo tocamos a principios de abril en php.ini debido a que suhoshin no me dejaba instalar una extensión (amoCourse) en otro subdominio. El ticket era CBB-635706.
Saludos

ResponderCitar
Respondido : 20/05/2012 5:06 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Manuel,

Efectivamente el problema radica en esa extensión que requiere de un filtrado de directivas de Suhosin para funcionar.

Parece ser que se desactivo para que pudieras instalar pero al volver a activarlo sigue marcando numerosos warnings en tu logs de errores.

NO he podido valuar la extensión amoCourse porque el JED (Joomla! Extensions Directory) la ha penalizado:

- http://extensions.joomla.org/extensions/living/education-a-culture/courses/7644

¿Para que utilizas la extensión?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/05/2012 5:49 pm

Cursos Gratuitos WordPress

Manuel
 Manuel
Usuario activo

Hola Luis,
AmoCourse es un gestor de cursos. (No de sus contenidos, sino de los propios cursos y sus reservas, gestión de plazas, etc.) Y lo cierto es que, dejando de lado los problemas de instalación, resulta bastante práctico.
Lástima que hayan optado por votos fraudulentos...
En todo caso, si realmente es el responsable de mis males, prefiero renunciar a usarlo.
Estos warning pueden ser los causantes de los problemas de sesiones?
Saludos

ResponderCitar
Respondido : 20/05/2012 8:17 pm
Manuel
 Manuel
Usuario activo

http://amotools.ch/index.php/products/1-amocourse-basic

ResponderCitar
Respondido : 20/05/2012 8:42 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Manuel,

Queda descartado que sea un problema de versión de PHP ya que esta extensión que comentas requiere:

PHP Version 5.2 or higher
MYSQLi Database type (changeable in Joomla global configuration)
MySQL Version 5.0.41 or newer

Y en tu caso se cumplen sin problemas.

Mira a ver si en tu gestor de plugins tienes habilitado Ultimate PNG Fix o similar y deshabilitalo y prueba nuevamente (tras limpiar la caché de tu navegador).

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/05/2012 8:47 pm

Por favor Iniciar Sesión o Registro