subdominio para realizar pruebas  

 
Jose Ángel
 Jose Ángel
Estimable Member

Hola, he decidido tener una web paralela para realizar pruebas de cambio de plugins y demas configuraciones y para tenerla de reserva. Es decir mi intención es trabajar con una nueva base de datos limpia migrando todo el contenido de un dominio a un subdominio que he creado llamado pruebas.joyayestilo.com.

Dicho subdominio se ha creado en la carpeta public_html/pruebas

he creado una nueva base de datos desde el asistente del cPanel, llamada: joyayest_pruebas.
usuario: joyayest_pruebas (todos los permisos efectuados)
contraseña: pruebas.

Con la herramienta akeeba backup he generado un respaldo (jpa) que me he descargado.

En la carpeta public_html/pruebas he subido el fichero kickstart-core-4.0.0.zip y posteriormente el fichero jpa del respaldo.

He seguido todos los pasos bien, he descomprimido el fichero kickstart y borrado el comprimido. Con lo cual se mantienen en el directorio el jpa y los descomprimidos del kickstart. He lanzado el instalador poniendo en la barra de direcciones pruebas.joyayestilo.com/kickstart.php y ha empezado el instalador con normalidad. Me ha encontrado el fichero jpa en el listado sin problemas, he elegido elegir método de extracción: Directamente y hasta ahí todo bien.

Pero cuando llega a la pantalla de reconocimiento del servidor me ha dado un fallo, ya no he podido ver la siguiente pantalla donde se elige el nombre de servidor, base de datos, usuario, etc...

Con lo cual no he podido elegir que mi nueva base de datos, donde quiero que se instale todo sea en la de joyayest_pruebas que era mi intención.

Hay dos capturas de pantalla que he cogido de otro sitio en el que si salen las pantallas que deberían salir y otras capturas de pantalla con los fallos que salen en mi web, asi como la demostración de la creación del subdominio y bases de datos correctamente.

No entiendo lo que está pasando. Encima es curioso, porque aunque da fallo el instalador, la web se vuelca en el subdominio pero utilizando la misma base datos que tiene en el dominio.

Por favor me urge solución pronto para poder realizar pruebas en el subdominio con la nueva base de datos creada. Gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 06/05/2015 11:23 am
Julen
 Julen
Miembro Admin

Hola,

Puede ser que la base de datos que nos comentas este dañada. Desde el panel de administración de la web puedes ir a Gestor de Extensiones => Base de Datos => Reparar. Una vez realizada la reparación, verifica nuevamente.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 06/05/2015 11:44 am

Cursos Gratuitos WordPress

Jose Ángel
 Jose Ángel
Estimable Member

¿Cual está dañada?, ¿La recién creada que está vacía? ¿Como puede ser? ¿cual de las otras 3 es la que estoy actualmente utilizando desde las restauraciones realizadas en su momento?, ¿Como puedo saberlo?

joyayest_pruebas (nueva, recién creada y vacía)

joyayest_phtw1
joyayest_ptbw1
joyayest_ptc1

Aun así esa comprobación ha hecho y sigue igual el asunto. Sin solución. (Panel de administración de la web puedes ir a Gestor de Extensiones => Base de Datos => Reparar)

ResponderCitar
Respondido : 06/05/2015 3:03 pm
Rafael
 Rafael
Miembro Moderator

¡Hola Jose Ángel!

Accediendo a tu página web compruebo que no veo errores aparentemente desde el front-end del sitio en la página clonada.

Entiendo que tienes problemas con poder subir la base de datos del sitio de producción. Para ello, te recomiendo leer el siguiente artículo y seguir los pasos para clonar correctamente tu sitio Joomla:

https://www.webempresa.com/blog/clonar-joomla-desde-el-panel-de-administracion-del-hosting.html

Revisa el vídeo y comprueba que todo se realiza sin ningún inconveniente incluyendo el paso de copiar la base de datos del sitio en producción.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 06/05/2015 4:43 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jose Ángel
 Jose Ángel
Estimable Member

Hola Rafael, el video está muy bien pero es algo complicado para mi manejarme tanto por cambios de registro de ficheros y demás. Además es un poco obsoleto viendo la versión de Joomla que es la 1.5.

Te comento, ahora mismo la carperta llamada pruebas dentro de public_html está vacía. La base de datos pruebas mirando el phpMyAdmin también está vacía.

El subdominio creado para las pruebas "pruebas.joyayestilo.com" está funcionando pero ligado al dominio, me explico. He realizado un pequeño cambio en dicho subdominio de unos textos y se ve reflejado también en el dominio principal. NO ESTÁN TRABAJANDO POR SEPARADO EVIDENTEMENTE.

He utilizado el akeeba backup y el kikckstart en muchas webs fuera de webempresa y no he tenido problemas de ningún modo.

Quiero trabajar en un subdominio aparte con una base de datos nueva migrando toda la información del dominio. Incluso debería haber una herramienta desde el cPanel que lo hiciera sin tener que utilizar el akeeba,no?

Esto es asi por si tengo que tocar cosas aparte de joomla, de la base de datos o lo que sea en esa segunda nueva metiéndome en el subdominio. Es como tener 2 webs trabajando por separado.

Por favor dígame solución a mi problema con akeeba u otra manera de hacerlo. Gracias.

ResponderCitar
Respondido : 07/05/2015 12:53 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Ambos sitios web apuntan a la misma BD, tendrías que migrar la BD a tu BD de pruebas y luego cambiar la configuración de conexión en tu archivo pruebas/configuration.php

Si te complica mucho será mejor hacer una copia con Akeeba y restaurarlo en el directorio, igual tienes que crear una nueva BD y usuario de BD para usarlo con el clon

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/05/2015 7:59 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose Ángel
 Jose Ángel
Estimable Member

Pero si lo hago con akeeba, en el kickstart me debe preguntar que base de datos quiero utilizar para funcionar y no sale dicha opción, se queda la instalación a medias como he comentado en este hilo anteriormente. Puedes ver las capturas

ResponderCitar
Respondido : 08/05/2015 12:14 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En lugar de utilizar el Akeeba Backup con el que estás teniendo problemas pruebas a utilizar el componente XCloner que te permite hacer y lo mismo, y comprueba si así te deja hacer la restauración sin problemas.

En el siguiente artículo de nuestro blog se explica el uso del XCloner:

https://www.webempresa.com/blog/copias-de-seguridad-con-xcloner-backup-en-joomla-15-25-y-30.html

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/05/2015 3:20 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Por favor Iniciar Sesión o Registro