Avisos
Vaciar todo

web móvil  

 
Aida
 Aida
Reputable Member

Buenas tardes!

En la web que acabo de hacer www.tspsurf.com cuando la cargo desde el móvil no me sale el menú principal.

Sólo he podido probar en un móvil Android, sale todo perfecto excepto el menú ¿a qué puede deberse?

La plantilla que ultilicé es de la Zenbase de Joomlababoo:

http://www.joomlabamboo.com/joomla-templates/zenbase

Gracias
Aida

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 02/07/2013 4:54 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Aida

La plantilla es Responsive Design, debería aparecerte tal como se ve en la pantalla adjunta, un ícono suporior que genera el menú

Sin embargo lo he probado en iphone, no se muesra el icono pero si que se muestra el borde del botón a través del cual accedes al menú

Si no has realizado modificaciones, debe ser un problema de la plantilla o un conflicto con alguna extensión, prueba despublicar extensiones que hayas instalado recientemente y verifica si te pasa lo mismo.

Saludos.

ResponderCitar
Respondido : 02/07/2013 6:43 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Aida
 Aida
Reputable Member

Hola!!

Pues en la plantilla yo no he realizado modificaciones, me ocurre desde el principio que empecé a crear la web (antes de publicarla) así que debe ser problema de la plantilla.

Intentaré solucionarlo añadiendo un menú inferior con las opciones del menú principal

Gracias
Aida

ResponderCitar
Respondido : 04/07/2013 12:17 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

He probado a abrir tu web con un móvil con Android y sí que veo en la parte superior un botón, aunque sin el icono dentro de él. Al pulsar se me despliega el menú.

He probado a abrir la plantilla de la que has partido:

http://bambootheme.com/showcase/zenbase/

En este caso sí que se muestra el icono dentro del botón.

Comparando tu plantilla con la demo veo que sí que hay cambios. Por ejemplo, el menú se muestra centrado. Es posible que alguno de estos cambios pueda haber afectado a la web.

También podrías probar si el problema puede estar provocado por el multilenguaje. Prueba a desactivarlo para ver si así carga bien el botón que despliega el menú.

ResponderCitar
Respondido : 04/07/2013 1:44 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Aida
 Aida
Reputable Member

Hola Pablo!

Pues ahora al decirme tú que has probado en un Android y te sale el botón he probado en otro distinto al mio y sí que sale el botón y al pulsar sale el menú.

Yo tengo un LG Optimus L5 y no sale nada, he probado en un Samsung y sale el botón y el menú.

Probé tambien a desactivar el multilenguaje y no hay diferencia, tampoco al cambiar el menú de posición...

Voy a intentar probar en diferentes teléfonos..

Saludos,
Aida

ResponderCitar
Respondido : 04/07/2013 4:48 pm
Rafa Noguera
 Rafa Noguera
Miembro Admin

Hola Aida,

añadiendo la siguiente regla CSS a tu hoja de estilos se debería de solucionar el problema.
La regla CSS es ésta:

.icon-list-ul:before {
content: "f0ca";
}

Lo que hace esta regla CSS es añadir un contenido a ese espacio que ahora está vacío, para que de esta forma el botón sea identificable para los usuarios que acceden la web con dispositivos móviles.

Recuerda hacer una copia antes de editar el fichero CSS para poder reponerlo en caso de haber cualquier problema.

Espero que te sirva.

Saludos,
Rafa Noguera

ResponderCitar
Respondido : 04/07/2013 5:46 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Aida
 Aida
Reputable Member

Hola!

Gracias por la respuesta, he probado como me indicas a añadir la regla CSS que me indicas pero no ha cambiado nada, sigue sin salir el botón.

Entiendo que el archivo CSS en el que debo añadir la regla es el archivo template.css de la ruta

/templates/zenbase/css/template.css

La he puesto al final de todo pero de momento no ha habido cambios.

Aida

ResponderCitar
Respondido : 08/07/2013 5:12 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Aida

En el código anterior, modifica por lo siguiente :

.icon-list-ul:before {
content: "menu";
display:block;
}

Es decir estas forzando a mostrar un texto y también a que se muestre como bloque

Saludos.

ResponderCitar
Respondido : 08/07/2013 9:19 pm

Cursos Gratuitos WordPress

Aida
 Aida
Reputable Member

Hola Jhon!

He probado pero no hay cambios.

Te adjunto el archivo template.css por si vieras algo que modificar.

Gracias
Aida

ResponderCitar
Respondido : 09/07/2013 10:35 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Abriendo tu página con Android ahora sí que veo el texto "Menú" en el botón superior. Si no lo ves, es posible que tengas cacheados los estilos CSS en el navegador de tu móvil. Prueba a abrir de nuevo la página o utiliza otro teléfono para ver si se muestra el texto.

ResponderCitar
Respondido : 09/07/2013 12:50 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Aida
 Aida
Reputable Member

Hola Pablo!

Pues tienes razón!! Probé en otro Android distinto y se ve el menú..

Muchisimas gracias y disculpa las molestias!!

Saludos,
Aida

ResponderCitar
Respondido : 09/07/2013 4:30 pm