Avisos
Vaciar todo

Actualizacion a Joomla 4.0.0  

 
Jose Manuel
 Jose Manuel
Estimable Member

Buenas tengo el Joomla 3.9.9 y dúrate esta semana me pide que actualice al Joomla 4.0.0 hoy lo he hecho y cuando ha finalizado me ha dado un error

(adjunto captura de pantalla) he tenido que hacer un super backups para volver a la versión anterior.

alguien sabe que se puede hacer para poder actualizar sin problemas?

error
error2

 

un saludo

Jose manuel

Contenido solo visible a usuarios registrados

Citar
Respondido : 22/08/2021 11:13 am
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Jose,

Has realizado todo el procedimiento tal como lo indican en la documentación oficial de joomla?

https://docs.joomla.org/Joomla_3.x_to_4.x_Step_by_Step_Migration

Verifica esta misma antes de realizar cualquier ajuste y nos comentas.

Un saludo 🖐️ 

ResponderCitar
Respondido : 22/08/2021 2:20 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose Manuel
 Jose Manuel
Estimable Member

@argenis

te adjunto unas capturas porque en mi administrador no veo lo mismo que las instrucciones que me has enviado

Extensions: Gestionar no veo lo mismo

joomla232
joomla 231

 

ResponderCitar
Respondido : 23/08/2021 9:17 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Jose Manuel.

El aviso es por alguna función que no esta definida.

Revisando los log veo el siguiente error:

[23-Aug-2021 10:51:15 Europe/Berlin] PHP Notice:  Only variables should be assigned by reference 
in /home2/empordad/public_html/templates/gk_news2/lib/framework/helper.cache.php on line 102 [23-Aug-2021 10:51:16 Europe/Berlin] PHP Deprecated: strpos(): Non-string needles will be interpreted as strings in the future.
Use an explicit chr() call to preserve the current behavior in /home2/empordad/public_html/libraries/src/Filesystem/Folder.php on line 259

Este error es de la plantilla que etas utilizando gk news2.

Por lo que veo no es compatible con Joomla 4:

-> https://www.gavick.com/forums/news2

 

Antes de actualizar tienes que revisar si las extensiones ( Módulos, plugins, componentes ) y la plantilla son compatibles con la nueva version de Joomla.

 

Tendras que consultarlo con el soporte de la plantilla si hay alguna actualización disponible para Joomla 4

 

Un saludo

 

ResponderCitar
Respondido : 23/08/2021 10:07 am

Cursos Gratuitos WordPress