Actualización fálli...
Avisos
Vaciar todo

Actualización fállida de Joomla y Virtuemart, con actualización plantilla y PHP a 8  

 
Alceste
 Alceste
Noble Member

Hola

Debemos hacer una actualización de Joomla y Virtuemart, con actualización plantilla y PHP. No queremos pasar a Joomla 4 por el momento.

Hemos descargado la plantilla Storebox correspndiente y la hemos actualizado

Tenemos Joomla 3.10 y hemos actualizado a 3.10.11

Tenemos Virtuemart 3.8.9 y hemos actualizado a 4.0.6

Hemos actualizado tambuién algunos modulos y componentes.

El resultado es que no funciona bien. Algunos títulos se muestran mal a nivel de presentación, pero lo peor es que no llega a verse la página del carrito al final de la compra.

Les comprato el mensaje enviado a los desarrolladores de la plantilla:
 
Instalé el archivo gk_storebox_4.1.zip. de la plantilla y la instalación fue correcta. El producto se podía agregar al carrito, pero en el último paso, la página desaparecía. Salía un error en el carrito de la virtudmart. Muestraba un error 500.
 
Así que restauré una copia de seguridad.
 
Para volver a intentarlo, necesito que me aclaren algunas dudas.
¿En qué orden deben ser las actualizaciones?
Hice las actualizaciones en este orden:
 
1ra plantilla de actualización
2.º actualizar algunos complementos
3ra actualización de PHP 7.4.3 a PHP 8
4 actualizar Joomla 3.10 a Joomla 3.10.11
5 actualizar Virtuemart 3.8.9 a 4.06
 
¿Es correcto? ¿O debe actualizar en otro orden? ¿Debí usar una versión anterior de virtuemart y no la que aparecía en el panel de Joomla?
 
Gracias por vuestra ayuda
Saludos
 
 

 

 

Contenido solo visible a usuarios registrados

Citar
Respondido : 10/11/2022 9:51 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alceste.

¿Es correcto? ¿O debe actualizar en otro orden? 

El orden en el que lo actualices no importa aunque yo empezaria por Joomla.

Sobre el tema del error 500 puede ser por la versión de PHP, si te pasa intenta bajar la version de PHP y revisa si carga.

Tienes que tener en cuenta que todas las extensiones, plantilla y Joomla tiene que soportar esa versión, por ejemplo Joomla 3x soporta la versión 8 de PHP pero no la versión 8.1

 

Un Saludo

 

ResponderCitar
Respondido : 10/11/2022 12:21 pm

wpdoctor-revisa-la-salud-de-tu-wordpress