Avisos
Vaciar todo

Bloquear URLs con caracteres  

Página 1 / 2
 
Domingo
 Domingo
Estimable Member

Bloquear URLs con caracteres
Hola, quiero evitar que ciertas URls que crea el sistema de Joomla en exceso la pueda bloquear por el robot TXT, por ejemplo, esta:
https://www.ruthmontenegro.com/index.php?option=com_content&view=article&id=101:videntes-famosos-del-mundo&catid=10&Itemid=418
¿este código es correcto para que no se indexen?
Disallow: /*.index.php?$
Y por supuesto quisiera saber si esto puede perjudicar para que se indexen las URLs que, si son correctas, que son todas amigables, en este caso esta es la correcta a la que pongo anteriormente:
https://www.ruthmontenegro.com/blog/videntes/101-videntes-famosos-del-mundo
Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 29/04/2017 3:40 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Domingo,

Antes de indicarte que regla de robots.txt seria la adecuada y basándome en la url "no amigable" que adjuntas que más bien parece una url de versión imprimible o PDF, indícame ¿tienes activado en Joomla las opciones de Impresión, PDF y e-mail?

Saludos

ResponderCitar
Respondido : 29/04/2017 10:52 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Domingo
 Domingo
Estimable Member

Estan desactivados, aqui te dejo otra que es de un error 404 y tambien con parametros https://www.ruthmontenegro.com/index.php?option=com_con...mundo&catid=10&Itemid=418

Saludos

ResponderCitar
Respondido : 30/04/2017 12:20 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Domingo.

Si dejas de indexar .index.php lo que estas realizando es que no indexe la pagina de inicio, nada aconsejable para el SEO.

Si tienes las URL amigables activas no tendría que mostrarse la URL que indicas, tendría que cargar con la segunda URL que indicas.

Donde te marca esos avisos ¿ En search ?, lo que puedes realizar es un direccionamiento de una URL a la otra, por ejemplo.

Redirect 301 /index.php?option=com_content&view=article&id=101:videntes-famosos-del-mundo&catid=10&Itemid=418  https://www.ruthmontenegro.com/blog/videntes/101-videntes-famosos-del-mundo 

Fíjate en que la primera URL no incluye el dominio y la otra sí.

Esto se realiza en el archivo htaccess de tu instalación.

Un saludo

ResponderCitar
Respondido : 30/04/2017 12:50 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Domingo
 Domingo
Estimable Member

Buenos dias, tengo activada las URLs amigables. Las URls que te indico con los parametros me las esta indexando google. He probado el redirecionamiento tal y como me indicas y no me funciona (adjunto el htacces), pero no es posible algun tipo de regla para poner en el robot.txt o en el htaccess, que impida que se indexen este tipo de URLs, son demasiadas para poner tantos redirecionamientos, aunque tambien me interesaria conocer una regla que sirva para redirecionar una URL de parametos a otra que sea amigable, tambien le dare un bue uso.

Gracias como siempre por vuestra colaboración.

ResponderCitar
Respondido : 30/04/2017 12:59 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Domingo.

Dices que esas URl te las indexa google, supongo que te refieres a que google search tienes el avisos 404.

Estos avisos pueden ser debidos a que en su momento o bien cambiaste de plantilla, activaste las URL amigables o cambiaste la jerarquía de las categorías despues de mandar el sitemap a google

Para solucionarlo tienes que volver a generar sitemap, marcar los avisos como solucionados en search y volver a mandar el sitemap nuevo a google.

Un saludo

ResponderCitar
Respondido : 30/04/2017 8:45 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Domingo
 Domingo
Estimable Member

Hola, estas URLs no me salen en la Google Search Console las encuentro con el comando site en Google y es de aqui de donde quiero eliminarlas.

Saludos

ResponderCitar
Respondido : 01/05/2017 1:33 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Domingo:

Si utilizo el comando site en el navegador no veo esos enlaces que nos indicas:

Lo que tienes que comprobar es que en la consola de serach no te marque ninguna URL con el aviso 404.

Un saludo

ResponderCitar
Respondido : 01/05/2017 2:06 pm

Cursos Gratuitos WordPress

Domingo
 Domingo
Estimable Member

Hola, el problema es que si son URls que no dan error 404 no aparecen en la consola y tambien necesito eliminarlas, te adjunto un pantallazo de la primera que encontre, no tengo muchas pero si las suficientes para querer eliminarlas de las busquedas.

Saludos

ResponderCitar
Respondido : 03/05/2017 9:02 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Qué término de búsqueda usas para que te aparezcan esos resultados?

De manera general puedes hacer una redirección 301 de esas urls, el robots.txt no sería adecuado para esto.

Saludos.

ResponderCitar
Respondido : 03/05/2017 11:24 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Domingo
 Domingo
Estimable Member

Hola, utilizo el comando site:

Saludos

ResponderCitar
Respondido : 04/05/2017 12:50 pm
Julen
 Julen
Miembro Admin

Hola,

En ese caso, lo mejor es que realices un redireccionamiento 301 para evitar errores 404 . Tienes que crear redirecciones 301 por cada url incorrecta que Google tenga indexada exista o no exista.

Si no existe lo recomendado es que la envies a la portada de tu web www.tudominio.com

Revisa: https://www.webempresa.com/blog/redirecciona-urls-de-forma-correcta-usando-cpanel-y-htaccess.html

ResponderCitar
Respondido : 04/05/2017 1:13 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Domingo
 Domingo
Estimable Member

Hola Julen,
Con los errores 404 no tengo problemas y se que tengo que hacer redireciones 301 pero cuando la URL es de parametros creados por joomla no son errores 404 y son estas URLs que ha indexado Google las que necesito eliminar de las busquedas, y para las que busco una solucion.
Por ejemplo esta https://www.ruthmontenegro.com/index.php?option=com_content&view=article&id=101:videntes-famosos-del-mundo&catid=10&Itemid=418 URLs como estas que aparecen son las que quiero eliminar en lo posible

Saludos

ResponderCitar
Respondido : 04/05/2017 2:10 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es posible que google te haya indexado estas urls cuando aún no configurabas totalmente tu sitio con urls amigables.

En este caso también puedes crear una redirección 301, de la url no amigable
Contenido solo visible a usuarios registrados

A la url amigable, ya que entiendo que quieres mantener indexado este contenido.

Saludos.

ResponderCitar
Respondido : 04/05/2017 7:04 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Domingo
 Domingo
Estimable Member

Hola, exacto esta indexada y quiero que se indexe la correcta, peor no me ha funcionado nada de lo que me indicas y yo tampoco consigo encontrar la forma de que estas URls con caracteres se redirijan.

Saludos

ResponderCitar
Respondido : 05/05/2017 11:59 am
Página 1 / 2