Avisos
Vaciar todo

El simulador Stephane me indica que tengo un error fatal.  

 
Pedro
 Pedro
Estimable Member

Después de una comprobación con el simulador Stephane, el resultado ha sido este:

[01-Oct-2014 22:54:21 Europe/Berlin] PHP Fatal error: Call to a member function get() on a non-object in /home2/publicos/public_html/components/com_k2/models/item.php on line 554

Resulta que ayer y en este foro también comentamos otros errores del estilo y después de desactivar el componente Ja k2 filtre de joomlart dimos el problema por resuelto.

Ahora tengo este error, que parece el mismo.

¿Que puedo Hacer?

Muchas gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 02/10/2014 1:48 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica si dispones de alguna actualización del componente k2, si existe una disponible aplica la actualización elimina el fichero error_log y comprueba si el error persiste.

ResponderCitar
Respondido : 02/10/2014 2:28 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pedro
 Pedro
Estimable Member

Hola,

Mi versión del K2 es V2.6.8 y parece que no hay ninguna actualización. El caso es que este error se produce a las 22:54 y resulta a las 22:30, actualice mi joomla de la versión 3.4 a la 3.6.

¿Tiene algo que ver?

¿Que debo hacer ahora?

Gracias.

ResponderCitar
Respondido : 02/10/2014 7:56 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Pedro,

Creo que lo mejor es volver el sitio web a un estado anterior antes de la actualización.

Revisa el siguiente enlace para restaurar archivos, directorios, emails o cuenta completa fácilmente desde tu panel de control cPanel: http://wiki.webempresa.com/Restaurar_Copia_cpRemote

Una vez hayas restaurado y funcione correctamente, creo que es mejor que realices un clon del sitio web en otro directorio y probar a actualizar, de esa forma si hay errores no hay la urgencia de solucionar en un sitio web en funcionamiento, y una vez se hayan corregido realizar los mismos pasos en el otro sitio web.

En http://forum.joomla.org/viewtopic.php?f=615&t=859096 tienen el mismo error, pero de momento no hay respuesta a esa consulta.

Saludos

ResponderCitar
Respondido : 02/10/2014 11:39 am

Cursos Gratuitos WordPress

Pedro
 Pedro
Estimable Member

Hola,

¿Y que ocurre si no restauro la copia ya que esto supondría perder todas la modificaciones que se realizaron ayer y que fueron numerosas?

¿Este error puede afectar de forma critica nuestro sitio?

Muchas gracias.

ResponderCitar
Respondido : 02/10/2014 1:03 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Por regla general, tienes que acostumbrarte a realizar una copia de seguridad completa de la web cada vez que vayas a actualizar Joomla o algún componente importante para, una vez actualizado, poder realizar pruebas varias en la web y comprobar si todo va bien, de forma que, si no es así, puedas restaurar esta copia de forma que no pierdas datos.

Por lo que se muestra en ese log, el error parece estar en el componente K2. Sin embargo, probando a navegar por tu web y, en concreto, en páginas que cargan K2 no veo que se produzca ningún error. Por tanto, es posible que no sea necesario aplicar ningún cambio.

Te aconsejo realizar pruebas en tu web y comprobar si después de esto se muestran nuevos errores en el log con fecha posterior al que se mostraba.

ResponderCitar
Respondido : 02/10/2014 1:37 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress