Avisos
Vaciar todo

Error actualización PHP  

 
David
 David
Prominent Member

Buenos días,
Tenemos problemas al actualizar la versión de PHP. En el back end nos aparece un mensaje constante. Lo copio debajo. Sin embargo cuando subimos a cualquier versión superior a la que hay actualmente, tanto el back end como el front end se bloquea y tenemos que retroceder a copia de seguridad anterior.

Buscamos errores con ayuda de soporte y parecía que el componente K2 era el que generaba el conflicto. Aunque en realidad , nunca instalamos k2. Borramos todas las carpetas que pudieran tener este nombre (pues no aparecía en componentes, modulos ni nada similar en nuestro backend). Pero segumos sin poder actualizar la versión de PHP en esta web.

Y no sabemos el motivo ni en qué puede afectar, además del molesto mensaje de que hay un error PHP en nuestro backend.

[19-Apr-2019 08:13:10 Europe/Berlin] PHP Notice: Use of undefined constant DS - assumed 'DS' in /components/com_k2/lib/k2plugin.php on line 15
[19-Apr-2019 08:13:10 Europe/Berlin] PHP Notice: Use of undefined constant DS /isp-audio/administrator/components/com_k2/lib/k2plugin.php on line 15
[19-Apr-2019 08:13:10 Europe/Berlin] PHP Notice: Use of undefined constant DS - assumed 'DS' in public_html/isp-audio/administrator/components/com_k2/lib/k2plugin.php on line 15

"Error
Hemos detectado que su servidor está usando PHP 7.0.33 el cual está obsoleto y ya no recibe actualizaciones de seguridad oficiales de sus desarrolladores. El Proyecto Joomla! recomienda actualizar su sitio a PHP 7.1 o posterior ya que recibirá actualizaciones de seguridad al menos hasta 01-12-2019. Por favor, pídale a su proveedor que PHP 7.1 o una versión posterior sea la versión predeterminada para su sitio. Si su proveedor ya está preparado para PHP 7.1, active PHP 7.1 en los directorio raíz y 'administración' de su sitio. Normalmente, puede hacerlo a través de una herramienta en su panel de control de alojamiento, pero si no está seguro es mejor preguntar a su proveedor."

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 15/05/2019 10:46 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola David.

Los errores que muestras son del componente K2, este componente es para crear artículos
¿ Utilizas el nativo de joomla o K2 ?
¿ Desde el administrador de joomla no puedes eliminarlo o no aparece ?

Si no lo utilizas y no puedes eliminarlo desde el administrador:
.- Accede a la carpeta isp-audio ->components y renombra la carpeta " com_k2 "
.- Accede a la carpeta administrator -> components y renombra la carpeta " com_k2 "
.- Accede a la carpeta modules y renombra todas las carpetas " mod_k2_xxx "

Revisa si después de esos pasos puedes actualizar la versión de PHP

Un saludo

ResponderCitar
Respondido : 15/05/2019 11:55 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Prominent Member

Hola Pepe,
Si vimos que era por ese motivo. Lo curioso es que nunca instalamos K2 en esta web. Habiamos renombrado algunas carpetas, pero al seguir ahora tus "rutas" vemos que hay más en modules y administrador que no habiamos renombrado.

Les he añadido BAK al final (a todas). Supongo que ahora deberíamos intentar ir a una versión más alta de PHP otra vez a ver si da guerra ¿no?

Muchas gracias

ResponderCitar
Respondido : 16/05/2019 12:24 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola David.

Exacto revisa si cambiando la versión de PHP ya no te aparecen eso errores, si ves que aparecen otros errores deja la versión de PHP que instalaste y revisamos si entra en conflicto con alguna otra extensión.

Un saludo

ResponderCitar
Respondido : 16/05/2019 12:56 pm

wpdoctor-revisa-la-salud-de-tu-wordpress