Avisos
Vaciar todo

Error en el administrador en la configuración global  

 
Lorenzo
 Lorenzo
Estimable Member

Hola.
Desde hace algunas actualizaciones (no se exactamente cuando) no puedo modificar la configuración global del joomla ya que no me aparecen los botones de guardar, guardar y cerrar o cancelar.

Hemos cambiado los permisos del config.php, y no conseguimos nada.

Tenemos estos dos errores que no sabemos como quitarlos:
[06-Aug-2018 10:44:21 Europe/Berlin] PHP Warning: ini_set() has been disabled for security reasons in /home/suformac/public_html/libraries/joomla/session/handler/joomla.php on line 48
[06-Aug-2018 10:44:21 Europe/Berlin] PHP Warning: ini_set() has been disabled for security reasons in /home/suformac/public_html/libraries/src/Session/Session.php on line 944

Hemos cambiado las dos plantillas que tenemos para el administrator y no salen con ninguno de los dos.

Alguien sabe que podemos hacer

adjunto una captura de pantalla del error que da en el administrator, ademas de no aparecer los botones.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 06/08/2018 12:05 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Lorenzo.

Por el aviso parece que es problema de versión de PHP.
.- Revisa la version de PHP que tienes instada para ese dominio, por el aviso tienes que tener instalada la versión 5.3
.- Desde tu cuenta de cPanel -> Software -> Configurar PHP, selecciona la versión 5.6 o superior para el dominio Contenido solo visible a usuarios registrados

Solo tienes que seleccionar la versión desde el desplegable y esto es reversible, es decir, si vieras que tu web no responde bien con esa versión, siempre puedes seleccionar la que tenias antes.

Un saludo

ResponderCitar
Respondido : 06/08/2018 1:03 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Lorenzo
 Lorenzo
Estimable Member

Hola Pepe.

Hemos puesto la versión 5.6 de php y el resultado es mucho peor, hasta pierde los estilos y tampoco salen los botones para guardar los cambios, he pasado a la versión 7.2.8 y ya me sale con el estilo normal, pero no se soluciona el problema de los botones.

ResponderCitar
Respondido : 06/08/2018 2:32 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Lorezno.

¿ Tuviste algún problema de infección en la web, malware, spam, etc... ?
.- accede a la carpeta libraries -> joomla -> database -> driver y revisa si tienes un archivo con el nombre " bclass.php "

Si lo tienes lo renombras por ejemplo " bclass_old.php " y revisa si se soluciona el problema.
Si da resultado y se soluciona, elimina el archivo.

Un saludo

ResponderCitar
Respondido : 06/08/2018 5:16 pm

Cursos Gratuitos WordPress

Lorenzo
 Lorenzo
Estimable Member

Hola Pepe.

Efectivamente borrando ese fichero se soluciona el problema.

Muchas gracias.

ResponderCitar
Respondido : 08/08/2018 2:38 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Lorenzo.

Genial !!! me alegra que lo solucionaras.
Ya sabes, cualquier consulta que tengas no dudes en comunicarlo.

Cerramos el tema.

Un saludo

ResponderCitar
Respondido : 08/08/2018 2:57 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress