Error en lenguaje prederteminado (es-ES) al migrar a joomla 3.3.6  

 
David Gómez
 David Gómez
Usuario experto

Hola:

Quiero hacer la página de mi casa rural en varios idiomas y he decidido optar ya por joomla 3. Es la última
versión 3.3.6. He querido hacerla en esta versión por hacerlo en una plantilla nueva que me gustó. Es una página bastante sencilla y creo que no habrá mucho problema.

Ayer hice un backup con akeeba y desinstalé todos los plugins, componentes,... que no eran de joomla limpio. Comencé una migracion desde joomla 2.5.28 a 3.3.6 y todo fue perfecto pero al final del día me dí cuenta que el idioma español es-ES aparece en FE, pero en BE sólo aparece en "Contenido", pero no en "Instalado-Administración" ni en "instalado-Sitio", aunque en BE se sigue viendo en español. Muy raro.

Es decir, todo funciona correctamente, pero el predeterminado es-ES no aparece como instalado. Se ve en español en BE y en FE pero en administrador no aparece como instalado.

Si le instalo el español de nuevo tampoco se arregla. He metido el paquete de joomla entero en español y tampoco. Si cambio de predeterminado ya no puedo volver a usar es-ES.

Lo único raro que veo es que aparece instalado como componente una cosa que aparece como pkg_es-es. Adjunto pantallazo.

Aún siendo el es_ES el predeterminado aparece así en gestor de idiomas:

Creo que es de la base de datos, pero no sé cual puede ser el problema.La version php es 5.3.29, de base de datos 5.5.40-cll y el cotejamiento de lenguaje latin1_swedish_ci (no sé si debo cambiarlo de alguna manera)

Sólo he instalado xmap, K2 y phocamaps.

Tampoco aparece en instalación directa el español desde el gestor de idiomas. Si le das a instalar no aparece en la lista, por lo que creo que lo entiendo como que ya está instalado.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 14/01/2015 8:04 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola David,

Lo de pkg_es-es creo que es posible que sea debido a Akeeba Backup. Procede a desinstalarlo.

Te muestra algún mensaje Joomla! referente a la actualización. ¿Tienes alguna advertencia en extensiones --> gestor de extensiones --> advertencias?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 14/01/2015 9:21 am

Cursos Gratuitos WordPress

David Gómez
 David Gómez
Usuario experto

No aparece ningún tipo de advertencia. Puede ser por el js. del componente k2.

¿Quieres una cuenta de usuario para entrar en administración?

ResponderCitar
Respondido : 14/01/2015 9:52 am
David Gómez
 David Gómez
Usuario experto

Hola:

Lo he solucionado. Una tontada. Al hacer la migración se debe borrar o dehabilitar el lenguaje de joomla anterior a la migración.

Simplemente cargáis :ohmy: el paquete de idioma por el gestor de extensiones. Vais a gestionar extensiones, idiomas y habilitas el que deseéis.

Está más escondido que en joomla 2.5.

FALTA DE COSTUMBREEEEEEE!!!

Gracias de todos modos

ResponderCitar
Respondido : 14/01/2015 11:33 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Lorena
 Lorena
Miembro Moderator

Hola David,

Gracias a tí por compartir la solución. Será de utilidad a usuarios del foro con el mismo problema.

Un saludo.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/01/2015 1:08 pm

Por favor Iniciar Sesión o Registro