Error en Slideshow Plantilla SJ Joomla3  

 
Asociación Cultural El Patiaz
 Asociación Cultural El Patiaz
Usuario experto

Buenos días
Estoy tratando de configurar el módulo Slideshow de la plantilla SJ Joomla3 pero al añadir mi propia imagen tiene un comportamiento extraño, al hacer clic sobre el slider y pasarlas, cuando inicia la secuencia de ir pasando las imágenes desaparece la imagen, aunque realmente solo estan las tres imágenes, las dos originales de la plantilla y la que he añadido yo para probar.
Ya me había pasado anteriormente pero creyendo que pudiera ser por algún módulo que había instalado volvi a restaurar una copia de seguridad anterior donde el módulo funcianaba perfectamente, ahora lo único que he hecho es crear categorías y trabajar con los artículos con lo cual para mi queda descartado que sea por incompatibilidad con algún otro módulo ya que ayer funcionaba correctamente y hoy tiene el comportamiento que comento.
También he probado en diferentes ordenadores con Opera, Firefox, Chrome y Explorer y en todos hace lo mismo.
Se puede ver aquí en MI WEB CLON
Y aqui el original en DEMO SJ jOOMLA3
Envío las capturas de pantalla, aunque nada he cambiado de la configuración original, solo añadir mi propio articulo a la categoría.

Saludos al foro.

URL del sitio: Contenido solo visible a usuarios registrados

Hosting Joomla 3Gb www.elpatiaz.es

Citar
Respondido : 01/07/2016 1:12 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Revisando tu web, donde se produce el error, veo que se produce un error de javascript al cargar, que se puede ver con un inspector de código como el Firebug.

Este código que provoca el fallo no aparece en la demo de la web, por lo que puede venir generado por alguna extensión que haya añadido, que provoque que fallen otros elementos de javascript, como el que hace la transición de la imagen.

Por ejemplo, me indica error para el siguiente código:

jQuery(document).ready(function(){
	jQuery('.hasTooltip').tooltip({"html": true,"container": "body"});
});

Tendrías que revisar las extensiones que tienes en tu web, para ver si alguna puede ser la causante de este problema. No debería tratarse de un problema del servidor, ya que el javascript se ejecuta en el navegador.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/07/2016 4:38 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Asociación Cultural El Patiaz
 Asociación Cultural El Patiaz
Usuario experto

Hola,
He desinstalado los únicos componentes que tenía, CinchMenu y OSMap y sigue produciendose el mismo error, aunque con estos componentes instalados anteriormente funcionaba el Slide Show.
Para probar, he asignado el módulo Slide Show a todas las páginas y he comprobado que el error se produce cuando se muestra una página que tiene asignada una categoría que se visualiza en formato blog. Se puede ver en estos menús de prueba:
Menu Accordeon CK> Mostrar categoría blog 1
Menu Accordeon CK> Mostrar categoría blog 2
Cuando se muestra una página que tiene asignada una categoría que se visualiza en formato lista el módulo Slide Show funciona correctamente. Se puede ver en estos menús de prueba:
Menu Accordeon CK> Mostrar categoría lista 1
Menu Accordeon CK> Mostrar categoría lista 2

Para descartar que el problema no lo generaba el módulo CinchMenu, he instalado el módulo Menu Accordeon CK y creado un menú que despliega los submenús al pasar el ratón por encima, pero el comportamiento es el mimso en uno y otro, en la página de inicio no los despliega, indistintamente que se mueste la página en formato lista o blog, Sin embargo en cualquier otra página que no sea el index funciona correctamente independientemente que el módulo Slide Show funcione o no. No sé si el comportamiento del Slide Show y Menu Accordeno CK tiene relación con el mismo problema.

Hosting Joomla 3Gb www.elpatiaz.es

ResponderCitar
Respondido : 03/07/2016 9:12 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola

¿Puedes pro favor probar a "deshabilitar" el plugin de cookies en portada o de forma global y luego limpiar la caché y verificar si persiste el problema?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 04/07/2016 3:07 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Asociación Cultural El Patiaz
 Asociación Cultural El Patiaz
Usuario experto

Ya he desabilitado el plugin de cookies. En su día instale el plugin Cookies Acept pero cuando empezo a dar problemas el Slide Show lo desinstale para descartar que fuese el problema, ahora solo está Autentificación Cookie de Joomla Proyect que lo he deshabilitado.
Imagenes 1 y 2

Saludos

Hosting Joomla 3Gb www.elpatiaz.es

ResponderCitar
Respondido : 04/07/2016 12:34 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.
Por defecto en la demo de la plantilla, en la categoría blog no muestra ningún slider, para descartar que sea problema de eso prueba a instalar la extensión ' RokSprocket ', veras que tiene muchas opciones de configuración, en tu caso puedes utilizar la opción ' Features ' para mostrar el slider

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 04/07/2016 1:42 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Asociación Cultural El Patiaz
 Asociación Cultural El Patiaz
Usuario experto

Hola,
Finalmente he encontrado porqué se produce el error en el slider, es al elegir el tipo de menú para que muestre los artículos en formato blog ya que éstos tienen que figurar como destacados.

Tipo de elemento del menú * Mostrar todos los artículos destacados de una o multiples categorías...
Al elegir el tipo:
Tipo de elemento del menú * Mostrar una categoría en formato blog.
es cuando el slider se comporta erroneamente.

En cuanto al módulo de menú que no se desplegaba en el index he visto que SmartAddons tiene un módulo para menús desplegables (SJ Flat Menu) y que posiblemente será más compatible con el template SJ Joomla3 al proceder las dos cosas del mismo sitio, con un cambio de colores en el CSS para adecuarlos al sitio por el momento solucionado.

Podemos dar este tema por cerrado.

Saludos al foro.

Hosting Joomla 3Gb www.elpatiaz.es

ResponderCitar
Respondido : 06/07/2016 10:49 pm

Por favor Iniciar Sesión o Registro