iframe no funciona  

 
Pedro
 Pedro
Reputable Member

hola,

tengo un iframe que sí me funciona en otra web (joomla 1.5), pero en la nueva versión (joomla 3) no se ve correctamente.

http://spangraf-cp125.webjoomla.es/index.php/prueba

no es problema del editor, ya que lo tengo desactivado. Pero parece que no da la altura correcta al iframe, con lo que se ve cortado.

¿alguna idea sobre lo que puede ser?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 08/01/2016 6:19 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tienes que especificarle la altura, veo que tienes definido un ancho pero agrega un height:500px por ejemplo

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/01/2016 8:32 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pedro
 Pedro
Reputable Member

hola Jhon,

la cosa es que dentro del iframe hay un menú que permite navegar por varias páginas, y cada una tiene una altura diferente. Por eso me gustaría que se autoajustara, como sucede en la web antigua con el mismo código de iframe:

http://www.free-run.es/index.php?option=com_content&view=article&id=131

Si no hubiera más remedio vería, pero ¿no podría ser algún problema de java o similar?

ResponderCitar
Respondido : 08/01/2016 9:04 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

En tu web en donde se redimenciona la altura lo hace por que tienes un javascript que lo hace ( iframerizer y jquery), ver imagen

Podrías evaluar poner el mismo código de referencia javascript, lo otro es poner una altura fija

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/01/2016 9:44 pm

Cursos Gratuitos WordPress

Pedro
 Pedro
Reputable Member

gracias Jhon,

copiando en el artículo todo el texto que aparece en tu captura se muestra correctamente. Haré lo mismo con el resto de iframes y arreglado.

un saludo

ResponderCitar
Respondido : 12/01/2016 10:35 am

Por favor Iniciar Sesión o Registro