Avisos
Vaciar todo

Imposible actualizar Joomla 3.5.1 a 3.6.X  

 
Luis
 Luis
Usuario activo

Estamos intentando actualizar la versión de Joomla de www.alquihogar.com y es imposible.
Desde Componentes-Actualizar Joomla tenemos el siguiente mensaje:

"No hay actualizaciones disponibles
You are on the "Personalizar URL" update channel. This is not an official Joomla! update channel.

Usted ya tiene la última versión Joomla!, 3.5.1."

Hemos intentado en Opciones todas las posibilidades, sin éxito.

Asimismo, hemos descargado el archivo zip de actualización, exactamente este, Joomla! 3.6.5 Upgrade Package (.zip), descargado de la siguiente URL https://downloads.joomla.org/es/cms/joomla3/3-6-5 y al intentar instalarlo nos sale el siguiente mensaje:

"Advertencia

JInstaller: :Instalación: No se puede encontrar el archivo de configuración XML
Error

No se puede encontrar paquete de instalación"

Ya no sabemos que puede ser. Un saludo y gracias por la ayuda.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 11/03/2017 2:57 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Luis.

Antes que nada, te aconsejo que primero clones tu instalación y realices la actualización en ese clon y una vez veas que todo esta correcto, realizas los mismos pasos es la web en producción, con esto nunca tendrás la web caída.

Una vez clonada la web, desactiva los componentes y plugins que tengas instalados sobretodo si tienes Akeeba Backup para las copias.

Cuando tengas deshabilitados los componentes y plugins prueba a realizar la actualización automática.

Un saludo

ResponderCitar
Respondido : 11/03/2017 7:05 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis
 Luis
Usuario activo

Hola Pepe. Te comento.

He descargado una copia y la he montado en local. En cuanto he accedido al administrador, me aparece la actualización automática, tanto de la versión de joomla a la última, como las de un par de extensiones.

No he desactivado nada, ni componentes, ni plugin alguno.

Un saludo y gracias por la ayuda.

ResponderCitar
Respondido : 12/03/2017 7:42 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Luis,

Es posible que en las opciones de actualización de Joomla estés trabajando es una versión STS (de corta duración) y por eso no veas versiones superiores (LTS).

Desde la opción Actualizar, en Componentes, en el backend, a la derecha en Opciones verifica que puedas activar LTS y luego limpia la cache del backend y entra de nuevo en actualizaciones y mira si te aparece la 3.6.5

Saludos

ResponderCitar
Respondido : 13/03/2017 2:23 am

Cursos Gratuitos WordPress

Luis
 Luis
Usuario activo

Lo que me aparece es lo que te envío en la captura adjunta. No obstante comentarte que he probado todas las opciones sin resultados. Gracias por la ayuda.

ResponderCitar
Respondido : 13/03/2017 1:05 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Luis.

¿ En local te deja actualizarlo ?

Es extraño lo que comentas, lo acabo de probar en un joomla con 3.5.1 y no obtuve ningún problema en la actualización.

Descárgate el paquete de actualización desde la URL que te indico e intenta actualizarlo instalándolo como si fuera una extensión mas desde Extensiones -> Gestionar -> Instalar

https://downloads.joomla.org/cms/joomla3/3-6-5/Joomla_3.6.5-Stable-Update_Package.zip

Otra opción puede ser por la versión de PHP que estas utilizando en tu cuenta de hosting, actualmente veo que utilizas la versión 5.4 , en este caso seria seria instalar la versión 5.6, esto lo puedes realizar tu mismo desde el archivo .htaccess que encontraras antes de Public_html ( no el htaccess que tienes en public_html )

Seria eliminar la linea

AddHandler application/x-httpd-php54 .php

, con esto se quedara instalada la versión por defecto que es la 5.6.

Te dejo información de como realizarlo, si ves que tienes problemas, manda un ticket a soporte y mis compañeros lo realizaran por ti:

Versión de PHP en cPanel ¿cómo cambiarla?

Un saludo

ResponderCitar
Respondido : 13/03/2017 3:08 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis
 Luis
Usuario activo

Hola Pepe,

En local me aparece la actualización a la última versión, así es.
El paquete de instalación, ya me lo descargué y probé a instalarlo. De todas formas he vuelto a repetir el proceso y me sigue dando el mismo error:

Advertencia

JInstaller: :Instalación: No se puede encontrar el archivo de configuración XML
Error

No se puede encontrar paquete de instalación

Sobre la versión de PHP que estoy utilizando, me he dirigido al .htaccess y no tenía ninguna línea. Si inserto la línea

AddHandler application/x-httpd-php55 .php

me aparece que la versión ese correctamente esa, la 5.5, pero si elimino la línea no me aparece que sea la 5.6, sino la 5.4. He dejado la línea mencionada para que sea la versión 5.5 al menos.
Aún así y con esta última version de PHP, sigo teniendo los mismos problemas.

ResponderCitar
Respondido : 14/03/2017 12:44 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Luis.

Ok en estos casos tienes varias opciones:

1º -
.- Ve a Componentes → Actualizar Joomla. Haz clic en el enlace "URL de actualización" y guarda el paquete de actualización en tu ordenador.
.- Copia el paquete de actualización en la carpeta /tmp de tu instalación de joomla en el hosting
(este método sólo funciona con el paquete de actualización, No va a funcionar para otros paquetes de actualización o el paquete completo de Joomla!.)
.- Ve a Componentes → Actualizar Joomla. El componente de actualización de Joomla! va a utilizar el paquete de actualización de tu carpeta /tmp.


.- Descarga el paquete de actualización desde https://www.joomla.org/download.html
.- Copia el paquete de actualización en el directorio raíz de tu sitio y descomprímelo ( Selecciona la opción de sobrescribir los archivos )
.- Inicia sesión en tu panel de administrador Joomla! y ve a Extensiones → Gestionar → Base de Datos y selecciona el botón Corregir en la parte superior izquierda.
.- Dentro de la sección de gestionar ve al elemento "Descubrir" en el menú de la izquierda y haz clic en el botón Descubrir. Selecciona sólo el NÚCLEO de extensiones de Joomla! que aparece en la lista y has clic en el botón Instalar.
.- En el menú principal de tu panel de administrador, ve a Sistema → Limpiar la Caché y haz clic en el botón Borrar en la parte superior izquierda.

Nota: recuerda copia de seguridad antes de probar estas opciones o mejor realízalo en el clon que tienes en tu equipo.

Un saludo

ResponderCitar
Respondido : 14/03/2017 2:19 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress