JError:1 al desconectar (system-logout)  

Página 1 / 2
 
Raúl
 Raúl
Usuario activo

Hola,

Hemos detectado que cuando los usuarios se desconectan del site aparece un error que es nuevo para nosotros:

JError:1

Error: 1

Primero revisamos y actualizamos el plugin "system / logout" y revisamos si por nuestra parte había algo que pudiese estar causando ese error pero en principio no.

También revisamos el archivo login.php y parece estar bien también.

Envié un ticket al servicio técnico para preguntar algo por parte del servidor o si alguna nueva configuración pudiese estar ocasionando ese error.

Hemos googleado y no hemos encontrado mucha información sobre este error excepto un caso de un usuario de Webempresa de hace unos años que le pasaba lo mismo y lo solucionaba al deshabitar el plugin "system logout".

https://www.webempresa.com/foro/4-Preguntas-Sobre-Joomla!/138262-Error-en-el-logout.html

Probamos y efectivamente si deshabitamos ese plugin ya no da ese error, pero sin embargo perdemos la funcionalidad de redirección al desconectar, pero obvio que queremos tener habilitado y funcionando correctamente el plugin.

J 3.5.1

¿Cómo puedo enviar en privado datos para que accedan y se desconecten para que vean el error en vivo y a todo color?

Citar
Respondido : 19/04/2016 4:17 pm
Raúl
 Raúl
Usuario activo

EL archivo error log desde el cpanel está limpio.

Pasando la revisión de stephan muestra lo siguiente:

PHP Fatal error: Call to a member function get() on a non-object in /.../.../public_html/components/com_users/models/login.php on line 62

PHP Fatal error: Call to a member function getName() on a non-object in /.../.../public_html/libraries/legacy/view/legacy.php on line 497

ResponderCitar
Respondido : 19/04/2016 4:35 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Revisa si con un plugin alterno de logout tienes el mismo problema, evalua por ejemplo :
http://extensions.joomla.org/extension/quick-logout

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/04/2016 8:06 pm
Raúl
 Raúl
Usuario activo

Hola,

Instalado y probado Quick Logout y pasa exactamente lo mismo.

Si tengo habilitado el system logout me da el Error 1

Si lo deshabilito no me da el error pero no me redirige.

Plugin Quick Logout desistalado.

ResponderCitar
Respondido : 19/04/2016 8:28 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Haz probado instalando un modulo de Joomla en la sección derecha?, los módulos de Joomla cuentan con una opción que al aplicar la desconexión realizan una redirección.

Puedes revisar por ejemplo el siguiente modulo: http://www.shape5.com/product_details/free_extensions/s5_register_module.html

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/04/2016 1:08 am
Raúl
 Raúl
Usuario activo

Hola Johnny,

Gracias por tu respuesta pero no quiero sustituir el system logout, lo que quiero es que por favor me ayuden a solucionar ese error que aparece (JError:1) que no debería existir 🙂

Saludos.

ResponderCitar
Respondido : 20/04/2016 12:31 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Para verificar si se trata de un problema relacionado con la plantilla que estás utilizando en tu web, prueba a activar temporalmente otra plantilla para el frontal de la web y haz una prueba de logout, para ver si da el mismo mensaje de error. Luego puedes volver a dejar tu plantilla actual.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/04/2016 6:03 pm
Raúl
 Raúl
Usuario activo

Con otras plantillas no me da el Error 1 pero sigue sin funcionar la redirección del plugin (System Plugin) preguntaré a los desarrolladores de la plantilla a ver si ellos detectan el Error.

ResponderCitar
Respondido : 20/04/2016 7:34 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Raúl
 Raúl
Usuario activo

Hola,

Hemos estado revisando con los desarrolladores de la plantilla y no es error de la plantilla, parece que había deshabilitado el plugin cuando probé las plantillas por defecto de Joomla.

El Error 1 continua y no encuentro una solución que no sea la de desactivar el plugin "system logout" como le pasó a la chica del tema: www.webempresa.com/foro/4-Preguntas-Sobre-Joomla!/138262-Error-en-el-logout.html

Quiero solucionarlo y no dejar el Error y hacer un "apaño".

¿Me pueden ayudar?

He hecho un clon de la web para hacer pruebas, si quieren puedo darles los datos de acceso.

También he probado deshabilitar todos los plugins uno por uno, excepto el system logout y sigue igual.

Probado sin URL amigables y todo igual.

Googleando no encuentro nada, solo este tema en el que dan la misma solución del hilo de Webempresa que puse antes: http://stackoverflow.com/questions/12603968/pages-redirect-to-homepage-when-user-logs-out-from-them

ResponderCitar
Respondido : 26/04/2016 6:43 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Cuando consulto el backend de tu sitio veo que no aparece la pantalla standard de Joomla, y aparece algo posiblemente configurado con alguna extensión:

Te sugiero desactivar esta extensión, aunque ya lo comentaste, te sugiero desactivar las extensiones que hayas instalado recientemente y que esten relacionados con permisos o accesos. Si aún asi sigues con problemas es posible que sea algo del core o en la base de datos de tu sitio, tendrias que evaluar actualizar tu joomla o reinstalar el parche de la actualización que tienes, esto lo puedes hacer en el clon de tu sitio.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/04/2016 10:14 pm

Cursos Gratuitos WordPress

Raúl
 Raúl
Usuario activo

Hola Jhon,

Gracias por respoinder.

La extensión es RSFirewall y ya probé desactivarla pero sigue todo igual.

Joomla está actualizado a la última versión.

He probado desactivar todas las extensiones/componentes y sigue igual.

Todo funcionaba bien, la única sospecha es que pasó cuando actualizamos a la ultima versión de Joomla.

ResponderCitar
Respondido : 29/04/2016 12:07 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

¿Desde qué versión de Joomla te has actualizado a la 3.5.1? Es posible que el conflicto venga de alguna extensión que tengas en la web que no sea compatible con la última versión de Joomla.

A priori el problema te lo tendría que estar causando alguna extensión adicional.

Haciendo pruebas con Joomla 3.5.1 no veo que se produzca ningún error cuando cierro la sesión de usuario en el frontal de la web. ¿Te ocurre aunque cierres la sesión desde la página de inicio?

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/04/2016 1:29 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Raúl
 Raúl
Usuario activo

Hola Pablo,

La instalación de Joomla de hizo con J3.4.4 (septiembre 2015 aprox) y se ha ido actualizando cada vez que se anunciaba una nueva hasta la 3.5.1

He probado también:

Desactivar cada uno de los componentes sigue apareciendo el Error 1

Probar cambiar el acceso (login) a publico y en todas las páginas y sigue apareciendo el Error 1

He reinstalado el system plugin logout y sigue apareciendo el Error 1

He reinstalado todos los system plugins y sigue apareciendo el Error 1

No sé por dónde más buscar.

ResponderCitar
Respondido : 29/04/2016 7:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Para descartar problema con la actualización tendrías que probar recuperar una copia de tu sitio antes de la actualización y verificar si te sucede lo mismo, puedes usar CPremote para realizar esto (Tendrias que recuperar base de datos y archivos de tu sitio)

Revisa : http://wiki.webempresa.com/Restaurar_Copia_cpRemote

Si no tienes problemas con la versión anterior, lo que te recomiendo es hacer pruebas de tu siito en un clon antes de actualizar en tu sitio web final.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/04/2016 11:25 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Raúl
 Raúl
Usuario activo

Ok.

Gracias

ResponderCitar
Respondido : 29/04/2016 11:48 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro