Jevents al cambiar de usuario un evento creado el login de acceso falla  

Página 1 / 2
 
Aurelio
 Aurelio
Reputable Member

Hola, voy a tratar de explicar este hilo porque creo que es un poco complejo lo que me está sucediendo y necesito de vuestros conocimientos expertos en materia de jooma 3.x y el compnente JEvents.

En primer lugar deciros que en mi sitio web tengo editado 3 eventos con el usuario que se encarga de crearlos que es el dueño de este sitio web con privilegios para poder crear y editar todos los eventos.

En el mes de mayo de mi sitio web tengo 3 eventos creados, dos que están con la categoria de ocupados y otro con la categoría de horas libres.
Pues bien, cuando entro a editar un evento de hora libre y cambio el usuario que lo crea por otro usuario que tiene privilegios de registrado y guardo los cambios sucede lo siguiente:
Cuando voy a hacer login con un usuario con permisos de registrado o cualquier otro tipo de usuarios, me dice que no tengo permisos de acceso. Me da que debe ser un bug y no sé cómo subsanarlo.
Ya he tenido que restaurar mi sitio web por esto 3 veces con las herramientas del cpanel y no me atrevo a hacer más pruebas hasta saber si me podéis ayudar a corregir esto y por qué sucede.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 17/06/2016 12:02 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Usas algún tipo de extensión adicional para el manejo de permisos o usuarios?

Si cambias el usuario desde JEvents para la creación del evento, entiendo que con este usuario ya no puedes acceder al sitio, si creas un neuvo usuario en Joomla puedes conectarte al front-end del sitio?, hay diferencias entre el usuario creado y el usuario con problemas?

Para descartar si es un bug o si es un problema de configuración de tu sitio tendrías que instalar un sitio web desde cero en una carpeta y luego Jevents y verificar si te sucede lo mismo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/06/2016 6:45 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Aurelio
 Aurelio
Reputable Member

Hola Jhon, en local con xampp y una plantilla de las que vienen por defecto con joomla 3.x he probado con los dos componentes que tengo instalado en mi sitio web en el hosting webempresa que son el community builder y el componente JEvents.

Me he creado un ítem de menú de Jevents que me muestre en vista mensual y tipo de calendario "flat".
Tengo dos usuarios uno con permisos publicador y otro administrador.
He creado un evento como publicador y lo he guardado. He vuelto a entrar con este usuario como publicador y he cambiado el propietario y la verdad es que cuando intento logar funciona correctamente hechos los cambios, pero sin embargo en la web me falla y supongo que o es algo de permisos o algún archivo del core de joomla que se ha debido dañar.

A ver si me podéis seguir guiando porque no sé darle solución y para mi cliente necesito darle el calendario como gestión del tiempo de trabajo.

ResponderCitar
Respondido : 17/06/2016 8:04 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Por lo que comentas debe ser entonces algo en la instalación de tu sitio.

Prueba haciendo una reparación de BD, desde Extensiones > Gestor de Extensiones > Base de datos > Corregir

Tienes tu Joomla actualizado?, en caso lo tengas actualizado puedes probar reinstalando el parche de actualización :
https://github.com/joomla/joomla-cms/releases/tag/3.5.1

Tendrías que instalar por ejemplo :
Joomla_3.5.x_to_3.5.1-Stable-Patch_Package.zip

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/06/2016 10:28 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Aurelio
 Aurelio
Reputable Member

Cuando intento actualizar el paquete que me dices Jhon me da el siguiente error en el back-end de joomla:

Advertencia
JInstaller: :Instalar: No se ha podido encontrar el archivo XML de configuración.

ResponderCitar
Respondido : 18/06/2016 12:30 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

El mensaje indica que no ha localizado el fichero XML de instalación. Prueba con la actualización previa copia de seguridad en componentes => actualización de Joomla.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/06/2016 1:39 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Aurelio
 Aurelio
Reputable Member

Hola Jhonny con tu indicación he probado eso que medices y desde el back-end me dice que ya dispongo de la última versión de joomla 3.5.1

ResponderCitar
Respondido : 18/06/2016 2:00 am
Aurelio
 Aurelio
Reputable Member

Hola Jhonny con tu indicación he probado eso que medices y desde el back-end me dice que ya dispongo de la última versión de joomla 3.5.1

Cuando podáis me indicáis que puedo hacer, porque me da miedo hacer la prueba de cambiar de usuario y no me funcione los login de los usuarios registrados al cambiar de propietario un evento de JEvents como comenté en este hilo que no entiendo el por qué.

La verdad que necesito saber cómo puedo solucionar esto porque si no la web se me queda coja y mi cliente descontento con el trabajo de la web.

ResponderCitar
Respondido : 18/06/2016 10:07 pm

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Entiendo que la web que tienes en local no es la misma que la web donde tienes problemas, sino que has realizado la prueba con las misma extensiones. El problema podría venir de otro lado. Para verificar esto podrías hacer un clon de la web que tienes alojada con nosotros y hacer una prueba en local para ver si te sucede lo mismo.

Sobre lo de que ya tiene la última versión de Joomla, una prueba que podrías hacer es volver a actualizar tu Joomla a la versión 3.5.1 para ver si solucionan los problemas, previo backup completo de la web.

Para hacer esto, tendrías que descargar el siguiente archivo:

https://github.com/joomla/joomla-cms/releases/download/3.5.1/Joomla_3.5.1-Stable-Update_Package.zip

Una vez que lo tengas, tendrías que instalarlo desde Extensiones->Gestor de extensiones, como si de una extensión se tratara.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/06/2016 12:49 pm
Aurelio
 Aurelio
Reputable Member

De acuerdo Pablo, voy a clonar la web. Si no recuerdo mal tengo en otro hilo donde me decís cómo clonar la web.
Cuando haga las pruebas oportunas en local y ver si me pasa lo mismo os lo indico por este hilo y comprobamos a ver qué sucede y os cuento.

ResponderCitar
Respondido : 20/06/2016 8:23 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si tienes problemas con la clonación puedes abrir otro hilo de discusión, de manera general sería hacer un backup con Akeeba y este archivo de backup recuperarlo en tu máquina local.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/06/2016 10:53 pm
Aurelio
 Aurelio
Reputable Member

Hola Jhon, el clon lo tengo perfecto funcionando en local. Cuando pueda os voy diciendo, dejad el hilo abierto y os comento

ResponderCitar
Respondido : 20/06/2016 11:12 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Aurelio
 Aurelio
Reputable Member

Hola, después de tener mi servidor local como comentó el compañero Pablo, cloné ahí la web que está alojada en el hosting y la verdad es que me sigue sucediendo lo mismo, es decir, cuando intengo logar en el front-end de mi sitio web me sale esta advertencia: Usted no puede acceder a la sección privada de este sitio..

Este usuario con el que intento logar o con cualquier otro que no sea super usuario me da esta advertencia.

En la configuración global está permitido el acceso al front-end de mi sitio web.

No sé qué mas puedo hacer, a ver si me seguís echando una mano chicos que tengo ganas de acabar la web a mi cliente que estoy parado por este tema que me preocupa bastante.

ResponderCitar
Respondido : 21/06/2016 8:12 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Podrías probar desactivando extensiones una a una y verificar si te sucede lo mismo.
Si aún sigue ocurriendo es posible que se haya dañado algo a nivel de base de datos, en este caso tendrias que evaluar pasar toda tu informacion a un nuevo sitio web desde cero.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/06/2016 10:30 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Aurelio
 Aurelio
Reputable Member

Ufff no me digas eso Jhon, no podéis ayudarme a evaluar dónde está y por qué sucede? porque la verdad es que sólo he instalado tres componentes instalados que son el community builder, ozio gallery de pago y jevents, no tiene más, el resto venía por defecto con vuestro pack profesional de joomla y la plantilla encelado. No hay nada más. Hacer todo el trabajo de nuevo bufffff!!!!!

ResponderCitar
Respondido : 22/06/2016 7:01 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro