Menu en inglés desa...
Avisos
Vaciar todo

Menu en inglés desaparece  

Página 1 / 2
 
David
 David
Noble Member

Buenas noches,

Hemos clonado una de nuestras webs para realizar modificaciones (la que aparece abajo en dominio afectado). El caso es que nos desaparece el menú en inglés. Es decir todo está bien, pero al pulsar en la bandera en inglés, el menú HOME, Success histories etc.. (es decir el traducido). En las plantillas todo está correcto, plantilla default, plantilla español, plantilla inglés.  Default como genérica, y el resto cada una en su idioma. Sin embargo al pulsar en bandera inglés, el menú desaparece. Regresamos a la bandera españa, y vuelve a aparecer.

Por otra parte, obserbo que en plantillas/estilos. HAcemos un cambio, guardamos. Salimos, y al volver a entrar al estilo de la plantilla está igual que antes de guardarlo. Es decir que algo nos vuelve a dejar el estilo de la plantilla como antes de guardar.

Todo esto ha sido al clonar, aunque debería ser una copia idéntica, algo falla, y no sabemos qué es.

Contenido solo visible a usuarios registrados

Este debate ha sido modificado el hace 10 meses por Jhon
Citar
Respondido : 29/12/2020 8:59 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

A mi me sigue apareciendo, si que desaparece temporalmente al hacer scroll pero luego aparece. No se si te refieres a eso.

Lo veo como en la imagen adjunta.

Captura de Pantalla 2020 12 29 a la(s) 16.16.03

Saludos.

ResponderCitar
Respondido : 29/12/2020 9:16 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

David
 David
Noble Member

@jmarreros Claro, el problema es en la copia que hemos clonado, para hacer variar diseños y cosas en la web off-line. Es una copia idéntica pero al pinchar en inglés, el menú no aparece.   Tal vez sabiendo

 

¿Por qué cuando hago cambios en la plantilla, salvo y vuelvo a entrar la plantilla vuelve de nuevo a estar como estaba ? es decir aunque se guardan cambios, es como si algo mandara sobre ellas y las pone de nuevo como estaban antes de mdificar.

ResponderCitar
Respondido : 30/12/2020 9:30 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola David.

Ok, puedes indicarnos la URL del clon para que podamos revisarlo ?

 

Un saludo

ResponderCitar
Respondido : 30/12/2020 9:38 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Noble Member

@pepesoler Pues nos pasa exactamente lo mismo que aquí. Estamos renovando webs, y clonando. Al duplicarlas nos dan estos errores. Y no sabemos por qué

http://www.pressmedia.es/index.php/ Pincha en la bandera de inglés y lo comprobarás. Luego regresas a español. Es el mismo problema. Como en el otro caso (que está en local ahora mismo) todos los parámetros, menus, estilos en plantillas etc.. están bien. Por más que revisamos, no damos con ello.

 

Gracias

ResponderCitar
Respondido : 30/12/2020 11:48 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola David,

Puedes enviarnos una captura como estas configurando los idiomas para este menú? de manera general comprueba tienes seleccionado el menú ingles para este idioma

Puedes ver información sobre como asociar los idiomas en el siguiente video -> https://www.youtube.com/watch?v=t43UX3SaKRc

Un Saludo

 

 

 

ResponderCitar
Respondido : 30/12/2020 1:13 pm

Cursos Gratuitos WordPress

David
 David
Noble Member

@karen Hola Karen,

Es que ya estaban funcionando. Y es una copia. Te adjunto capturas de la configuración.

Captura 1

adjunto las capturas de la configuración.

Captura 2

 

Esta publicación ha sido modificada el hace 10 meses por David
ResponderCitar
Respondido : 30/12/2020 1:57 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola David,

Es muy raro que no logres visualizar el menú, es como si no estuviera configurado de forma correcta. Prueba lo siguiente ve al apartado Menús -> Gestionar

Screenshot

Dentro de este pulsa el menú principal asignado

Screenshot

Dentro de este selecciona tu pagina de inicio y pulsa sobre ella

Screenshot

En la pestaña asignación de menú comprueba que el menú de Ingles esta marcado como si

Screenshot

Pulsa sobre el nombre y prueba cambiar la asignación del menú

Screenshot

Verifica si con esto logras ver el menú en ingles

De igual forma verifica si las asociaciones se están realizando de forma correcta para cada paginad de acuerdo a su idioma correspondiente

Un Saludo

 

Esta publicación ha sido modificada el hace 10 meses 4 veces por Karen Rios
ResponderCitar
Respondido : 30/12/2020 2:37 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David
 David
Noble Member

Buenos días

He seguido los pasos indicados en el post anterior. En la primera captura muestro como estaba:

Asignaciones

 

Ahora lo hemos cambiado así:

ahora si

Y el resultado es este. Aparece pero en guiones/columna, y en un sitio que no es el correcto. No se si debe ser por la ubicación tal vez, aunque no se donde cambiar esto y cual es la posición, porque he probado muchas y no sale como en español. Qué es como debe salir.

 

Menu aparece

 

ResponderCitar
Respondido : 02/01/2021 10:08 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Entiendo que el problema es la desconfiguración del menú, ya que igual el menú se sigue viendo, pero cambia el diseño en horizontal.

Esto puede ser debido a las urls amigables, es decir, no se esta cargando el archivo de estilos correctamente debido al "index.php" que tienes como parte de la url

Lo que te sugiero es que actives las urls amigables correctamente en tu Joomla, de manera que no aparezca el index.php

Saludos.

ResponderCitar
Respondido : 02/01/2021 4:56 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

David
 David
Noble Member

@jmarreros Hola Jhon

Pues es una apreciación muy interesante. No me había dado cuenta de este detalle. Aunque mira lo que ocurre. Al activar el segundo boton de las URLS (el que marco en rojo estaba en no, ahora está en si) - adjunto captura -

Amigables

Mira lo que ocurre, carga correctamente sin el index.php pero da error - captura -

URls amigables

Algo está raro aquí , pero no entiendo lo que ocurre...

ResponderCitar
Respondido : 02/01/2021 6:06 pm
David
 David
Noble Member
Respondido por: 

@jmarreros Hola Jhon

Pues es una apreciación muy interesante. No me había dado cuenta de este detalle. Aunque mira lo que ocurre. Al activar el segundo boton de las URLS (el que marco en rojo estaba en no, ahora está en si) - adjunto captura -

Amigables

Mira lo que ocurre, carga correctamente sin el index.php pero da error - captura -

URls amigables

Algo está raro aquí , pero no entiendo lo que ocurre...

Además desde que movimos esta web a otro ftp (y reconectamos la base), antes funcionaba todo bien y es una copia idéntica, nos aparece este error al intentar actualizar cualquier plugin o componente: Joomla\CMS\Filesystem\Folder::create: No se ha podido crear la carpeta.Path: /html

¿Tal vez esté todo relacionado?

 

Esta publicación ha sido modificada el hace 8 meses por Pepe
ResponderCitar
Respondido : 02/01/2021 6:15 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Realizaste la mitad de la configuración, te sugiero revisar: https://www.webempresa.com/blog/urls-amigables-en-joomla.html

Es decir no es suficiente con activar la opción que comentas, necesitas renombrar el htaccess.txt a .htaccess que viene por defecto con tu Joomla.

Saludos.

ResponderCitar
Respondido : 02/01/2021 7:20 pm
David
 David
Noble Member

@jmarreros Hola Jhon,

Hecho. Ahora si aparece sin el index.php en inglés, pero el resultado del menú en inglés es el mismo.

Urlamigble menu no sale
ResponderCitar
Respondido : 02/01/2021 7:38 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

No veo que aparezca ningún menú, a mi me sale tal como se muestra en la siguiente imagen:

Revisa si tienes el menú correctamente asignado.

Captura de Pantalla 2021 01 02 a la(s) 14.46.36

Prueba igualmente con otro template ya que el template que usas usa Gantry 4 y esta desactualizado, evalúa usar un tema diferente.

Saludos.

ResponderCitar
Respondido : 02/01/2021 7:47 pm
Página 1 / 2