No funcionan bien los enlaces a articulos en joomla 3.0  

 
Fernando
 Fernando
Usuario eminente

Hola,

1.-En el enlace referenciado ha creado un banner que solo se tiene que ver en la pagina principal, cuando hay el menu inicio activado. (VER IMAGEN UNO)

2.- He creado un menú llamado SERVICIOS donde enlazo un articulo. En este articulo se enlazan tres articulos llamados servicio 1, servicio 2 y servicio 3 (creo los enlaces con la extension de edicion de texto JCE) (VER IMAGEN DOS y TRES)

3.- Al pulsar un enlace SERVICIO 1, SERVICIO 2 o SERVICIO 3 se carga el articulo correspondiente pero tambien se activa el menú INICIO y aparece el BANNER. (IMAGEN TRES)

4.- Esto en otras versiones de JOOMLA (1.5 O 2.5) no pasaba.

El procedimiento para crear los enlaces en los articulos es el mismo que siempre he realizdo.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 24/03/2015 10:05 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Revisando la página donde están los enlaces de los servicios Contenido solo visible a usuarios registrados se ve que los enlaces a los 3 servicios tienen en la url "Itemid=101", es decir, están asociados con el elemento de menú con id 101, que precisamente se corresponde con el elemento de menú de la página de inicio.

Por tanto, cuando se entra en uno de estos enlaces se cargarán los módulos asociados con el elemento de menú de inicio.

Tendrías que cambiar estos enlace, a menos si Itemid. Por ejemplo podrías poner el Itemid 187 que corresponde con el elemento de menú "Servicios".

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/03/2015 2:53 pm

Cursos Gratuitos WordPress

Fernando
 Fernando
Usuario eminente

Gracias,

Cuando creo el enlace lo hago desde el gestor de enlaces de JCE.

Este gestor me ha puesto el &Itemid=187 final en el Enlace.

¿hay alguna manera de evitar que cuando hagas el enlace te añada el vinculo al itemid=101 para que no se carge el menu inicio?

ResponderCitar
Respondido : 24/03/2015 6:50 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Una opcion sería que tengas un ítem de menú para el enlace y luego desde JCE enlaces directamente al ítem de menú y no al artículo

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/03/2015 8:23 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro