No muestra la última versión a actualizar sino otra anterior. ¿Cómo solucionarlo?  

 
Alceste
Noble Member

Hola,
Tengo la versión de Joomla 3.9.8. La última versión de Joomla es la 3.9.11 pero en actualizaciones me muestra la 3.9.9 que encima tuvo graves problemas y no conviene actualizar a esta.
Sé que siempre puedo descargar la última versión e instalarla manualmente, pero me gustaría solucionar esto de todos modos para que muestre la última versión estable de Joomla y no otra a la hora de sugerir actualizaciones.
Saludos y gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 29/08/2019 10:47 am
Pepe
 Pepe
Miembro Moderator

Hola Alceste.

Es posible que solo sea en esa actualización, no tiene porque pasarte en las próximas actualizaciones.

Puedes descargar el paquete de actualización, por ejemplo descargas la versión Joomla! 3.9.10 y comprueba si muestra la actualización para la versión 3.9.11

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 29/08/2019 11:18 am

Cursos Gratuitos WordPress

Alceste
Noble Member

Hola Pepe,
El problema es que tengo la versión 3.9.8. La versión de actualización automática que me sugiere es la 3.9.9 de la cual en Joomla informan que hubo errores graves y que no se actualice a esta versión.
https://www.joomla.org/announcements/release-news/5772-joomla-3-9-9-release.html

Note to users with multilingual sites: Please do not update to 3.9.9 and wait for 3.9.10.
More information can be found here
Due to the bug introduced in Joomla 3.9.9, this version is not available anymore for download. We apologise for the inconvenience.

Viendo esto, he tratado de descargar una versión de actualización de 3.9.x a 3.9.11 ya que las otras no son mi caso al partir de 3.9.9 o 3.9.10 (No existe ninguna que sea de 3.9.8 a 3.9.11)
He tratado de instalarla manualmente pero da error: Dice que necesito ampliar el tamaño permitido para subidas y que no ha encontrado el paquete de actualización.
¿No hay alguna manera de cambiar la url asignada a los sitios de actualización? Lo digo porqué en otra web en qué he podido actualizar bien, la url que aparece en el sitio de actualización de Joomla core es esta:
https://update.joomla.org/core/sts/list_sts.xml
Mientras que en esta web en la que me falla aparece una url sin "sts":
https://update.joomla.org/core/list.xml
Creo recordar que había alguna manera de indicarle que las actualizaciones a descargar fueran de larga duración o estables, pero no recuerdo como hacerlo.

Nota Posterior: Tras entrar a actualizar automático, veo que aunque indica 3.9.9 va a la url del pack de 3.9.11 por lo que he actualizado automáticamente y veo que bien. De todos modos la consulta de como decirle que actualice a versiones estables y lo de la url de sitios de actualización seria interesante saberlo.

Saludos y gracias

ResponderCitar
Respondido : 30/08/2019 9:39 am
Pepe
 Pepe
Miembro Moderator

Hola Alceste.

como decirle que actualicen a versiones estables
Siempre mostrara la ultima version que tenga para actualizar, es posible que te indicara la version 3.9 pero lo mas seguro que sea problema de la propia versión, de normal siempre aparecerá la última versión a descargar.

lo de la url de sitios de actualización
La URL de descarga cambia según versiones, no tienes que modificar nada.
Cuando tengas una actualización veras que te indica la URL de descarga de esa actualización:

Puedes modificarlo desde Configuración Global -> Actualización de joomla
.- En las opciones de " Servidor de actualizaciones " puedes seleccionar como quieres que se actualice.

Predeterminado, siempre actualizará a la última versión.
Próximo: version superior a la que tienes
Pruebas: Betas de joomla
URL Personalizada: le indicas la URL de donde quieres que cargue ( Esto se utiliza solo si quieres cargar des una URL distinta, por ejemplo un paquete que tengas en tu equipo, una carpeta del servidor, en gestores de descarga tipo Drive, etc...

Lo normal es que este seleccionada la opción " Predeterminado " con eso siempre ira al servidor de actualizaciones de Joomla.

Desde las versiones 3.5 de joomla el archivo XML de carga para las actualizaciones ya no se utiliza, por eso no puedes actualizar desde las opciones extensiones y la actualización manual hay que realizarla desde el plugin de actualización de joomla,, si no recuerdo mal creo que lo vimos en otra entrada.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 30/08/2019 1:17 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro