Avisos
Vaciar todo

No puedo configurar Osmap con Joomla 3.5.1 y SSL  

 
Alceste
 Alceste
Noble Member

Hola, No puedo configurar los sitemaps con Osmap Free des del back end o administración. Cuando voy a Componentes y clico en Osmap se me abre una pantalla en blanco con dos enlaces.

Sitemaps (Este no lleva a ninguna parte)
Extensions (Este lleva al pluguin)

Pero no puedo configurar los mapas como sí podía hacer antes. El único cambio reciente es que ahora trabajo con certificado SSL. Uso Joomla 3.5.1, Virtuemart 3.0.18 y la última versión descargable de Osmap Free: 4.2.9

Actualizo info: En la revisión de Stephan me informa de un error fatal:
[24-Jan-2017 10:40:01 Europe/Berlin] PHP Fatal error: Cannot access protected property OSMapViewSitemaps::$activeFilters in /home/micuenta/public_html/miweb.com/layouts/joomla/searchtools/default.php on line 32

Me ocurre con dos webs.

Saludos y gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 24/01/2017 11:04 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El mensaje de error hace referencia a los archivo del OSmap, es posible que sea algún problema en la extensión, has probado desinstalarla e instalarla nuevamente?, es posible también que no sea compatible con la versión de PHP que tienes.

Puedes evaluar probar otra extensión, revisa por ejemplo:
https://extensions.joomla.org/extensions/extension/structure-a-navigation/site-map/sitemap-faster/

Saludos.

ResponderCitar
Respondido : 24/01/2017 5:41 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alceste
 Alceste
Noble Member

Hola,
Creo que debe haber más usarios con este mismo problema ya que Osmap era la extensoón recomendada.

Por el mensaje de la revisión parece que puede haber algún problema con la version PHP pero no tengo claro que cambiar de versión de PHP no me genere otros problemas. A parte de que voy a ciegas, pues no sé con qué versión sí es compatible.

En cuanto a instalar otra extensión, tampoco lo tengo claro porqué no sé si voy a perder los sitemaps actuales (que con Osmap se heredaban de Xmap) y por otro lado tampoco sé si la nueva extensión funciona bien.

El error está en el archivo default.php en la línea 32, y esto es lo que hay en dicha línea, por si puede servir de ayuda:
$filtersClass = $data['view']->activeFilters ? ' js-stools-container-filters-visible' : '';

El archivo default.php se halla en esta ruta:
in /home/micuenta/public_html/miweb.com/layouts/joomla/searchtools/default.php on line 32

Actualizo información: he desinstalado y vuelto a instalar Osmap Free y no se ha resuelto el problema. He instalado sitemap faster y veo que no permite confirgura nada, solo genera un sitemap en xml mezclando los idiomas de la web. He perdido los sitemaps. Ahora intentaré encontrar otra alternativa a Osmap para generar sitemaps.

Saludos y gracias

ResponderCitar
Respondido : 25/01/2017 10:27 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alceste.

Prueba lo siguiente:
.- Realiza una copia de seguridad del archivo por si pasa alguna cosa que no deseamos.
Solo con un copia y pega en el block de notas tendrás suficiente para dejarlo como estaba anteriormente.

.- Edita el archivo default.php y modifica la linea :

$filtersClass = $data->activeFilters ? ' js-stools-container-filters-visible' : '';

Por esto:

$filtersClass () = $data () ->activeFilters ? ' js-stools-container-filters-visible' : '';

Por el mensaje de la revisión parece que puede haber algún problema con la version PHP
En principio no ya que el mensaje es una propiedad protegida, por eso añadimos los paréntesis ()

Un saludo

ResponderCitar
Respondido : 25/01/2017 11:05 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola,
Gracias por el aporte. Sin embargo, no se ha solucionado. ¿No podría ser que el problema derive de haver pasado a trabajar cifrado "SSL"? Lo digo porqué tras intentar instalar otra extensión de sitemap, esta me ha advertido de que para trabajar cifrado se necesita la versión de pago...

ResponderCitar
Respondido : 25/01/2017 11:31 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

No debería presentar problemas que hayas pasado a SSL, que versión PHP utilizas?

Puedes probar a cambiarlo como lo menciona el articulo: https://www.webempresa.com/blog/version-php-cpanel-como-cambiarla.html ,si tienes dificultades puedes enviar un ticket a soporte desde tu área de clientes para que te ayuden con el cambio.

ResponderCitar
Respondido : 26/01/2017 12:50 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola,
Ya lo he tratado con soporte y se ha barajado la posibilidad de que sea la versión de PHP pero por el momento no he aplicado cambios a la versión PHP. Prefiero no tocar eso porqué luego puede que me fallen otras cosas. Al final lo he solucionado de otro modo. En una web lo he solucionado extrayendo archivos anteriores de OSMAP de una copia de seguridad y subiéndolos a la ruta sustiuyendo lo que había y me funciona con la última versión OSMAP Free, 4.2.9. En cambio en la otra web no lo he podido solucionar así y he tenido que instalar una versión vieja: Osmap_free 3.1.3, con lo cual también lo he resuelto de momento.
Me gustraría saber si alguién más ha tenido problemas similares al actualizar OSMAP o tras pasar a SSL.
Saludos y gracias

ResponderCitar
Respondido : 27/01/2017 11:03 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Por lo que comentas si que puede ser la versión de PHP, cuando decidas actualizar tu PHP seguramente vas a tener que actualizar también tu extensión.

Saludos.

ResponderCitar
Respondido : 27/01/2017 5:31 pm

Cursos Gratuitos WordPress