Avisos
Vaciar todo

Problema al editar links  

 
David
 David
Usuario experto

Hace unos días he actualizado a Joomla 3.10.4 y me pedia actualizar la versión de PHP y lo hice a la Version PHP 8.0.11

Ahora me encuentro que no puedeo actualizar, ni ver los links que pongo en mi página porque al intentar editarlos me sale el error que os mando en la imagen.

"0 func_get_arg(): Argument #1 ($position) must be less than the number of the arguments passed to the currently executed function"

Desde la Página Web, al intentar editar, me da un error similar.

Ya la versión anterior, me dejaba Editar, pero no Guardar. El botón "Guardar" no hacía ninguna función al pulsarlo y tenía que editar desde la Administración.

Este error es en todos los links por lo que me temo tiene que ver con el PHP

¿Alguna idea de como solucionarlo?

Muchas gracias.

Error

 

Contenido solo visible a usuarios registrados

Citar
Respondido : 20/12/2021 9:02 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal David,

Al hacer la actualización no probaste antes de pasar directamente a la version PHP 8.1 a una mas cercana y estable como 7.4? es necesario considerar este tipo de problemas al actualizar tanto la version del CMS como la del PHP https://docs.joomla.org/Updating_PHP

Valida y nos comentas, Saludos!

ResponderCitar
Respondido : 20/12/2021 9:40 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Usuario experto

Hola Bruno,

La versión de PHP 7.4 es la que tenía y Joomla me pedia cambiar a una superior y como siguiente solo vi que teneis la 8.

¿que puedo hacer?

Un saludo.

ResponderCitar
Respondido : 21/12/2021 5:16 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si regresas a la versión 7.4 que tenías, aún sigue el problema?

Prueba esto y nos comentas.

Saludos.

ResponderCitar
Respondido : 21/12/2021 5:26 pm

Cursos Gratuitos WordPress

David
 David
Usuario experto

No Jhon,

Al volver a la PHP 7.4, se soluciona el problema, pero ¿esto quiere decir que no podré pasar a la versión 4 de Joomla?

Me preocupa no poder seguir avanzando.

Muchas gracias.

ResponderCitar
Respondido : 23/12/2021 6:43 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola David,

En este caso es posible que algún plugin que tengas instalado sea el que ocasione el conflicto, debes comprobar entre las extensiones que tienes cuál puede esta generando este error con la versión de tu PHP

Verifica esto y nos comentas como ha ido todo

Un Saludo

ResponderCitar
Respondido : 23/12/2021 6:54 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación