Problemas al configurar "Términos del Servicio"  

 
NeroCaes
 NeroCaes
Estimable Member

He migrado mi web joomla 2.5 a la rama 3.

Mi problema es que al activar los términos del servicio, le inserto la id del artículo que tiene que mostrar, pero sin embargo, en lugar de mostrarme solo ese artículo, aparecen todos los artículos que están configurados como destacados, De modo que aparecen todos los artículos destacados, tal y como se ven en la portada de la web. Si quito los artículos destacados, no aparece nada, simplemente la página en blanco, con el título del menú de Inicio. ¿A qué se puede deber esto?

Gracias anticipadas. Saludos.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 05/04/2015 8:06 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola

Tendrás que facilitarnos una captura de donde configuras en enlace a "Términos del Servicio" para que podamos ver si es correcto el modo en que lo haces.

- Los formatos de capturas admitidos son .jpg y .png (no .bmp)
- No las incrustes en archivos .doc de Word o similares, ni en PDFs.
- No las unifiques en una sola captura.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 06/04/2015 4:45 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

NeroCaes
 NeroCaes
Estimable Member

Gracias Luís.

Te adjunto dos capturas de pantalla. La primera, desde el apartado de perfil de usuario, donde configuro el documento que tiene que abrir con las condiciones. La segunda captura corresponde al contenido de la ventana que se abre, al pinchar en términos y condiciones, del apartado para registrar una nueva cuenta. Aquí, en lugar de aparecer el artículo que he indicado en el plugin, aparecen todos los artículos que están configurados como destacados, y que aparecen en la pantalla de inicio de la web.

Un saludo.

ResponderCitar
Respondido : 06/04/2015 6:38 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Usas algún tipo de extensión para mostrar este link de términos de servicio?
Contenido solo visible a usuarios registrados

Envíanos algunas capturas de pantalla de como configuras el artículo a mostrar en este link.

saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 06/04/2015 11:16 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

NeroCaes
 NeroCaes
Estimable Member

Hola Jhon. No, no uso ninguna extensión para esto. Lo configuro directamente desde el plugin user profile que trae por defecto Joomla. En el apartado de términos, tiene un selector, para que selecciones el artículo que quieres que aparezca como términos.

Saludos.

ResponderCitar
Respondido : 06/04/2015 11:32 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Cual es el articulo que estas adjuntando? seria bueno que adjuntas la url para poder visualizarlo.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/04/2015 1:26 am

Cursos Gratuitos WordPress

NeroCaes
 NeroCaes
Estimable Member

Hola,
Ésta es la url del artículo: http://00.buscametales.com/16-web/6-normas-del-foro.html

Pero realmente, da igual el artículo que ponga, el resultado siempre es el mismo, y lo que se muestra son los artículos que están marcados como destacados y que se muestran en la página principal. Si desmarco los artículos destacados, la ventana aparece en blanco. Reseñar que el artículo que quiero incluir en las condiciones, no está marcado como destacado. Otro detalle importante, es que al abrir la ventana, el sistema no está formateando el texto ni los elementos de la ventana.
Saludos.

ResponderCitar
Respondido : 07/04/2015 12:41 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Por lo que veo, parece que el problema está en que se está generando de forma incorrecta el enlace que carga el artículo.

Prueba a crear un elemento de menú que cargue el artículo que quieres mostrar en los términos del servicio. Si no quieres que ese elemento de menú se vea en tu web crea un nuevo menú que no publicarás en ningún módulo y añade en él el elemento de menú. Es probable que esto arregle el problema.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/04/2015 4:17 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

NeroCaes
 NeroCaes
Estimable Member

Hola nuevamente,

Hice lo que me recomendó Pablo, y ciertamente cuando meto un ítem de menú para que cargue el artículo de las normas, funciona medio bien. Digo medio bien porque aunque funcione, me parece una salida por la tangente, ya que considero que el sistema debería funcionar a secas, no hacerlo con artimañas que a final de cuentas, no dejan de ser soluciones a medias. A pesar de que ahora ya carga el artículo con las condiciones de uso correctas, el artículo sigue sin coger la hoja de estilos que tiene todo el sistema asignada. ¿Hay alguna solución para esto?

Daros las gracias por toda vuestra ayuda, que sin duda no es poca. Aunque en mi mensaje me muestre algo crítico, evidentemente no es una crítica hacía vuestra labor que siempre es intachable, sino a las propias fallas que a veces surgen en Joomla.

Un saludo.

ResponderCitar
Respondido : 08/04/2015 9:49 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El problema de que no se haya mostrado y tengas que haber creado un ítem de menú es posiblemente debido a algún tipo de fallo con el artículo específico o con las urls, por ejemplo prueba cambiando de artículo, en versiones anteriores a Joomla se han detectado algunos problemas con el .html en las urls amigables, podrías probar quitar esta opción de la urls amigables y probar si te funciona.

Con respecto al estilizado del artículo que se muestra es por que se muestra el artículo sin ningún CSS , tendrías que definir los estilos desde el propio editor en la construcción del artículo

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/04/2015 10:53 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

NeroCaes
 NeroCaes
Estimable Member

Hola Jhon,
no, no se trata de un problema con las urls amigables ni tampoco con el artículo en cuestión. He probado con otros artículos, y el problema es exactamente el mismo. He probado también en una instalación limpia de Joomla, y aunque de otro tipo, pero también ha dado problemas el sistema de normas. La única explicación que me queda, es que se pueda tratar de algún problema relacionado con el contenido o la estructura de la BBDD. Comparando instalaciones de Joomla, por ejemplo los packs de Yootheme, usan algunas modificaciones en algunas tables, campos NULL, cuando por defecto en la instalación de Joomla vienen como NOT NULL, y pequeños detalles de este tipo.

ResponderCitar
Respondido : 09/04/2015 1:25 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Una opción podría ser generar un segundo articulo para que puedas modificar el estilo de los textos, es posible que sea un problema de la plantilla, verifica si dispones de una actualización.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/04/2015 1:52 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro