Avisos
Vaciar todo

Visualización incorrecta de módulo Testimonios Clientes de plantilla Zenit II  

 
Adrián Ituarte
 Adrián Ituarte
Honorable Member

Hola,
Estoy usando Joomla 3 Zenith II, no puedo hallar mi error en la personalización del módulo Testimonios Clientes. Al hacer click en la flecha Next, los contenidos desaparecen. He instalado la plantilla Zenith II en un directorio prueba y desde el módulo Testimonios Clientes he copiado la sintaxis que por defecto tiene la plantilla nueva (que funciona perfectamente) en el módulo Testimonios Alumnos del sitio que estoy desarrollando. Sólo he reemplazado las fotos de perfil. El problema se mantiene. Agradecería me ayuden a encontrar la solución, desde ya gracias de antemano!!

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 15/02/2016 10:30 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Cuantos testimonios tienes creados?, haz realizado la prueba con un mínimo de 4?, de esta manera se podrá verificar si se trata de un bug del modulo.

ResponderCitar
Respondido : 16/02/2016 5:35 am

Cursos Gratuitos WordPress

Adrián Ituarte
 Adrián Ituarte
Honorable Member

Hola Johnny,

Tengo creados 4 testimonios, los que vienen por defecto, salvo que he reemplazado las imágenes. Mismo tamaño, distinto nombre. Es decir la sintaxis es exacta (copy/paste) a la plantilla original...

ResponderCitar
Respondido : 16/02/2016 12:37 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Revisando el código y haciendo pruebas veo que se añade una etiqueta div cuando se pulsa en la flecha para cambiar los testimonios, cosa que no ocurre en la configuración por defecto.

A modo de prueba, prueba a cambiar el código que tienes actualmente en el módulo (haz una copia del mismo antes) por el siguiente, y comprueba si funciona:

Esta publicación ha sido modificada el hace 2 meses por antonio
ResponderCitar
Respondido : 16/02/2016 2:53 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Adrián Ituarte
 Adrián Ituarte
Honorable Member

Hola Pablo,

He duplicado el modulo, Testimonio 2 y he pegado la sintaxis que me sugeriste. El problema se mantiene...

ResponderCitar
Respondido : 16/02/2016 4:46 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

No deberías duplicar, ya que si hay un error de sintaxis en la primera parte afectará a la copia al ser visto en tu navegador

Prueba con el código que te dio Pablo directamente, si aún tines problemas prueba visualizando este módulo en otra página diferente de la de inicio , la idea es ver que no existe conflicto con otros módulos.

Saludos.

ResponderCitar
Respondido : 16/02/2016 6:07 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Adrián Ituarte
 Adrián Ituarte
Honorable Member

Hola John,

1) Codigo enviado por Pablo en Módulo Testimonio a corregir. No funciona cuando se pulsa la flecha next.
2) Codigo enviado por Pablo en Módulo Testimonio a corregir, en otra posición o en otras páginas. No funciona cuando se pulsa la flecha next.
3) Codigo enviado por Pablo en Módulo Testimonio 3 creado como HTML personalizado. No funciona, ver imagen adjunta.
4) Codigo original plantilla en Módulo Testimonio 3 creado como HTML personalizado. No funciona, ver imagen adjunta.

ResponderCitar
Respondido : 16/02/2016 10:45 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Utilizas el editor JCE?, es posible que el editor te corte el código, prueba a cambiarlo por sin editor y luego intenta nuevamente

ResponderCitar
Respondido : 17/02/2016 12:01 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Adrián Ituarte
 Adrián Ituarte
Honorable Member

Hola Johnny,

He probrado SIN EDITOR, y el módulo Testimonios sigue presentando el mismo problema de visualización. Click en la flecha next, y desaparecen los testimonios 3 y 4.-

ResponderCitar
Respondido : 17/02/2016 1:17 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Según lo que he revisado el código html que te ha enviado Pablo es correcto, el problema es en algún archivo javascript, si inspeccionas tu código con firebug verás que por alguna razón cuando usas la felcha para ver mas testimonios te crea un contenedor con este código :

...

Y tambien se modifica parte del código que sigue con un style , esto es incorrecto y no sucede en la demo.

Tendrías que revisar si es que tienes alguna extensión adicional que te esta cuasando conflicto, tendrías que descartar una a una, lo otro es que si has hecho modificaciones en javascript puede ser que estas te esten causando el problema

Saludos.

ResponderCitar
Respondido : 17/02/2016 5:24 pm

Cursos Gratuitos WordPress