Avisos
Vaciar todo

VM payment reds'ys  

 
JOSE LUIS
 JOSE LUIS
Prominent Member

Hola, intento acceder a la configuración de la forma de pago "VM payment reds'ys" y no me salen opciones

le doy a guardar y me da el siguiente aviso:
Aviso
alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.virtuemart_order_id : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `virtuemart_order_id` `virtuemart_order_id` INT(11) UNSIGNED DEFAULT NULL AFTER `id`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.order_number : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `order_number` `order_number` CHAR(32) DEFAULT NULL AFTER `virtuemart_order_id`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.virtuemart_paymentmethod_id : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `virtuemart_paymentmethod_id` `virtuemart_paymentmethod_id` MEDIUMINT(1) UNSIGNED DEFAULT NULL AFTER `order_number`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.cost_per_transaction : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `cost_per_transaction` `cost_per_transaction` DECIMAL(10,2) DEFAULT NULL AFTER `payment_currency`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.cost_percent_total : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `cost_percent_total` `cost_percent_total` DECIMAL(10,2) DEFAULT NULL AFTER `cost_per_transaction`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.tax_id : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `tax_id` `tax_id` SMALLINT(11) DEFAULT NULL AFTER `cost_percent_total`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.Ds_Date : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `Ds_Date` `Ds_Date` CHAR(16) DEFAULT NULL AFTER `tax_id`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.Ds_Hour : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `Ds_Hour` `Ds_Hour` CHAR(16) DEFAULT NULL AFTER `Ds_Date`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.Ds_TransactionType : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `Ds_TransactionType` `Ds_TransactionType` CHAR(8) DEFAULT NULL AFTER `Ds_Hour`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.Ds_SecurePayment : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `Ds_SecurePayment` `Ds_SecurePayment` CHAR(8) DEFAULT NULL AFTER `Ds_TransactionType`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.Ds_MerchantData : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `Ds_MerchantData` `Ds_MerchantData` CHAR(255) DEFAULT NULL AFTER `Ds_SecurePayment`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.Ds_AuthorisationCode : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `Ds_AuthorisationCode` `Ds_AuthorisationCode` CHAR(255) DEFAULT NULL AFTER `Ds_MerchantData`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.Ds_Card_Country : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `Ds_Card_Country` `Ds_Card_Country` CHAR(3) DEFAULT NULL AFTER `Ds_AuthorisationCode`

alterTable CHANGE w47fa_virtuemart_payment_plg_redsys.post_raw : ALTER TABLE `w47fa_virtuemart_payment_plg_redsys` CHANGE COLUMN `post_raw` `post_raw` TEXT DEFAULT NULL AFTER `Ds_Card_Country`

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 26/06/2015 3:36 pm
Julen
 Julen
Miembro Admin

Hola,

Al parecer es un problema con la base de datos y Virtuemart.

¿Has comprobado si renombrando los archivos de sobreescritura del template te sucede lo mismo?

Ubica : /templates/TU_TEMPLATE/html/com_virtuemart

Renombra este directorio por : back_com_virtuemart por ejemplo

Si tras estas modificaciones, los problemas persisten, prueba a reinstalar virtuemart manualmente, que podrás encontrar en el siguiente enlace:

virtuemart.net/download

Tendrás que instalar los archivos como si de una extensión se tratara.
Recuerda hacer una copia de seguridad antes de proceder con la actualización.

Saludos

ResponderCitar
Respondido : 26/06/2015 5:36 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

JOSE LUIS
 JOSE LUIS
Prominent Member

Hola! he instalado la última versión de Virtuemart, primero este archivo

y luego este:

El mensaje de instalación me dice que todo perfecto, pero la configuración de el método de pago tarjeta de crédito sigue igual

¿Qué me aconsejáis?

ResponderCitar
Respondido : 02/07/2015 11:34 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica instalando otro Pack en tu cuenta y haz la prueba nuevamente:

Confirmarnos si el error persiste.

ResponderCitar
Respondido : 03/07/2015 12:00 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

JOSE LUIS
 JOSE LUIS
Prominent Member

Hola, cuando me dices que pruebe a instalar un nuevo pack, ¿te refieres a otro pack distinto a Anthe o al mismo? ¿Y lo instalo desde aquí?

ResponderCitar
Respondido : 04/07/2015 11:02 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jose Luis,

Prueba, por favor a realizar una copia de seguridad y luego actualizar a la versión 3.0.9.4 y mira si aparecen las opciones.

Si no aparecen, coméntanoslo para que sigamos revisando 🙂

Saludos

ResponderCitar
Respondido : 04/07/2015 11:59 pm

Cursos Gratuitos WordPress

JOSE LUIS
 JOSE LUIS
Prominent Member

Buenos días, es esa la versión que tengo

ResponderCitar
Respondido : 05/07/2015 8:28 am
Rafael
 Rafael
Miembro Moderator

¡Hola Jose Luis!

Tal y como te comentaba Jhonny, te recomiendo que instales el mismo Pack que actualmente usas en otro directorio y proceder a configurar el método de pago que deseas verificando si funciona correctamente.

Para ello, desde cPanel > Bloque Packs Webempresa > Aplicaciones destacadas - Pulsa en "Ver más", selecciona el Pack > Instalar Aplicación > en la casilla dominio coloca el dominio a utilizar y en la casilla ruta coloca la palabra -> prueba

Por último, termina de realizar la instalación y verás que se instala el pack en la dirección eldominioseleccionado.com/prueba

Realizado esto, prueba la configuración del método de pago deseado.

Saludos

ResponderCitar
Respondido : 05/07/2015 4:05 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

JOSE LUIS
 JOSE LUIS
Prominent Member

Sí, ya lo he instalado y la configuración del método de pago "tarjeta" funciona, en el otro pack de prueba. ¿Porqué no funciona en el que yo tengo instalado? ¿Qué puedo hacer? si no me funciona eso, todo lo que he conseguido hasta ahora no me serviría de nada.

ResponderCitar
Respondido : 05/07/2015 4:43 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

En tu sitio web en donde no funciona, has actualizado Joomla o virtuemart?, es posible que tengas una versión antigua de la pasarela ya que salen errores a nivel de BD

Indícanos que versión exacta del plugin tienes, lo puedes averiguar desde Gestor de Extensiones, también compara con la versión del plugin en la instalación en donde si funciona.

Saludos.

ResponderCitar
Respondido : 05/07/2015 5:01 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

JOSE LUIS
 JOSE LUIS
Prominent Member

Hola, tengo la misma versión instalada, esta es mi versión:

y esta es la del pack tienda de prueba:

ResponderCitar
Respondido : 05/07/2015 11:05 pm
JOSE LUIS
 JOSE LUIS
Prominent Member

Hola, tengo la misma versión instalada, esta es mi versión:

y esta es la del pack tienda de prueba:

ResponderCitar
Respondido : 05/07/2015 11:05 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola José Luis,

¿En ambas pasarelas tienes configurados los mismos datos?
¿Están configuradas en modo sandbox (pruebas) o modo real?
¿Ambas instalaciones utilizan la misma versión de Joomla?

Saludos

ResponderCitar
Respondido : 06/07/2015 12:16 am
JOSE LUIS
 JOSE LUIS
Prominent Member

En mi tienda no puedo saber el modo que tengo no me deja acceder a configuración. te paso la captura de pantalla de mi tienda

y del pack tienda Anthe

¿Es esto lo que quieres comprobar? en las capturas puedes ver las versiones

ResponderCitar
Respondido : 06/07/2015 12:41 am

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jose Luis,

Ok, veo que en la Anthe con VirtueMart 3.0.8 te funciona perfectamente y en la otra instalación con una versión más nueva no te funciona.

Preguntaba por la versión de Joomla exacta de ambas instalaciones.

No obstante envía un Ticket al Departamento de "Packs" para que revisen si hay alguna anomalía "rara" en ese pack y te informen, para descartar cosas 🙂

Saludos

ResponderCitar
Respondido : 06/07/2015 3:35 am