Avisos
Vaciar todo

Búsqueda de la tienda no funciona  

 
Jose M. Laso
 Jose M. Laso
Usuario experto

Bueno, pues aquí estoy de nuevo con otro problema. He empezado a cargar productos en la tienda (Prestashop v1.6.0.6) y he probado el módulo de búsqueda, y no encuentra nada de nada. Ni por nombre, ni por referencia...

Hay que hacer algún tipo de indexación de los productos o algo??

Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 05/10/2014 7:33 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Realice una prueba de búsqueda y veo que funciona:

Puedes adjuntarnos algún ejemplo?

ResponderCitar
Respondido : 05/10/2014 7:52 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jose M. Laso
 Jose M. Laso
Usuario experto

Por lo que veo funciona para los productos de muestra que ya traía instalados el pack, pero no para los mios. ¿Quizás los he importado mal? Hay bastantes ya cargados en la sección de papelería.
Adjunto captura.
Edito: Por lo que veo solo encuentra los productos que están en la categoría inicio. Pero no los que están en las demás.

ResponderCitar
Respondido : 05/10/2014 7:57 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jose,

No tengo constancia que en la versión 1.6.0.6 hubiese un bug en el buscador, no obstante la versión estable de PrestaShop es la 1.6.0.9.

Si actualizas haz una copia de seguridad antes.

- Copias de Seguridad desde el Panel de Hosting cPanel: https://www.webempresa.com/blog/copias-de-seguridad-desde-el-panel-de-hosting-cpanel.html

¿Has realizado algún cambio en algún archivo de PrestaShop?.

En el buscador del Pack Mobile original nuestro funciona perfectamente:

http://demopacktienda.webempresa.eu/prestashop_mobile/index.php?controller=search&orderby=position&orderway=desc&search_query=iphone&submit_search=Buscar

Saludos

ResponderCitar
Respondido : 06/10/2014 3:19 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jose M. Laso
 Jose M. Laso
Usuario experto

Hola Luis, me plantearé lo del cambio de versión.
He hecho algunos cambios que me habéis ido aconsejando pero han sido sobre css, no creo que ninguno deba afectar al tema de la búsqueda (claro que yo no tengo mucha idea).
Me plantearé lo de la actualización. Supongo que si hago copia de seguridad y algo sale mal durante la migración luego la puedo restaurar sobre la versión nueva, ¿no?
Gracias.

ResponderCitar
Respondido : 06/10/2014 9:25 am
Lorena
 Lorena
Miembro Moderator

Hola José M.

Comprueba si tienes activada la indexación en tu backoffice ->Preferencias -> Buscar y fíjate que pone en Productos indexados te pondrá algo como 20/30 o lo que sea.
En esa misma pantalla tienes las opciones de:

Añadir los productos que faltan al índice.
Reconstruir el índice completo.

A continuación tienes una imagen de lo que acabo de comentarte.

Respecto a la actualización, siempre se debe hacer copia de seguridad para recuperarla en caso de haber algún problema.

Un saludo.

ResponderCitar
Respondido : 06/10/2014 1:52 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose M. Laso
 Jose M. Laso
Usuario experto

Perfecto Lorena, de eso se trataba. La verdad, ni siquiera me había fijado en ese menú y eso que llevo ya un par de semanas trasteando. Tenía indexados solo 11 de los 361 que llevo importados de momento. Ahora va de lujo, ya veo que hay mas opciones para determinar la orientación de la búsqueda.

En cualquier caso migraré a la version 0.9 lo antes posible, previa copia de seguridad.

Muchas gracias y un saludo. Tema Solucionado!

ResponderCitar
Respondido : 06/10/2014 2:00 pm