Avisos
Vaciar todo

Error 404 en modulo bloque de marcas o fabricantes  

Página 1 / 2
 
Enrique
 Enrique
Reputable Member

Hola me pasa lo mismo creo que el tema ya cerrado que indico en el enlace que sigue. El caso es que cuando pincho en el cuadro combinado o lista en el modulo "bloque de marcas" sale un error 404.

Sin embargo los fabricantes funcionan perfectamente en el modulo de navegacion por facetas y filtra perfectamente los productos sin dar error. Recientemente he modificado la columna izquierda para que aparezca en el index e incluye este modulo de antes pero no creo que tenga nada que ver. Antes si funcionaba.

He mirado los permisos 644 de lo que habla ese hilo y esta asi puesto. No se donde esta eso de la limpieza de urls que indica en la solucion al problema al final del hilo.

https://www.webempresa.com/foro/41-Preguntas-sobre-PrestaShop/145238-Error-404-p%C3%A1ginas-fabricantes.html?limitstart=0

Saludos y gracias como siempre.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 02/03/2016 9:49 pm
Julen
 Julen
Miembro Admin

Hola,

Prueba temporalmente a desactivar las urls amigables y después vacía la caché, para comprobar si así los enlaces de ya cargan. Así podremos determinar si el problema está con las urls amigables.

ResponderCitar
Respondido : 03/03/2016 9:11 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Enrique
 Enrique
Reputable Member

Hola, si las desactivo aunque sea temporalmente, al volverlas a activar, volveré a tener las mismas url generadas de forma amigable que antes no? lo digo por el rastreo de las url de Google.

saludos y gracias

ResponderCitar
Respondido : 04/03/2016 5:36 am
Julen
 Julen
Miembro Admin

Hola,

Efectivamente, tal y como nos indicas al volver activar las URL amigables, volverás a tener la misma configuración que tenias antes de desactivarlas.

Saludos

ResponderCitar
Respondido : 04/03/2016 9:24 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Reputable Member

Al desactivarlas funciona,, pero al verver a activarlas nada, sigue igual. Incluso vaciando la caché.

Saludos y gracias.

ResponderCitar
Respondido : 18/03/2016 4:23 am
Julen
 Julen
Miembro Admin

Hola,

En ese caso, te recomendamos que pruebes la siguiente solución =>

https://www.webempresa.com/foro/41-Preguntas-sobre-PrestaShop/145238-Error-404-p%C3%A1ginas-fabricantes.html?limitstart=0#224951

En ese mismo post, tienes adjunto el modulo que tienes que descargar y instalar.

Saludos

ResponderCitar
Respondido : 18/03/2016 10:00 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Enrique
 Enrique
Reputable Member

Lo he cargado pero no lo encuentro ni puedo instalarlo. He probado buscando de varias formas pero nada.

que debo hacer exactamente? por otro lado sirve para algo mas de esto de indexar? quita las id de las urls amigables?

saludos

ResponderCitar
Respondido : 19/03/2016 9:35 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Enrique.
Adjunto tienes al archivo que te indica mi compañero, Instalarlo como cualquier otra extensión, una vez instalado lo activas y accedes al plugin. Configúralo con las siguientes opciones:

Este plugin lo que hace es solucionarte los errores 404 que aparecen al modificar algún producto.

Nota: Recuerda realizar una copia de seguridad antes instalar el plugin
Copias de seguridad en PrestaShop con Akeeba Solo

Un saludo

ResponderCitar
Respondido : 19/03/2016 10:35 am

Cursos Gratuitos WordPress

Enrique
 Enrique
Reputable Member

Ya, pero como digo antes, no puedo llegar hasta donde me mandas la captura.

Cuando le digo subir fichero, lo hago como he hecho siempre con otros muchos modulos, y aparece el mensaje de "subido correctamente", pero no aparece justo debajo para poder elegir el boton instalar.

He estado buscando con el explorador de archivos la carpeta o el archivo en los modulos tanto dentro como fuera de mi tema y nada (buscando los nombres de carpeta dentro del zip, el nombre descriptivo y el que aparece en la ruta de la barra de titulo del modulo en el back end).

Saludos.

ResponderCitar
Respondido : 10/04/2016 12:10 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Enrique
Perdón Había un problema en el empaquetado del archivo que te adjuntamos :blush:

Revisa si con el que te adjunto puedes instalarlo.

Un saludo

ResponderCitar
Respondido : 10/04/2016 2:11 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Enrique
 Enrique
Reputable Member

Hola, me he puesto con ello de nuevo y nada. No funciona, sigue haciendo lo mismo.

Me deja elegir el archivo zip, y me da incluso el mensaje de subirlo correctamente, pero nada. No aparece en el listado como cualquier modulo recien subido para ser instalado. Lo he buscado por los nombres que aparecen en tu captura de pantalla anterior, y nada de nada.

Incluso, como estoy haciendo pruebas en un clon de mi tienda actualizado a la ultima version, que por cierto sigue haciendo lo mismo (no se para que tanta actualizacion), y falla igualmente el modulo que me mandas.

Que extraño. Seguro que es un modulo correcto? No hay otra solución mas fiable?.

La verdad es que ya no me fio, no se que estoy subiendo a mi tienda, he probado como seis veces y no se que ha estado haciendo porque voy a buscarlo con el explorador de archivos y no encuentro nada parecido ni en modules, ni en themestemamodules, ni en themestemamodulescssmodules. Yo creo que la carpeta para alojar lo subido es modules no?

Saludos y gracias.

ResponderCitar
Respondido : 04/05/2016 7:51 pm
Enrique
 Enrique
Reputable Member

Hola de nuevo. Aunque te he mando la respuesta anterior, he vuelto a mirar por el nombre de la carpeta que hay dentro del zip (no habia caido, lo siento) y lo he probado en la tienda clon.

Es un modulo distinto al que me indicas, ni tan siquiera tiene la misma apariencia al configurarlo. De hecho ojo, si lo pruebas o lo prueban por que se pone a trabajar con darle a instalar y sin preguntar ni nada. Ha tenido al servidor ocupado unos 10 minutos al menos (comprobado en cpanel). Parece ser que lo que hace es quitar las IDs, pero creo que tampoco lo hace. Ya que estaba he probado a ver si hace lo que dice:
- dsactivado el smarty
-desactivado las urls amigables
-activado las urs amigables
- vaciado la cache

y nada, siquen apareciendo los ids, asi que he mirado si lo que hace es tocar o permitor tocar de la parte inferior del enlace "seo y urls" en preferencias para poder quitar del formato de los enlaces el {id} pero nada.

Asi que me olvido de esto directamente.

Hay alguna forma de que funcione este modulo de fabricantes entonces? Si me funciona el filtro de fabricantes que tengo puesto en el modulo "navegacion por facetas".

Un saludo y abrazos.

ResponderCitar
Respondido : 04/05/2016 8:46 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El módulo al parecer no trabaja correctamente con versiones actuales de PS, revisa como desinstalarlo siguiendo las indicaciones
https://github.com/Ha99y/PrestaShop-modules-CleanURLs

Has realizado cambios en las configuraciones de urls amigables?, es decir en el formato de los enlaces, ver imagen

Saludos.

ResponderCitar
Respondido : 04/05/2016 11:46 pm
Enrique
 Enrique
Reputable Member

Ya decia yo.

Yo ya tenia cambios hechos en las configuraciones de las urs amigables (te lo digo por si las has mirado), pero no ha hecho ningun cambio este modulo en eso, ni me deja quitar campos fijos como las ids si te refieres a eso.

lo quitaré y listo.

Saludos y gracias a todos

ResponderCitar
Respondido : 05/05/2016 1:00 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Enrique
 Enrique
Reputable Member

Hola de nuevo John, aqui pego lo que dice para desisnntalar. Hay muchos archivos para borrar. Me da miedo, vaya a liarla borrando archivos importantes. Lo hago tranquilamente?

UNINSTALLATION
Go to modules -> Find and uninstall "CleanURL".
Open folder /override/classes/ -> Remove "Link.php" -> Remove "Dispatcher.php"
Open folder /override/controllers/front/ -> Remove "CategoryController.php" -> Remove "CmsController.php" -> Remove "ManufacturerController.php" -> Remove "ProductController.php" -> Remove "SupplierController.php"
Open folder /cache/ -> Remove "class_index.php"

Go to back office -> Preferences -> SEO and URLs -> Set userfriendly URL off -> Save Go to back office -> Preferences -> SEO and URLs -> Set userfriendly URL on -> Save

If you got any other override modules, you should now go to you back office, uninstall them, and reinstall them again to work correctly.

ResponderCitar
Respondido : 05/05/2016 1:10 am
Página 1 / 2