Avisos
Vaciar todo

Error 404 en modulo bloque de marcas o fabricantes  

Página 2 / 2
 
Enrique
 Enrique
Reputable Member

Hola me pasa lo mismo creo que el tema ya cerrado que indico en el enlace que sigue. El caso es que cuando pincho en el cuadro combinado o lista en el modulo "bloque de marcas" sale un error 404.

Sin embargo los fabricantes funcionan perfectamente en el modulo de navegacion por facetas y filtra perfectamente los productos sin dar error. Recientemente he modificado la columna izquierda para que aparezca en el index e incluye este modulo de antes pero no creo que tenga nada que ver. Antes si funcionaba.

He mirado los permisos 644 de lo que habla ese hilo y esta asi puesto. No se donde esta eso de la limpieza de urls que indica en la solucion al problema al final del hilo.

https://www.webempresa.com/foro/41-Preguntas-sobre-PrestaShop/145238-Error-404-p%C3%A1ginas-fabricantes.html?limitstart=0

Saludos y gracias como siempre.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 02/03/2016 9:49 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Es recomendable realizar una copia de seguridad antes de realizar cualquier desinstalación.

Si no estas del todo seguro prueba solo a desactivarlo.

ResponderCitar
Respondido : 05/05/2016 4:58 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Enrique
 Enrique
Reputable Member

Bueno, entonces volviendo al tema que nos trata que es arreglar el modulo de fabricantes, ¿hay alguna solucion fiable que no sea lo de las urls amigables ni lo de meter mas modulos raros?

gracias y saludos

ResponderCitar
Respondido : 06/05/2016 11:28 am
Enrique
 Enrique
Reputable Member

Hola, os mando este aviso aun pendiente de respuesta, por que me ha funcionado una cosa que leí de la respuesta de un usuario, ya no recuerdo donde.

Poniendo guion bajo en vez de guion medio en el formato de las urls {rewrite}_{id}. Probado sigue funcionando los fabricantes en el modulo de navegacion por facetas tambien.

Os pregunto si ¿seria posible sabiendo esto, tocar algo en algun archivo que no obligue a esto y vuelva a funcionar con los guines medios? He visto en varios sitios que por lo visto a google lo de los guiones bajos.. para nada los quiere.

Saludos

ResponderCitar
Respondido : 06/05/2016 12:01 pm

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

No sería conveniente una modificación del código para el tema de los guiones medios, ya que casi con total seguridad esto habrá que hacerlo en un archivo propio de PrestaShop, y no en un módulo o tema, por lo que los cambios se perderían con la actualización de PrestaShop.

Google no tiene problema en que las urls lleven guiones bajos. Los suele interpretar como espacios en blanco.

ResponderCitar
Respondido : 06/05/2016 3:31 pm
Enrique
 Enrique
Reputable Member

Entonces dais por buena esta solucion?

saludos

ResponderCitar
Respondido : 06/05/2016 3:39 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Sí, se podría aplicar esa solución.

ResponderCitar
Respondido : 06/05/2016 4:41 pm
Enrique
 Enrique
Reputable Member

Bien entones.

Saludos y gracias

ResponderCitar
Respondido : 06/05/2016 6:26 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Página 2 / 2