error 500 en modulo redsys  

 
Nacho
 Nacho
Usuario activo

Buenas tardes,
Acabo de instalar el modulo de Redsys para mi prestashop, y ellos me dicen que tengo un error 500 a la hora de pasar una tarjeta denegada.
Esto es lo que me comentan ellos en un email. Como podria solventarlo? Gracias de antemano.

Le informamos que el error es el Server returned HTTP response code: 500 en las notificaciones a la url indicada https://www.espacioorganico.com/tiendaonline/index.php?fc=module&module=redsysoficial&controller=validation debido a que actualmente es posible que exista un bloqueo, restricción o filtro por parte del servidor el cual no permite conectar para que se entreguen las notificaciones online.
Para solventar esta incidencia rogamos revisar estos errores con su proveedor del servidor y verificar que no se estén bloqueando las siguientes ips:
195.76.9.222
195.76.9.187
195.76.9.182
193.16.243.33

En caso de tener el servicio CloudFlare activo, indicarle que el mismo utiliza su propio certificado y cipher suites por lo que es necesario configurarlo para que utilice al menos uno de los siguientes cipher suites:
TLS_RSA_WITH_AES_256_CBC_SHA256
TLS_RSA_WITH_AES_256_CBC_SHA
TLS_RSA_WITH_AES_128_CBC_SHA256
TLS_RSA_WITH_AES_128_CBC_SHA
TLS_RSA_WITH_AES_256_GCM_SHA384
TLS_RSA_WITH_AES_128_GCM_SHA256
TLS_RSA_WITH_3DES_EDE_CBC_SHA
TLS_RSA_FIPS_WITH_3DES_EDE_CBC_SHA
TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384
TLS_ECDH_RSA_WITH_AES_256_CBC_SHA384
TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA
TLS_ECDH_RSA_WITH_AES_256_CBC_SHA
TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256
TLS_ECDH_RSA_WITH_AES_128_CBC_SHA256
TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA
TLS_ECDH_RSA_WITH_AES_128_CBC_SHA
TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
TLS_ECDH_RSA_WITH_AES_256_GCM_SHA384
TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
TLS_ECDH_RSA_WITH_AES_128_GCM_SHA256

Es posible que el error se esté generando porque el servidor no tiene habilitadas las comunicaciones, pero dicho error se puede generar por distintos motivos, le indicamos algunos de los mas comunes pero es necesario que se comunique con el proveedor del servidor para lograr solventarlo.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 16/10/2019 2:17 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Nacho.

El único error que veo es del 15:

[15-Oct-2019 13:53:54 UTC] PHP Fatal error: require_once(): Failed opening required '/home2/espacior/public_html/web/wp-content/plugins/digital-publications-by-supsystic/modules/book/classes/dom2pdf/lib/fonts/dompdf_font_family_cache.dist.php'

Pero hace referencia a una extensión de WordPress que supongo es de otra instalación.

Veo que utilizas la version 1.7.4.2 de prestashop, una versión que estaba dando muchos problemas de compatibilidades.

Previa copia de seguridad actualiza la versión de Prestashop y modifica también la version de PHP, instalas por ejemplo la versión 7.2.

En esta guía tienes informacion de como modificar la versión de PHP:
-> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

El cambio de versión de PHP no afecta a los archivos de tu Web y es solo a nivel servidor. Una vez modificada la versión revisa que todas las partes de la Web carguen bien, si vieras que hay problemas en algún bloque puedes bajar de version de PHP.

No sé si utilizas un módulo de terceros para Redsys o utilizas el oficial.
Puedes descargar el módulo oficial desde este enlace:
-> https://pagosonline.redsys.es/descargas.html

Revisa todos los puntos que te comento y comprueba si solucionan el problema.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 16/10/2019 5:31 pm

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro