Modulo Categorias no se configura bien  

 
isabel
 isabel
Reputable Member

Buenas noches.

He actualizado una nueva tienda de 1.5 a 1.6, pero da un fallo en el modulo de categorias y no se como solucionarlo.

El caso es que aparece el modulo, pero no las categorias cuando entras dentro de un producto.

Ayer me sucedio lo mismo con otra tienda y Pablo me aconsejo lo siguiente:

Agregando un código css como el siguiente es posible que se arregle el problema:

#categories_block_left ul.tree {
display: block !important;
}

Se podría añadir al final de archivo themes/leomobi/css/global.css

Pues bien, esto lo he puesto en practica con esta nueva tienda que tiene la misma plantilla y si que aparecen las categorias en la ficha de producto, pero el problema es que aparecen totalmente desplegadas haciendose muy largo. Que solucion tiene esto?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 05/02/2015 2:51 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Adjuntanos el enlace o la captura del problema, es posible que durante la actualización el modulo haya dejado de funcionar y que también necesite de un actualización.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/02/2015 5:24 am

Cursos Gratuitos WordPress

isabel
 isabel
Reputable Member

Hola.

Te envio uno de los enlaces, porque en una captura no se puede de lo largo que se hace.

http://www.regalospuntocom.com/maletas-y-trolley/636-trolley-.html

Un saludo.

ResponderCitar
Respondido : 05/02/2015 10:11 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Veo que el error parece producirse solo en la ficha de los productos. Además, veo que esto coincide con un error de javascript.

Es posible que se trate de un problema de compatibilidad entre el tema que estás usando (Mobile) y la versión 1.6 de PrestaShop.

Prueba ir al directorio themes/leomobi/modules y renombra el directorio blockcategories como blockcategories_BAK. Ahora sube en esa ruta el archivo blockcategories.zip que te adjunto y descomprímelo (lo puedes hacer con el administrador de archivo de CPanel). Se deberá generar un nuevo directorio blockcategories. Comprueba si así se soluciona el problema.

De no ser así, prueba a eliminar este directorio blockcategories generado, aunque esto puede afectar al diseño.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/02/2015 11:52 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

isabel
 isabel
Reputable Member

Hola Pablo.

Acabo de hacer lo que me indicas y no da resultado, te adjunto pantallazo para que lo veas, aunque como no resulta ya lo he borrado.

En cuanto a la compatibilidad del tema, esta plantilla la estoy utilizado en otra tienda y con lo que me indicaste en su momento se soluciono, pero ahora no funciona.

Agregando un código css como el siguiente es posible que se arregle el problema:

#categories_block_left ul.tree {
display: block !important;
}

Se podría añadir al final de archivo themes/leomobi/css/global.css

No tenemos otra manera de solucionar esto?

ResponderCitar
Respondido : 05/02/2015 12:19 pm
Lorena
 Lorena
Miembro Moderator

Hola Isabel,

¿Has comprobado que en esta página y la otra en la que se solucionó tengas las mismas versiones del módulo y configuraciones?

¿Puedes volver a aplicar el cambio de ficheros que te indicó Pablo y dejarlo para que podamos comprobar en el código?

Como ahora está sin el cambio sigo viendo el error de javascript, pero no puedo comprobar si sigue con el cambio que te dijo Pablo.

Un saludo.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/02/2015 1:13 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

isabel
 isabel
Reputable Member

A que cambio te refieres Laura, al del directorio con el archivo zip o agregando el codigo css?

ResponderCitar
Respondido : 05/02/2015 1:16 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

La última captura de pantalla que has enviado no muestra la información que comentabas. Vuelve a adjuntarla, cambiado de nombre el archivo.

Si en otra web con la misma plantilla te funciona es posible que te no tengas en ella la misma versión de PrestaShop o de la plantilla, o que estés utilizando algún módulo adicional en alguna de las webs. Además, tendrías que comparar en ambas web el bloque de las categorías. Indícanos también la página donde esto te funciona correctamente.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/02/2015 2:48 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Por favor Iniciar Sesión o Registro