Problema con modulo de pago en mi prestashop  

 
Cristian
 Cristian
Usuario activo

Buenas tardes, tengo un problema con un modulo de mi prestashop,
es un modulo de pago para mi pais Chile, todo funcionaba perfecto hasta ayer que me da este mensaje:

A continuación le indicamos el error y los 50 primeros caracteres de la respuesta recibida:
Error: No signature - Response:
404 Not Found

El formato correcto de su respuesta debería ser:
status=ACEPTADO&c=email de su comercio&s= su firma electrónica

Me contacte con la empresa del modulo, la cual señala lo siguiente

Al revisar lo mencionado, encontramos la siguiente situación:
1) Al concretarse un pago, Flow envía una notificación de pago exitoso a la página de confirmación del comercio, que en su caso es: https://www.chilesteam.cl/modules/flowpayment/validate.php
2) La notificación consiste en una llamada POST que va desde Flow a la página de confirmación del comercio, el cual debe ser recibido y procesado por la misma.
3) Cuando la notificación enviada es procesada en forma correcta, Flow obtiene la siguiente respuesta por parte del comercio: ACEPTADOventas@chilesteam.clstatus=ACEPTADO&c=ventas%40chilesteam.cl
4) El problema, es que las transacciones ocurridas mediante su sitio web entregan la siguiente respuesta:
[Wed Nov 01 20:49:58 2017] [error] [client 190.3.169.141] post response

404 Not Found

404 Not Found


nginx

me dice que busque el error de la siguiente forma
Para verificar que error se debe inspeccionar el log del servidor (asociado a PHP

Pero no tengo conocimiento en programacion, donde y como puedo ver donde esta el error,
si alguien me pudiese ayudar de antemano Muchas gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 02/11/2017 4:36 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Has consultado este problema a través de tickets de soporte?, envía esta información detallada para que revisen primero si es que se esta produciendo algún tipo de bloqueo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/11/2017 5:44 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Cristian
 Cristian
Usuario activo

Hola

Has consultado este problema a través de tickets de soporte?, envía esta información detallada para que revisen primero si es que se esta produciendo algún tipo de bloqueo.

Saludos.

Hola, si me contacte al soporte, solo me dijeron que actualize mi versión prestashop a la mas reciente
Ya lo hice, pero sigo con el mismo problema

Gracias por responder

ResponderCitar
Respondido : 02/11/2017 7:43 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Has realizado alguna configuración reciente?, es extraño que antes te haya funcionado y ahora no. Verifica si tienes habilitados los parámetros de optimización y prueba deshabilitarlos.

Lo que podrías probar es instalarte un nuevo PrestaShop en una carpeta, instalar tu método de pago y hacer una prueba en este nuevo sitio de manera que podamos descartar si es un problema con la cuenta.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/11/2017 9:32 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Cristian
 Cristian
Usuario activo

Hola

Has realizado alguna configuración reciente?, es extraño que antes te haya funcionado y ahora no. Verifica si tienes habilitados los parámetros de optimización y prueba deshabilitarlos.

Lo que podrías probar es instalarte un nuevo PrestaShop en una carpeta, instalar tu método de pago y hacer una prueba en este nuevo sitio de manera que podamos descartar si es un problema con la cuenta.

Saludos

Ningun cambio he realizado dejo de funcionar asi sin mas el dia 1 del 11 2017
verifique los errores del modulo y me da esto
[03-Nov-2017 10:27:29 America/Santiago] PHP Notice: Undefined index: response in /home/chil1979/public_html/modules/flowpayment/validate.php on line 20
[03-Nov-2017 10:27:29 America/Santiago] Invalid response (no signature)
[03-Nov-2017 10:36:52 America/Santiago] PHP Notice: Undefined index: response in /home/chil1979/public_html/modules/flowpayment/validate.php on line 20
[03-Nov-2017 10:36:52 America/Santiago] Invalid response (no signature)
[03-Nov-2017 10:36:55 America/Santiago] PHP Notice: Undefined index: response in /home/chil1979/public_html/modules/flowpayment/validate.php on line 20
[03-Nov-2017 10:36:55 America/Santiago] Invalid response (no signature)
[03-Nov-2017 10:36:59 America/Santiago] PHP Notice: Undefined index: response in /home/chil1979/public_html/modules/flowpayment/validate.php on line 20
[03-Nov-2017 10:36:59 America/Santiago] Invalid response (no signature)

La pasarela del modulo me indico esto:
En este caso, sugerimos indicar al proveedor de hosting que su página requiere recibir un POST desde Flow, cuyas IPs son las siguientes:

flow.cl: 190.3.169.141
flow.tuxpan.com: 190.82.83.84

Cabe mencionar que por parte de Flow no se ha realizado ningún cambio en las últimas semanas.

ResponderCitar
Respondido : 03/11/2017 3:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Envía esta última comunicación a Tickets de soporte para que verifiquen si esas Ips pueden hacer post correctamente en tu cuenta.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 03/11/2017 5:50 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro