Avisos
Vaciar todo

Problemas con el navegador por facetas - error 500  

 
Gabriel
 Gabriel
Usuario activo

Hola!
Tengo instalado Prestashop 1.6.11 y no me funciona el módulo de navegación por facetas:

- en la página de filtrado de productos, al pulsar en cualquiera de las opciones me da un error 500 con el siguiente mensaje:
http://tuwebenelhorno.es/proyectos/bathstock/modules/blocklayered_mod/block…ed_price_slider=225_226&orderby=position&orderway=asc&n=24&_=1488988964817 500 (Internal Server Error)

- En la parte de administrador, en la pantalla para configurar el "layer navigation block", me da error 500 al intentar ejecutar cualquiera de las opciones de indexación: Index all missing prices/Rebuild entire price index/Build attribute index/Build URL index

¿Sabéis que puede estar ocurriendo?

Muchas gracias!

NOTA: La web está en desarrollo y se encuentra capada a nivel servidor

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 08/03/2017 5:32 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Qué versión de PHP tienes en tu cuenta de hosting?, evalúa cambiarte a PHP 7, revisa:
https://www.webempresa.com/blog/version-php-cpanel-como-cambiarla.html

Luego, si sigues con problemas, desinstala el módulo y prueba instalarlo nuevamente.

Saludos.

ResponderCitar
Respondido : 08/03/2017 8:28 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Gabriel
 Gabriel
Usuario activo

Hola!
La versiónde php es 5.6.3

He seguido los pasos para modificar la versión de PHP a la 7 en el .htaccess, pero no me ha funcionado (te adjunto pantallazo de fichero y de estructura de directorios)

¿Es posible que no esté disponible en mi cuenta? ¿Qué debo hacer para activarlo?

Gracias!

ResponderCitar
Respondido : 09/03/2017 2:36 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Gabriel.

El error 500 o pagina en blanco generalmente cuando sucede suele ser porque hay algún fallo en la programación, esto puede suceder si hemos hecho algún cambio en la plantilla del sitio web o si se instalo alguna extensión con algún bug.

cada vez que se genera uno de estos errores, se genera un fichero error_log y se introduce una línea indicando el motivo del error, el fichero y línea donde se ha producido. Esto nos ayudara para ver donde se producen los errores que aparecen en la web.

Puedes localizarlo accediendo desde cPanel -> administrador de Archivo y despliega la carpeta public_html y edita el fichero error_log.

Adjúntanos los errores que te indica o nos adjuntas el fichero para que podamos revisarlo.

Comprueba también si para ese modulo tienes alguna actualización disponible.

Un saludo

ResponderCitar
Respondido : 09/03/2017 3:12 pm

Cursos Gratuitos WordPress

Gabriel
 Gabriel
Usuario activo

Buenas tardes,
debo estar muy torpe, pero en la carpeta public_html no se encuentra ningún error_log. Sin embargo, hay unos ficheros de logs comprimidos llamados" tuwebenelhorno.es-'nombredelmes'-2017.gz" situados en la carpeta "logs" en el mismo nivel que el public_html. Pero estos ficheros no han recogido datos nuevos desde hoy a la 13:50. Os dejo un fragmento de los errores que muestran, ya que el fichero contiene básicamente estos errores repetidos una y otra vez:
1.37.135.57 - proyectos_horneados [09/Mar/2017:13:03:31 +0100] "POST /proyectos/bathstock/adminwe/ajax.php?rand=1489061012097 HTTP/1.0" 200 282 "http://tuwebenelhorno.es/proyectos/bathstock/adminwe/index.php?controller=AdminMeta&token=956c3edfcb7d161feabd3cd1a86d4317" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36"
81.37.135.57 - proyectos_horneados [09/Mar/2017:13:03:49 +0100] "POST /proyectos/bathstock/adminwe/ajax.php?rand=1489061030097 HTTP/1.0" 200 282 "http://tuwebenelhorno.es/proyectos/bathstock/adminwe/index.php?controller=AdminModules&token=81ebfb767e05318db3e064640a630dd2&configure=blocklayered_mod&tab_module=front_office_features&module_name=blocklayered_mod" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36"
81.37.135.57 - proyectos_horneados [09/Mar/2017:13:05:32 +0100] "POST /proyectos/bathstock/adminwe/ajax.php?rand=1489061133101 HTTP/1.0" 200 282 "http://tuwebenelhorno.es/proyectos/bathstock/adminwe/index.php?controller=AdminMeta&token=956c3edfcb7d161feabd3cd1a86d4317" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36"
81.37.135.57 - proyectos_horneados [09/Mar/2017:13:05:50 +0100] "POST /proyectos/bathstock/adminwe/ajax.php?rand=1489061151101 HTTP/1.0" 200 282 "http://tuwebenelhorno.es/proyectos/bathstock/adminwe/index.php?controller=AdminModules&token=81ebfb767e05318db3e064640a630dd2&configure=blocklayered_mod&tab_module=front_office_features&module_name=blocklayered_mod" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36"
66.249.93.149 - - [09/Mar/2017:13:06:43 +0100] "GET /proyectos/bathstock/index.php HTTP/1.0" 404 - "http://www.google.com/search" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko; Google Web Preview) Chrome/27.0.1453 Safari/537.36"
81.37.135.57 - proyectos_horneados [09/Mar/2017:13:07:33 +0100] "POST /proyectos/bathstock/adminwe/ajax.php?rand=1489061254104 HTTP/1.0" 200 282 "http://tuwebenelhorno.es/proyectos/bathstock/adminwe/index.php?controller=AdminMeta&token=956c3edfcb7d161feabd3cd1a86d4317" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36"
81.37.135.57 - proyectos_horneados [09/Mar/2017:13:07:51 +0100] "POST /proyectos/bathstock/adminwe/ajax.php?rand=1489061272106 HTTP/1.0" 200 282 "http://tuwebenelhorno.es/proyectos/bathstock/adminwe/index.php?controller=AdminModules&token=81ebfb767e05318db3e064640a630dd2&configure=blocklayered_mod&tab_module=front_office_features&module_name=blocklayered_mod" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36"
81.37.135.57 - proyectos_horneados [09/Mar/2017:13:09:34 +0100] "POST /proyectos/bathstock/adminwe/ajax.php?rand=1489061375108 HTTP/1.0" 200 282 "http://tuwebenelhorno.es/proyectos/bathstock/adminwe/index.php?controller=AdminMeta&token=956c3edfcb7d161feabd3cd1a86d4317" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36"
81.37.135.57 - proyectos_horneados [09/Mar/2017:13:09:52 +0100] "POST /proyectos/bathstock/adminwe/ajax.php?rand=1489061393109 HTTP/1.0" 200 282 "http://tuwebenelhorno.es/proyectos/bathstock/adminwe/index.php?controller=AdminModules&token=81ebfb767e05318db3e064640a630dd2&configure=blocklayered_mod&tab_module=front_office_features&module_name=blocklayered_mod" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36"

Gracias!

ResponderCitar
Respondido : 09/03/2017 6:19 pm
Gabriel
 Gabriel
Usuario activo

Un apunte importante por si nos puede ayudar: he instalado de nuevo un prestashop desde cero en el mismo servidor (otra carpeta), y me da el mismo tipo de errores que indiqué al comienzo del ticket.
Las características son:
Prestashop: 1.6.1.11
Tema: warehouse theme version 3.8.2

No funciona el navegador por facetas por defecto de PS ni el del tema (iqit block layered).

¿Puede ser un tema de versión de PHP o de configuración del servidor?

Gracias de nuevo.

ResponderCitar
Respondido : 09/03/2017 6:23 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Gabriel
 Gabriel
Usuario activo

Buenas de nuevo (y creo que última en esta cadena),
parece que he encontrado la solución. Al ver que no funcionaba independientemente del tema o configuración que usaba, he tirado por el campo permisos:
Resulta que en la instalación que se hace desde cpanel, los directorios se crean con permisos 777. En este caso, ha bastado con:
a) cambiar los permisos de la carpeta "modules" a 755 (no subcarpetas)
b) cambiar los permisos de la carpeta "blocklayered" a 755

Os lo indico para no daros más trabajo con este tema y por si puede servir de ayuda para futuras consultas.

Gracias por vuestra atención y ayuda!

ResponderCitar
Respondido : 09/03/2017 6:42 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

En una de tus capturas de pantalla cuando cambias la versión de PHP debe haber un espacio entre el 7 y .php

La instalación de PretaShop lo has realizado desde la instalación de los Packs y comentas que te instaló con permisos incorrectos?, no debería suceder esto.

Tal como comentas los permisos de todas las carpetas deberían ser 755 y de los archivos 644

Saludos.

ResponderCitar
Respondido : 09/03/2017 9:00 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Gabriel
 Gabriel
Usuario activo

Gracias por la indicación sobre el .htaccess y la versión de PHP, lo tendré en cuenta para siguientes ocasiones, en este caso no fue necesario finalmente.

En cuanto a las instalaciones, no se la razón, pero en las 2 instalaciones que realicé a través de los packs aparecían con 777 como permisos en las carpetas indicadas. Si no hubiera sido así no lo hubiera indicado como posible solución.
En definitiva, lo importante es que se consiguió arreglar.

Gracias por la ayuda!

ResponderCitar
Respondido : 14/03/2017 3:15 pm