Problemas con IVA. Módulo Redsys (y otros) no devuelven IVA  

 
Regina
 Regina
Nuevo usuario

Buenas tardes,

Hace tiempo que vengo arrastrando un tema el qual ya no puedo dilatar más en el tiempo.

Tengo problemas con Redsys, el tema es que de repente va bien, luego de repente empiezo a recibir errores de pago del estilo "ea ha cobrado xxx en vez de xxx". Aun así hay pedidos en los cuales se registra correctamente pero en el tpv se cobra sin iva. He intentado borrar y volver a instalar el modulo de redsys (que vosotros me recomendasteis dados los problemas que tuve con este modulo y el SSL) pero aún así tengo problemas con el IVA .

después de investigar e investigar, acabo de tener el mismo problema con otro módulo de pagos diferente a Redsys, con lo que me cabe pensar que no es el módulo si no que es algún fallo general, que hace que en algunos pedidos no se cobre el IVA (ahora ya prácticamente en todos).

El tema es que presta sabe el total a pagar, pero al salir de presta y pagar en la plataforma (Redsys o similar) el pago devuelve sin IVA.

Estoy problemas los vengo teniendo des de que instalé el SSL por primera vez (contratado con vosotros) así que empiezo a pensar que es alguna incompatibilidad con el mismo. (He leído problemas de incompatibilidad con módulos de pago)

La verdad es que es muy engorroso y poco serio estar reclamando a los clientes el IVA a parte. Necesito solucionarlo cuanto antes, hace meses que me pasa.

Dejo un par de pantallazos con el error.

De momento he desactivado el SSL des de prestashop a ver que pasa.

Un saludo!

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 04/08/2017 7:13 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Lo primero sería asegurarte que es un problema a nivel de PrestaShop o del módulo de pago.
Prueba creando un nuevo método de pago, por ejemplo Paypal, verifica si con este método te sucede lo mismo.

De ser este el caso entonces debes tener algo mal configurado o alguna inconsistencia en la data.

Dudo que sea algo de https, ya que este sólo se encarga de cifrar la comunicación, igual al desactivarlo seguraemente lo comprobarás. Has hecho algún otro tipo de cambio recientemente?, instalado módulos, importado datos?, etc.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 04/08/2017 10:11 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Regina
 Regina
Nuevo usuario

Gracias John,

Hasta ahora solo pasaba con Redsys, pero hoy me ha pasado con otro módulo de pago...

De momento sin SSL activado ya he comprobado que el módulo de hoy no ha fallado... le daré un poco más de margen.

Con Redsys tuve el mismo problema hace un tiempo, reinstalé el módulo y parece que todo ok.. pero ahora ya no sirve...

El tema es que yo este proyecto lo gestiono des de hace unos meses, antes lo llevaba una agencia que le estuvo metiendo vete a saber que modulos, había algunos originales, otros "backups"... pero esto puede ser como buscar una aguja en un pajar...

En cualquier caso antes del SSL ya no me pasaba... le daré más margen...

ResponderCitar
Respondido : 04/08/2017 10:43 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Es posible que el problema este en el modulo, utilizas el módulo de Redsys o el que te ofrece Webempresa?

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/08/2017 1:09 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Regina
 Regina
Nuevo usuario

Hola Johnny,

Ahora mismo el de Webempresa, ya que tuve problemas con el SSL anteriormente con el original, que había pedidos que no se registraban.

ResponderCitar
Respondido : 05/08/2017 3:09 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Cuando comentas que le darás más margen signfica que realizaras algunas pruebas?

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/08/2017 4:02 am

Cursos Gratuitos WordPress

Regina
 Regina
Nuevo usuario

Hola Johnny,

Me refiero a dejar unos días para ver con compras reales si el problema se soluciona deshabilitando el SSL.

De momento con los poco que ha entrado este fin de semana, a falta de comprobar redsys parece que no hay fallo...

Mañana confirmo todo 🙂

ResponderCitar
Respondido : 07/08/2017 2:45 am

Por favor Iniciar Sesión o Registro