Duda ACL  

 
Victor
 Victor
Usuario activo

Buenas, estoy volviendome algo loco configurando las ACL para un usuario creado en un grupo, que le quiero dar permisos para editar, borrar y modificar artículos de una determinada categoría. Hasta ahí bien.
También he configurado que tenga acceso al gestor multimedia. También ... bien!
Pero tengo un problema al crear un nuevo artículo. El botón que aparece abajo del editor (TinyMCE) donde pone "Imagen", y que sirve para poner una imagen a la noticia, no aparece. No tengo ni idea la razón pero me está haciendo perder mucho tiempo.
¿Alguien sabe darme alguna indicación para descubrir la razón? Con el usuario administrador si que aparece, claro.

También me podría ser de ayuda algún manual de como configurar un usuario/grupo para que puedan dar de alta noticias en una determinada categoría. (Por si repito el proceso de dar permisos)

Mi Joomla es 1.7.

Muchas gracias

URL del sitio: www.getbrit.es

Citar
Respondido : 30/07/2012 9:34 am
David Noguera
 David Noguera
Miembro Admin

Hola Victor, ese botón es un plugin de Joomla, accede a la administración >> gestor de plugins >> y filtra por el tipo "Editors - XTD", busca el plugin:

Editor Button - Image

Tendrás que configurar las ACL de ese plugin..

Saludos!

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/07/2012 10:14 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Victor
 Victor
Usuario activo

Hola, ya había estado mirando por ese lado. Había comprobado que ese botón estuviera habilitado y lo está, pero el tema de los permisos no lo había visto.
Ahora, conforme me dices, en el gestor de plugins -> Button - Image entro y no tengo muchas más opciones que habilitar o deshabilitar este plugin. ¿Dónde están los permisos para este plugin?

Perdona por la pregunta, donde configuro las ACL para este botón?. Gracias

ResponderCitar
Respondido : 30/07/2012 2:17 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Victor,

¿ El botón de imagen no se muestra en ese usuario, y si que se muestra si accedes como superadministrador ?

Entiendo que estamos hablando de que el usuario accede por el frontal del sitio web, y no desde el administrador.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 30/07/2012 2:35 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Victor
 Victor
Usuario activo

¿ El botón de imagen no se muestra en ese usuario, y si que se muestra si accedes como superadministrador ?
Así es

Es un usuario para entrar desde la back-end, o sea, entra desde la administración. Esa pregunta puede ser la clave, no? Alguna idea?

ResponderCitar
Respondido : 30/07/2012 3:41 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola Victor

Es extraño lo que comentas, asigna al usuario el grupo de gestor o administrador y verifica si te funciona.

Por otro lado te recomiendo actualizar a Joomla 2.5 que hay varias cosas que se han corregido y esta podría ser una de ellas.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/07/2012 9:47 pm

Cursos Gratuitos WordPress

Victor
 Victor
Usuario activo

Hola Jhon, gracias por la respuesta (también a Jordi y David, claro).
He probado a meter el usuario en el grupo de administradores y efectivamente, funciona bien. Aparece el botón Image.

Sigo sin entender este asunto, me está haciendo perder mucho tiempo.

Respecto a migrar a 2.5, si te digo la verdad, no tengo mucha idea de como hacerlo porque estoy trabajando sobre una plantilla que está preparada para 1.7 y no se como afectaría. Además, algunos módulos los he retocado y he hecho cambios sobre ellos. De momento me interesa encontrar el posible problema y no meterme en la migración.

Muchas gracias, y si alguien tiene alguna idea ... se lo agradezco

ResponderCitar
Respondido : 31/07/2012 8:12 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Victor,

Te será de utilidad el artículo http://magazine.joomla.org/issues/Issue-May-2012/item/761-Joomla-ACL-Configuring-back-end --> 3b. Assign permissions: Media Manager

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 31/07/2012 10:54 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Victor
 Victor
Usuario activo

Hola Jordi, ese documento es el que seguí para dar de alta el usuario y el grupo. Además en Español gracias a Ivan Ramos.
Voy a volver a repetirlo, pero me huele a que esto puede ser un problema de Joomla 1.7.

Si lo repito y funciona, confirmaré el problema.

Gracias.

ResponderCitar
Respondido : 31/07/2012 4:02 pm
Victor
 Victor
Usuario activo

Buenas, parece que ya está resuelto el enigma. En la zona de Confgiuración Global -> Permisos, debía asignarle además de permitir el acceso de Admin Login la opción de Crear.

No se la razón por la que afecta a ese botón, pero he probado y ha colado. En el manual de Ivan Ramos no habla de eso y por eso no lo hice.

Gracias por vuestra ayuda.

ResponderCitar
Respondido : 31/07/2012 4:12 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro