No puedo instalar componentes  

 
Marí­a
 Marí­a
Honorable Member

Hola, al intentar instalar componentes o acualizaciones de componentes ya instalados (en concreto akeeba backup... ya he hecho varias actualizaciones desde la primera instalación hace ya meses) me da el error:

JFolder::files: La ruta no apunta a un directorio válido o el directorio ha sido eliminado.
JFolder::folder: La ruta no apunta a un directorio válido o el directorio ha sido eliminado.
JFolder::files: La ruta no apunta a un directorio válido o el directorio ha sido eliminado.
¡Error! No puedo encontrar un archivo de configuración XML para Joomla! en el paquete.

Esta mañana he hecho un cambio, el video que se ve estaba en la ruta public_html/images/stories/images

El valor para la carpeta de imágenes era /images/stories. Cambié esta ruta a images y, creé una nueva carpeta conteniendo el video bajo /images/video. También copié ahí el fichero playlist.php. El video se ve correctametne en todo el sitio. Fue el único cambio que hice, no sé si puede tener que ver.

También se ven mal las imágenes de esta dirección: http://www.cmarosa.org/index.php?option=com_content&view=section&layout=blog&id=19&Itemid=502 que es una vista de tipo blog. Sin embargo, si se pincha en cada noticia de la vista blog, la imagen se visualiza correctamente en el artículo.

Muchas gracias,

María

Gracias,

María

Citar
Respondido : 27/05/2012 1:22 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla María

Con respecto a los problemas de instalación, te sugiero revises que tengas una ruta temporal válida, desde el backend de Joomla => configuración global => servidor => Ruta Carpeta Temporal.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/05/2012 2:13 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Marí­a
 Marí­a
Honorable Member

Hola, lo he revisado por si acaso y sí, existen las carpetas definidas en la ruta de la carpeta temporal que indicas. De hecho, bajo esa carpteta temporal he visto los .zip que he tratado de instalar sin éxito...
Se me olvidaba comentar que revisé los permisos y son correctos.

Estoy leyendo post por la web y muchas veces dicen que el error puede estar originado por el server. No sé si puede ser también este el caso ¿?

ResponderCitar
Respondido : 27/05/2012 2:48 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Maria,

¿Hay alguna razón especial por la que tengas un archivo php.ini personalizado en tu carpeta /public_html?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/05/2012 6:37 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Marí­a
 Marí­a
Honorable Member

No, nunca toqué ese archivo... veo que tiene hora de modificación hace una hora aproximada más o menos....
No sé para qué vale, no está dentro de los archivos que toqué esta mañana.

ResponderCitar
Respondido : 27/05/2012 8:08 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Maria,

Lo edito el técnico para indicarme que tenias ese archivo, de ahí que te aparezca recientemente editado.

¿Puedes renombrarlo a php.ini_old y probar a subir nuevamente archivos?, revisa que no tengas la Capa FTP en tu Configuración de Joomla! habilitada.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/05/2012 8:47 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Marí­a
 Marí­a
Honorable Member

Hola Luís,

renombrando ese fichero ahor sí puedo subir archivos para instalar... Gracias! Y por cierto, para qué se supone que valía ese fichero? Me dejará de funcionar algo si ya no está?

A continuación traté de actualizar el akkeba backup y, no me salen las 3 primeras líneas:
JFolder::files: La ruta no apunta a un directorio válido o el directorio ha sido eliminado.
JFolder::folder: La ruta no apunta a un directorio válido o el directorio ha sido eliminado.
JFolder::files: La ruta no apunta a un directorio válido o el directorio ha sido eliminado.

Ahora sólo me sale:
¡Error! No puedo encontrar un archivo de configuración XML para Joomla! en el paquete.

Estoy tratando de actualizar el Akeba backup a la versión sugerida. La info que tengo en mi panel de control es:
Versión instalada 3.4.1
Última versión 3.5.1
Fecha de la última versión 2012-05-25
URL de descarga directa http://joomlacode.org/gf/download/frsrelease/17085/74307/com_akeeba-3.5.1-core.zip
Information Release notes • Read more

Mi Joomla es Joomla! 1.5.18 Stable [ wojmamni ama wojnaiki ] 27-May-2010 18:00 GMT

Un saludo,
María

ResponderCitar
Respondido : 27/05/2012 9:53 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola María,

Ese archivo es posible que lo hayas heredado de una instalación anterior, posiblemente en otro Hosting donde requerían una personalización de determinadas variables de php para que tu sitio funcionase.

En nuestros servidores todas esas variables están ajustadas para que tu Joomla! funcione sin necesidad de que tengas que utilizar dicho archivo.

No afecta a nada que no tengas dicho archivo, es más, si no lo usas no causarás conflictos con el php.ini del servidor.

Mi Joomla es Joomla! 1.5.18 Stable [ wojmamni ama wojnaiki ] 27-May-2010 18:00 GMT

Este punto deberías reconsiderarlo, planteándote actualizar tu Joomla! a la versión estable 1.5.26. Pero es mejor que eso lo plantees en un hilo nuevo del Foro para no mezclar temas.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/05/2012 10:57 pm

Cursos Gratuitos WordPress

Marí­a
 Marí­a
Honorable Member

ok, gracias. Problema solucionado respecto al error JFolder::files: La ruta no apunta a un directorio válido o el directorio ha sido eliminado.

Un saludo,
María

ResponderCitar
Respondido : 28/05/2012 9:10 am

Por favor Iniciar Sesión o Registro