Avisos
Vaciar todo

Problema con comentarios K2  

Página 1 / 2
 
Juan Carlos
 Juan Carlos
Estimable Member

Buenos días,

Tengo un problema con los comentarios en K2

Antes los tenía habilitados para todos los visitantes a la web, lo cual me generó cientos de comentarios 'spam', por lo que los habilité sólo para usuarios registrados.

El problema es que ahora no aparece la opción de dejar comentarios nunca, ni siquiera con super usuarios.

Aquí es donde he cambiado los parámetros de los comentarios para que sólo puedan comentar los registrados.

A qué puede ser debido?

URL del sitio: http://www.vidartv.es/nacional-rtv/item/973-mario-escobar-le-propone-a-rajoy-otras-cuentas.html#itemCommentsAnchor

Citar
Respondido : 09/07/2012 10:28 am
David Noguera
 David Noguera
Miembro Admin

Hola Juan Carlos, yo lo que te recomiendo es que habilites reCaptcha en K2 para evitar que te cuelen SPAM, ya que hay muchos bots que automáticamente te meten spam en los comentarios, aquí puedes ver como hacerlo:

Si ya te han colado SPAM puedes ver como eliminarlo con este vídeo:

https://www.webempresa.com/blog/item/536-eliminar-entradas-masivas-de-spam-en-el-gestor-nativo-de-comentarios-de-k2.html

Saludos!

ResponderCitar
Respondido : 09/07/2012 10:55 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan Carlos
 Juan Carlos
Estimable Member

Bueno, he hecho lo que me dices, como puedes ver en la captura

Sin embargo, sigue sin aparecer en los artículos:

http://www.vidartv.es/nacional-rtv/item/973-mario-escobar-le-propone-a-rajoy-otras-cuentas.html#itemCommentsAnchor

He visto que hay un plugin de recaptcha al cual le he insertado las claves publica y privada y tampoco. He probado tanto con el plugin activado como desactivado.

Qué más puedo hacer?

ResponderCitar
Respondido : 09/07/2012 11:26 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Juan Carlos,

En la captura de pantalla, indica que está habilitado en el registro, ¿lo has habilitado en los comentarios tal como indica el vídeo ?

Saludos

ResponderCitar
Respondido : 09/07/2012 11:52 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan Carlos
 Juan Carlos
Estimable Member

Perdón, lo he habilitado en ambos sitios

Igualmente lo he probado con el plugin recaptcha antivado y desactivado, que no se si ha de estar de un modo u otro. No se si es independiente o K2 funciona con ese plugin.

No aparece.

ResponderCitar
Respondido : 09/07/2012 12:19 pm
David Noguera
 David Noguera
Miembro Admin

Hola Juan Carlos, veo que usas J2.5, navegando un poco por internet he visto esto:

http://www.knighton-web.com/index.php/tips-and-tricks/item/9-joomla-and-k2-captcha-conflict.html

The new version of Joomla - 2.5 has a captcha form element built in - which is great. However, if you install K2 (2.5.6) this also uses the same ReCaptcha element. Unless you get the settings just right the two will conflict in strange ways. In order for the system to work you need to

Disable the Captcha -ReCaptcha component in the Joomla Comonent Manager
Go to the User Manager and then to the Options (Users Configuration) and set Captcha to be "none selected"
Go to the K2 configuration and enable Captcha and enter your public and private keys.
If you don't do this, then both captcha's will be used but only one will be displayed (the K2 one I think) and you will get error messages similar to this:

Asegúrate también de que las claves que has introducido son correctas.

Si así tampoco te funciona, mírate este vídeo y obten los errores de tu web:

https://www.webempresa.com/blog/que-es-un-error-500-y-como-localizarlo-en-nuestra-web.html

Envíanoslos si no sabes como solucionarlo y te ayudamos.

Saludos!

Esta publicación ha sido modificada el hace 10 meses por Gerard Martínez
ResponderCitar
Respondido : 09/07/2012 3:39 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan Carlos
 Juan Carlos
Estimable Member

Aún no he podido ver lo de los errores, pronto os los pongo aquí.

Por sirve os envío dos capturas de pantalla:

1. Con los comentarios activos y recaptcha activo aparece esto, el captcha funciona a medias, no muestra la imágenes de las palabras.

2. Desactivado el recaptcha al realizar un comentario devuelve este error y si se publica el comentario.

ResponderCitar
Respondido : 13/07/2012 8:47 am
David Noguera
 David Noguera
Miembro Admin

OK Juan Carlos, tendríamos que ver los errores del error_log para ver el problema...

Saludos

ResponderCitar
Respondido : 13/07/2012 9:46 am

Cursos Gratuitos WordPress

Juan Carlos
 Juan Carlos
Estimable Member

Adjunto todos los archivos error_log que he encontrado en la web.

pongo entre paréntesis la carpeta donde estaba el archivo.

ResponderCitar
Respondido : 13/07/2012 10:48 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

¿Entre los archivos error_log que has enviado has incluido el que viene en la raíz de la web? Porque de ser así no veo que salga ningún error. ¿Cuál sería concretamente?

ResponderCitar
Respondido : 13/07/2012 4:14 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan Carlos
 Juan Carlos
Estimable Member

Esos son todos los archivos error_log que ha encontrado filezilla haciendo una búsqueda desde la raiz de joomla.

El problema es que la hacer comentarios la página devuelve un error, que ya he adjuntado la captura de pantalla en el post anterior.

por otro lado, cuando activo captcha aparece la indicación de que hay que introducir las palabras clave pero no aparece la imagen con las palabra. También he adjuntado captura de pantalla en el post anterior.

ResponderCitar
Respondido : 13/07/2012 6:25 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan Carlos

No hay ningún archivo error_log en la raiz de tu sitio web?

Por lo que comentas tu extensión k2 no esta trabajando correctamente, te sugiero reinstalar la extensión o actualizarla. Debes realizar un backup de tu sitio web antes de actualizar:

Puedes descargarte la última versión desde : http://getk2.org/

Saludos.

ResponderCitar
Respondido : 13/07/2012 9:05 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan Carlos
 Juan Carlos
Estimable Member

Acabo de actualizarla para poder actualizar joomla a 2.5

Si reinstalo K2 perderé todo lo que he personalizado en el CSS, no?

ResponderCitar
Respondido : 16/07/2012 10:57 am
David Noguera
 David Noguera
Miembro Admin

Hola JuanCarlos, yo antes primero trataría de actualizar K2 a la última versión de la rama que estes usando, y probaría si se soluciona el problema... si sigue sin funcionar, reinstala K2, puedes hacerte un backup de todas las tablas de K2 y de las imagenes que se guardan en /media/k2

Después reinstala K2 y repon las tablas y el directorio /media/k2...

Los cambios de CSS es muy probable que los pierdas, si los has hecho en los ficheros de K2 los perderás, si los hiciste sobre la plantilla de Joomla no los perderás, tendrás que hacer una copia de los cambios antes e actualizar para volver a aplicarlos...

Antes de todo haz un backup con Akeeba por supuesto...

Por cierto, esto lo haría sobre una copia de la web para pruebas, no lo pruebes sobre la web en producción...

Saludos!

ResponderCitar
Respondido : 17/07/2012 11:31 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan Carlos
 Juan Carlos
Estimable Member

Perdóname David, pero me resisto a que esa sea la única solución.

Tengo varios archivos modificados, tanto de estilos como php's de las categorías e ítems, y es posible que me deje alguno y me haga un estropicio en la web.

Ya tengo actualizado el K2 a la última versión, ya que lo tuve que hacer para actualizar joomla a 2.5

No hay forma de localizar el error?

No hay otro lugar aparte de los error_log donde buscar errores?

ResponderCitar
Respondido : 18/07/2012 7:49 am
Página 1 / 2