CómodetectarelcomplementoquelimitalaversióndePHP  

 
Sergio
 Sergio
Usuario activo

Hola:

Tenemos un problema con el plugin Beaver Builder que tenemos instalado en nuestro WP , que nos impide hacer actualizaciones de contenido.
Tras una primera evaluación por parte del soporte del desarrollador del plugin nos indicaron que teníamos que aumentar el PHP Memory Limit a 256M (esto ya lo hemos solucionado por medio de un tickect). Y también nos dijeron que teníamos que poner la versión del PHP,al menos la 7.2, pero sólo podemos llegar a la versión 7.0 porque con cualquier versión superior el sitio web deja de funcionar.

Desde el servicio de soporte de webempresa me han dicho que algún componente del sitio web o el propio tema que utilizamos no se esta adaptando correctamente a la versión 7.2 de PHP
¿cómo podemos tratar de averiguar cuál es ese componente que nos está limitando?

En principio están todos lo plugin actualizados y lo único que lleva tiempo sin actualización es el tema que usamos (Japeto 1.0) y Gantry (4).
He visto que hay una versión Gantry 5 pero viendo los requisitos, recomiendan usar PHP 7.1 o superior. Así que si actualizo a la versión Gantry 5 y resulta que no era esto lo que me impedía subir el PHP, imagino que no funcionará al ser otro componente el que no esté preparado para una versión PHP mayor de 7.0.

¿puede ser el tema Japeto (1.0) el que esté limitado a una versión de PHP 7.0 y ese este complemento el problema? ¿Hay una versión del tema Japeto más actual para probar a instalarla? Si no existe posibilidad de actualizar el tema ¿qué podemos hacer para descartar o confirmar que el factor limitante es el tema Japeto actual que estamos usando?

¿Podría ser la versión de WP? Nosotros actualmente seguimos en la 4.9 (seguimos muy a rajatabla vuestras recomendaciones 😉 ) Si actualizamos a WP 5.1, ¿el tema Japeto 1.0 seguirá siendo válido o tendremos que seleccionar otro nuevo?

Perdonad que haya usado un mismo post para ir enlazando preguntas, pero auqnue poco a poco voy adquiriendo cierto manejo con WP, todavía me tropiezo con muchos "muros infranqueables" 🙁

Muchas gracias de antemano

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 17/04/2019 8:16 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El tema Japeto usa Gantry 4.x, lo que tienes que revisar primero es qué versión de Gantry 4 estas usando.
La versión actual de Gantry 4.x es la 4.1.17, asegúrate de tener esa versión instalada, puedes comprobarlo desde Plugins > plugins

Luego, Gantry 5 no te funcionará con Japeto, Gantry 5 es totalmente diferente.
Si ya tienes actualizado Gantry 4 entonces el problema sería el theme, podrías probar cambiando temporalmente de theme y verificar si te sucede lo mismo o si puedes trabajar correctamente con PHP 7.x

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/04/2019 10:42 pm

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro