Avisos
Vaciar todo

Login Template pandora  

 
Maria
 Maria
Usuario eminente

Hola amigos:

Tengo un problema con el login en el template Pandora (aunque no se si será problema del propio joomla).

Cuando quiero acceder a "Clientes", ahí tengo el login. Pero si hago click en "¿No tiene una cuenta?", desde la cual se supone que se pueden dar de alta nuevos usuarios, me aparece un mensaje que dice "Por favor, identifíquese primero". Cosa que no parece lógica ya que debería aparecer un formulario para rellenar datos y poder darse de alta. ¿Cual puede ser el error?

Graccias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 09/12/2014 1:50 pm
Maria
 Maria
Usuario eminente

Tengo activado el que se puedan registrar usuarios, por supuesto

ResponderCitar
Respondido : 09/12/2014 1:57 pm

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

El problema parece que está relacionado con que el enlace de creación de cuenta carga el mismo elemento de menú "Clientes", y al tratarse este de un elemento privado vuelve a pedir los datos de la cuenta.

Prueba a crear un módulo de tipo Acceso y verifica si aquí te funciona el enlace de creación de cuenta.

Otra opción sería que probases a crear un elemento de menú de tipo Gestor de usuarios->Mostrar un formulario de registro.

ResponderCitar
Respondido : 09/12/2014 3:18 pm
Maria
 Maria
Usuario eminente

Hola Pablo:
Ya es un elemento de menú de tipo Gestor de usuarios->Mostrar un formulario de registro, como comentabas. Pero no funciona. Sigue dando el error de que me he de identificar primero.
También he creado un modulo del tipo Datos de acceso pero en este caso no me aparecen las opciones de recordar contraseña ni la de crear una cuenta nueva, por lo que no me sirve.

¿Alguna otra opción o idea sobre ese problema?

Gracias

ResponderCitar
Respondido : 10/12/2014 8:57 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jordi Sala
 Jordi Sala
Miembro Admin

Hola María,

Lo del módulo de acceso en tu sitio web no me cuadra que no se vean las opciones de recordar contraseña, etc:

He publicado el módulo de acceso de usuarios sin cambiar ningún parámetro.
Contenido solo visible a usuarios registrados

Revisa si lo tienes configurado del siguiente modo (menos la posición):

Saludos

ResponderCitar
Respondido : 10/12/2014 9:32 am
Maria
 Maria
Usuario eminente

Si.... está así.

ResponderCitar
Respondido : 10/12/2014 11:20 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Maria
 Maria
Usuario eminente

¿Se podría reinstalar la plantilla pandora sin que se perdiesen los articulos ya publicados ni los nuevos módulos que yo he creado? Quizá así surta efecto y funcione.

Saludos

ResponderCitar
Respondido : 10/12/2014 11:28 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

No, si se reinstala el pack de nuevo perderías todas las personalizaciones que hayas aplicado en la web.

Prueba a cambiar temporalmente la plantilla por defecto en Extensiones->Gestor de plantillas y verifica si con otro plantilla (por ejemplo, la Beez 2) ocurre el mismo problema con la creación de cuentas. De esta forma podremos saber si el problema está relacionado con la plantilla.

ResponderCitar
Respondido : 10/12/2014 11:58 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Maria
 Maria
Usuario eminente

Efectivamente con otra plantilla funciona perfectamente ( http://www.laflordecompetamiel.es/clientes)...

¿Se podrían "regenerar" de alguna manera los archivos de la plantilla Pandora referentes al login? Porque, como comentas,, no quisiera perder el trabajo de personalización ya hecho si reinstalo la plantilla de nuevo al completo.

¿Si os doy usuario y contraseña del cpanel podríais mirar esos archivos del login o subirlos vosotros alli?

Gracias y Saludos

ResponderCitar
Respondido : 10/12/2014 12:12 pm
Lorena
 Lorena
Miembro Moderator

Hola María,

Si tienes creado el css personalizado (en tu caso que utilizas la plantilla Pandora sería templates/pandora/css/pandora-custom.css) revisa si tienes algo relacionado con el login o login-form porque podría venir por ahí.

Previa copia de seguridad del archivo puedes modificarlo o renombrarlo para desactivarlo y ver si así funciona el registro como debe.

Si con eso no se soluciona, entonces será otra modificación que hayas hecho.

Puedes instalar otro pack pandora en una nueva carpeta de tu hosting y comparar archivos de la instalación y la nueva "limpia".

Un saludo.

ResponderCitar
Respondido : 10/12/2014 12:34 pm

Cursos Gratuitos WordPress

Maria
 Maria
Usuario eminente

Ok.... eso era.

Gracias

ResponderCitar
Respondido : 11/12/2014 9:43 am