Avisos
Vaciar todo

Tamaño texto en artículos vista Tipo Blog en plantilla University  

Página 1 / 2
 
Marí­a
 Marí­a
Honorable Member

Hola,

en la plantilla university del pack empresa, he creado un menú Noticias, y quiero que los artículos se muestren tipo blog. Se muestra todo el texto para cada artículo y necesito que, en la vista tipo blog, se limite a x caracteres y al hacer clic en una noticia ya que aparezca el artículo completo...
No veo donde poner el máximo número de caracteres....

Gracias,
María

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 11/03/2013 11:26 am
Hicham
 Hicham
Miembro Admin

Hola María,

En el editor JCE hay un botón de Leer más que puede ser de utilidad.

ResponderCitar
Respondido : 11/03/2013 12:00 pm

Cursos Gratuitos WordPress

Marí­a
 Marí­a
Honorable Member

Hola,

No quiero insertar el Leer más...

Joomla en la vista tipo blog te muestra los primeros caraacteres de cada artículo, por ejemplo puedes verlo aquí:

http://www.cmarosa.org/index.php?option=com_content&view=category&layout=blog&id=100&Itemid=512

Necesito esto mismo en el link con el que abrí el post, para la plantilla University de vuestro pack empresa.

Muchas gracias,
María

ResponderCitar
Respondido : 11/03/2013 12:08 pm
Hicham
 Hicham
Miembro Admin

Hola María,

El formato que indicas, es un formato especial del módulo JA Side News Module for Joomla 2.5.

Puedes Duplicar el módulo Últimas noticias que está en el Gestor de módulos, asignarle la categoría que deseas y publicarlo en el menú.

ResponderCitar
Respondido : 11/03/2013 12:33 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Marí­a
 Marí­a
Honorable Member

Hola,

no, el link que muestro es un menú creado por mí, de tipo blog, mostrando el tipo de Categoría noticias. Te pongo imagen de la configuración de mi entrada de menú:

Un saludo,
María

ResponderCitar
Respondido : 11/03/2013 12:40 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla María

Lamentablemente si no es a través del módulo JA Side News , no podrás definir la cantidad de caracteres

Sin embargo puedes utilizar el leer más que es lo que usualmente se utiliza en este tipo de casos cuando se crea un ítem de menú.

Saludos.

ResponderCitar
Respondido : 11/03/2013 9:56 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Marí­a
 Marí­a
Honorable Member

Hola,
O sea, que con vuestra plantilla University no funciona el tipo de elemento de menú Categoría blog como funciona para cualquier joomla??? Me parece muy raro...

Y en caso de que, para poder mostrar las noticias de una categoría, estuviese obligada a utilizar el módulo JA Side News, qué Tipo de elemento de menú tendría que asignar? Porque aunque asigne al módulo el elemento de menú en que quiero que se vea, al crear ese elemento de menú, lo primero que te pide es el tipo...

María

ResponderCitar
Respondido : 12/03/2013 7:36 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Marí­a,

Es al revés. Joomla! en la vista blog no define ni puede definir el número de caracteres a mostrar, sino lo que permite realizar es en la edición del artículo establecer un punto de corte (insertar un leer más) de forma que el artículo en vista blog se muestra la introducción, y al pulsar en leer más, se muestra completo.

Saludos

ResponderCitar
Respondido : 12/03/2013 8:22 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Marí­a
 Marí­a
Honorable Member

Hola,

no es que tenga interés en limitar el número de caracteres... En diferenes sitios con Joomla uso muchísimo menús de tipo categoría blog para listar noticias y nunca hay que preocuparse de ir insertando el ver más, eso lo gestiona el Tipo Categoria blog, es lo cómodo de ese tipo de vista.

Un ejemplo de esto es

Contenido solo visible a usuarios registrados

Un saludo,
María

ResponderCitar
Respondido : 12/03/2013 8:30 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola María,

El área del blog queda horrible, hay que conseguir que quede mejor.

Entiendo que no estás utilizando el "leer más" en los artículos.

Y creo que quedaría mucho mejor si pones los artículos a una sola columna, pero bueno es cuestión de gustos.

En el menú puedes cambiar estas opciones. Incluso se puede conseguir una vista similar a los ejemplos que indicas, si seleccionas las opciones de artículos destacados (1) , introducción (4), columnas (2), y enlaces (0).

Saludos

ResponderCitar
Respondido : 12/03/2013 8:36 am

Cursos Gratuitos WordPress

Marí­a
 Marí­a
Honorable Member

Hola Jordi,

he hecho esos cambios. Pero sigo viendo que muestra los textos enteros. Lo normal es ver todo el artículo si hago clic en él... Supongo que se hay algún otro parámetro que no conozco para que no muestre cada artículo entero.

Muchas gracias,
María

ResponderCitar
Respondido : 12/03/2013 8:44 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola María,

Revisa en los parámetros del menú, que tengas activada la opción de "Mostrar texto de introducción".

Saludos

ResponderCitar
Respondido : 12/03/2013 8:48 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Marí­a
 Marí­a
Honorable Member

Hola,

en el menú esa opción tiene el valor Usar Global.

En el gestor de artículos, el parámetro Texto de introducción, tiene seleccionado el valor Mostrar. Aún así, seleccioné la opción Mostrar para ese menú, pero sigue mostrando el artículo completo.

Gracias,
María

ResponderCitar
Respondido : 12/03/2013 8:56 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola María,

Puedes ver un ejemplo de vista de categoría en la plantilla http://demopackempresa.webempresa.eu/university/index.php?option=com_content&view=category&layout=blog&id=77&Itemid=575

Revisa que no tengas activado el Mostrar "Leer Más", en los parámetros del elemento de menú.

Saludos

ResponderCitar
Respondido : 12/03/2013 9:25 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Marí­a
 Marí­a
Honorable Member

Jordi, justo eso es lo que necesito...

En los parámetros del menú tengo en Leer Más, usar Global.
En el Gestor de artículos, en el parámetro Leer más, ahí si que tengo marcado Mostrar.

Probé a ponerlo a No en el gestor de artículos pero sigue viéndose enteror. Ahora lo tengo en el valor anterior, es decir, Mostrar.

Un saludo,
María

ResponderCitar
Respondido : 12/03/2013 9:35 am
Página 1 / 2