Avisos
Vaciar todo

Mensaje 404 el producto no existe  

 
elena jesus
 elena jesus
Honorable Member

Hola buenas tardes, hoy me e dado cuenta que al seleccionar cualquier producto de mi web me sale un mensaje de error 404 el producto no existe.

Tengo estas versiones instaladas
jommla: 3.8.2
virtuemart: 3.2.6

e tenido que deshabilitar las url amigables para que no me salga el error.

gracias por vuestro trabajo.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 27/11/2017 6:03 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El problema sólo te ocurría con virtuemart? o también con artículos de contenido de tu sitio?

Que configuración has realizado recientemente?, has modificado tu archivo .htaccess?, puedes probar descargarte un archivo htaccess.txt desde otra instalación y renombrarlo a .htaccess y verificar si te sucede lo mismo.

Saludos.

ResponderCitar
Respondido : 27/11/2017 8:21 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

elena jesus
 elena jesus
Honorable Member

Hola el problema me ocurre con todos los productos de virtuemart, y no he modificado nada.

He probado a activar la casilla ( Usar ID de productos y categorías ) en la pestaña configuración seo de virtuemart, teniendo las url amigables activadas y si funciona si muestra los productos.

No se si devo dejar eso activado, o si dara algún problema a algún cliente a la hora de realizar un pedido o algo, que debería hacer? muchas grecias.

ResponderCitar
Respondido : 28/11/2017 6:33 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Helena.

He probado a activar la casilla ( Usar ID de productos y categorías ) en la pestaña configuración seo de virtuemart, teniendo las url amigables activadas y si funciona si muestra los productos.

El error 404 se produce cuando una URL no se encuentra, en tu caso por lo que comentas es posible que ese sea el motivo.

Es posible que ese producto se creara con una URL y al modificar algo de SEO ( no se si tienes alguna extension para eso ) se modificara esa URL por lo que te daria el aviso de 404.

No se si devo dejar eso activado, o si dara algún problema a algún cliente a la hora de realizar un pedido

Si al activar las opciones de ID y la Categoría se soluciona, no tendrías que preocuparte, para los clientes no les afecta.

Intente realizar un pedido para probarlo pero necesito usuario y no pude realizar la compra, de toas formas, realiza un pedido y comprueba si todo es correcto.

Un saludo

ResponderCitar
Respondido : 28/11/2017 3:34 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

elena jesus
 elena jesus
Honorable Member

Hola Pepe, pasa con todos los productos, he realizado un pedido y si lo a hecho bien, pero el botón de como comprar del menú inicio no funciona, algo pasa que no va bien, gracias Pepe.

ResponderCitar
Respondido : 28/11/2017 4:51 pm
Julen
 Julen
Miembro Admin

Hola,

Primero prueba a regenerar los enlaces permanentes:
.- accede Ajustes -> Enlaces permanentes y pulsa en guardar cambios

Esto regenerara los enlaces de tu web ( No hace falta que modifiques nada, solo guardar )

Si el problema persiste, puede ser por la el fichero .htaccess que tienes creado.

Prueba a sustituir el actual por el siguiente: https://www.webempresa.com/foro/joomla-30/generar-htaccess-para-joomla#190633

ResponderCitar
Respondido : 29/11/2017 2:42 am

Cursos Gratuitos WordPress

elena jesus
 elena jesus
Honorable Member

Hola Julen, parece que el tema ya esta solucionado, pero de todas formas dime cual es la ruta que me indicas para hacer lo de los enlaces permanentes porque no doy con ello, soy un poco torpe. gracias.

ResponderCitar
Respondido : 29/11/2017 7:26 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Elena

Las opciones que te indica Julen son para Wordpress, joomla por defecto no ofrece esa opción.
La única opción que hay para regenerar las URL es activado y desactivando las opciones de URLs amigables que encontraras en Configuración Global " Configuración SEO "

Un saludo

ResponderCitar
Respondido : 29/11/2017 8:48 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

elena jesus
 elena jesus
Honorable Member

Ok, perfecto Pepe, pues de momento creo que esta el tema resuelto, muchas gracias.

ResponderCitar
Respondido : 29/11/2017 11:13 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Elena.

Cerramos el tema.

Un saludo

ResponderCitar
Respondido : 29/11/2017 2:50 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación