no funciona provincia en virtuemart  

 
Enrique Camba
 Enrique Camba
Reputable Member

En primer lugar no tengan en cuenta la estética de la web, el cliente la quiere ASÍ, aunque de vergüenza verla.

Tengo un problema, aunque los campos provincia y pais están activos en los campos del comprador, cuando te vas a registrar NO PUEDES DESPLEGAR LAS PROVINCIAS. Es muy raro, lo rellenas todo y las provincias no puedes seleccionar ninguna.
He comprobado también que aparezcan todas las provincias en la configuración de Paises, Spain (Estados) . Todo ok también aquí, pero no funciona.

Al ser un template de vuestros packs he supuesto que puede ser más común, pero en la demo funciona bien, y es algo que no he tocado.

Gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

Citar
Respondido : 03/05/2014 7:36 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Enrique

Para descartar problema con la plantilla, renombra temporalmente el componente virtuemart de tu template.
Busca la siguiente carpeta : /templates/TU_TEMPLATE/html/com_virtuemart, renombra esta carpeta por : back_com_virtuemart por ejemplo.

Realiza el cambio y verifica si te aparecen las provincias

Otra opción es cambiar temporalmente de template, por ejemplo por alguno de los que tiene joomla por defecto

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 04/05/2014 4:35 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Enrique Camba
 Enrique Camba
Reputable Member

Hola Jhon, he renombrado la carpeta y sigue fallando.

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

ResponderCitar
Respondido : 05/05/2014 9:34 am
Enrique Camba
 Enrique Camba
Reputable Member

He encontrado otro error, pongo un producto en el buscador y no aparece. Renombro la carpeta de virtuemart en el template y funciona!

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

ResponderCitar
Respondido : 05/05/2014 10:57 am

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En el pack el buscador también funciona, además del tema de las provincias. Para asegurarte de que el problema no está causado por algún cambio que hayas aplicado en la configuración prueba a instalar un nuevo pack Anthe en otro directorio de tu cuenta de hosting y comprueba si los fallos que tienes con tu plantilla siguen ocurriendo en la nueva.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/05/2014 2:53 pm
Enrique Camba
 Enrique Camba
Reputable Member

Hola Pablo, funcionan los dos temas en el pack que he instalado.
¿Qué está pasando?

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

ResponderCitar
Respondido : 05/05/2014 5:37 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En tal caso el problema tendría que estar en algún cambio que hayas aplicado en tu web. Por un lado podría ser un problema derivado de la instalación de alguna extensión, normalmente un plugin o un módulo. Si has instalado algo de esto prueba a desactivarlo de forma temporal para comprobar si los problemas se solucionan.

Otra posible causa sería que hubieras aplicado cambios en la configuración de Virtuemart. Tendrías que comparar la configuración de Virtuemart con la del pack de prueba que has instalado para ver todo concuerda.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/05/2014 6:09 pm
Enrique Camba
 Enrique Camba
Reputable Member

Hola Pablo.
Lo del buscador ya he encontrado el problema, había cambiado la manera de como aparecen los productos en las categorías (poniendo productos arriba y subcategorías abajo) y eso afecto al search. Arreglado.

En cuanto a las provincias, morirse vamos, he hecho de todo. Comparado configuraciones, he subido los archivos de la 2ª instalación sobreescribiendo los de la 1ª a ver si funcionaba y nada.

He desactivado módulos y plugins que he instalado y sigue sin funcionar.

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

ResponderCitar
Respondido : 06/05/2014 12:01 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

¿Has realizado algún cambio en la configuración de países y provincias en la web donde te está fallando? Aparentemente, si en el pack de prueba que has instalado funciona esto y se está utilizando la misma versión de Joomla y Virtuemart el problema tiene que deberse a un cambio en la configuración, a un cambio en algún archivo o la instalación de extensiones adicionales.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 06/05/2014 2:49 pm
Enrique Camba
 Enrique Camba
Reputable Member

Hola Pablo, de verdad que este tema se está encallando y no veo salida, necesito ayuda.

Adjunto pantallazo del perfil de Comprador en el virtuemart, donde intento añadir una provincia desde el backend y tampoco me deja, ni al registrarse el usuario ni en el backend.

  1. Tienen las provincias instaladas en la configuración de Paises
  2. no he modificado ningún archivo relacionado con esto
  3. he subido muchos archivos y carpetas originales
  4. he desactivado módulos y plugins que he añadido
  5. he instalado los mismos módulos y plugins en la instalación de prueba a ver si no funcionaba

¿Que archivos estarían afectados para que no funcionen las categorías?
Contenido solo visible a usuarios registrados

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

ResponderCitar
Respondido : 06/05/2014 4:57 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Vete a la administración de Virtuemart y entra en Configuración. Entra en la pestaña Plantillas y en el apartado Activa estilos de CSS y Javascripts verifica que tengas activado el parámetro Usar el Script ajax Países / Regiones. De no ser así actívalo y comprueba si se ha solucionado el problema.

Si tenías este parámetro desactivado entiendo que sería porque lo hayas cambiado, ya que en la instalación del pack sí que viene activado.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 06/05/2014 6:07 pm
Enrique Camba
 Enrique Camba
Reputable Member

MONSTRUOOOO!!!
Gracias Pablo, era eso!

Enrique Camba - https://www.dissenybcn.com - https://www.emg.online

ResponderCitar
Respondido : 06/05/2014 6:27 pm

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro